Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Virtual console shortcut keys don't respond in xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
knifeyspoony
n00b
n00b


Joined: 01 Jun 2005
Posts: 70

PostPosted: Sun Oct 01, 2006 9:39 pm    Post subject: Virtual console shortcut keys don't respond in xorg Reply with quote

Hi,

I updated many of my system's packages yesterady. Since then, my virtual console shorcuts, CTRL-Shift-Fn, no longer do anything when I'm in an X session. They still work when I do a console login and don't load X. I have

  • kdebase 3.5.2-r2 (haven't tried a different desktop environment yet, but I had been using this KDE for a while before the issue arose)
  • xorg-x11 7.0-r1
  • xorg-server 1.0.2-r7
  • ati-drivers 8.28.8


I've searched the forums for this problem, and the solutions mentioned don't seem to apply to me. One post says upgrading the kernel fixed it, but since my shortcut keys still work outside of X, I don't think it's a kernel issue. Another mentions a problematic "no VC key" switch in xorg.conf, but my xorg.conf doesn't have that line. Magickeys do work, but I'd like to get my normal shortcuts back.

Thanks!
Back to top
View user's profile Send private message
hothead
Apprentice
Apprentice


Joined: 02 Jul 2004
Posts: 277
Location: /dev/core

PostPosted: Sun Oct 01, 2006 9:51 pm    Post subject: Reply with quote

Quote:
Another mentions a problematic "no VC key" switch in xorg.conf, but my xorg.conf doesn't have that line.


So you definitely don't have
Code:
Option      "DontVTSwitch" "true"

in your xorg.conf?

This is the only option I know that blocks the vt-switch shortcuts.

But maybe your keyboard layout is crapped.
Try to run 'xev' and press down the FN keys to check if they're mapped correctly.
_________________
Got a question? - http://justfuckinggoogleit.com/
Back to top
View user's profile Send private message
knifeyspoony
n00b
n00b


Joined: 01 Jun 2005
Posts: 70

PostPosted: Sun Oct 01, 2006 9:56 pm    Post subject: Reply with quote

Code:
bizarro / # grep -i VTSwitch /etc/X11/xorg.conf || echo 'Nope!'
Nope!


Seems CTRL, Shift, and F1 are each mapped correctly. Together they seem to produce F13, if I'm reading xev correctly. Is that normal?

Code:
KeyPress event, serial 31, synthetic NO, window 0x1c00001,
    root 0x3e, subw 0x0, time 98922170, (57,-11), root:(1119,321),
    state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyPress event, serial 31, synthetic NO, window 0x1c00001,
    root 0x3e, subw 0x0, time 98922754, (57,-11), root:(1119,321),
    state 0x4, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

FocusOut event, serial 31, synthetic NO, window 0x1c00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 31, synthetic NO, window 0x1c00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 31, synthetic NO, window 0x0,
    keys:  2   0   0   0   32  0   4   0   8   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

KeyRelease event, serial 31, synthetic NO, window 0x1c00001,
    root 0x3e, subw 0x0, time 98924162, (57,-11), root:(1119,321),
    state 0x5, keycode 67 (keysym 0xffca, F13), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False
Back to top
View user's profile Send private message
knifeyspoony
n00b
n00b


Joined: 01 Jun 2005
Posts: 70

PostPosted: Fri Oct 06, 2006 6:43 am    Post subject: Reply with quote

Anyone?
Back to top
View user's profile Send private message
stenius
n00b
n00b


Joined: 26 Jan 2005
Posts: 42
Location: .us

PostPosted: Sat Jan 06, 2007 10:45 pm    Post subject: Reply with quote

try useing ctl alt f#. iam am having a similar problem
Back to top
View user's profile Send private message
knifeyspoony
n00b
n00b


Joined: 01 Jun 2005
Posts: 70

PostPosted: Sun Jan 07, 2007 2:40 am    Post subject: Reply with quote

Eh, well, thanks, but I hosed my Gentoo system in a big way, so I ended up reinstalling. After I reinstalled, the problem was no longer present.
Back to top
View user's profile Send private message
stenius
n00b
n00b


Joined: 26 Jan 2005
Posts: 42
Location: .us

PostPosted: Sun Jan 07, 2007 6:53 pm    Post subject: Reply with quote

i was having the same problem until i reenabled "xkb options" in the kde control center
Back to top
View user's profile Send private message
tijara
n00b
n00b


Joined: 04 Feb 2007
Posts: 8

PostPosted: Sat Feb 10, 2007 6:07 pm    Post subject: Reply with quote

I had to look at a dozen posts to find a solution to the
"CTRL-ALT-Fn doesn't bring up a console" problem, so I
thought I'd summarize the possible solutions in one post.
Thanks to all who responded....

Problem: CTRL+ALT+F[1-7] doesn't switch virtual consoles.
Details: X is running and the graphical desktop is
working, but you cannot switch to a text-based
console using CTRL+ALT+F1.

Open an xterm and enter "chvt 1" --you may need to
be root to do this. If you still don't get a
virtual console, agetty may not be running. See
Solution 1.
If you are running Gnome: open an xterm and try
CTRL+ALT+F1 and then CTRL+ALT+F2. If you see the
letters "PQ" then try Solution 4.


Solution 1: See if agetty is running
Your /etc/inittab should have at least one line like this:

c1:12345:respawn:/sbin/agetty 38400 tty1 linux

meaning that agetty should be run whenever runlevel
1,2,3,4 or 5 is started, and that agetty
should be restarted (respawn) if it (agetty) terminates.
See man agetty and man inittab.
To make sure agetty is running, open an xterm and run

ps -A | grep agetty


Solution 2: Check your X config file:
Edit /etc/X11/xorg.conf and look at the Section that
describes your keyboard. Mine looks like this:
Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"

EndSection

If your xorg.conf has a line like

Option "XkbVariant" "nodeadkeys"

try commenting it out and re-starting X.
One poster claimed that removing the line:
Option "XkbLayout" "us"
worked. Also, search the file for a line:
Option "DontVTSwitch" "true"
Which would appear to block you from switching
Virtual Terminals. (I can't find documentation
on this option.)


Solution 3: Try setting the X keyboard map with setxkbmap
(I can't tell you much this one-- on my machine, I
just got the error "Error loading new keyboard desc."
But some posters claimed it fixed their problem.) Run
setxkbmap us
This will break native language support for non-US
keyboards.

Solution 4. If you are running Gnome, try setting keyboard
properties using gnome-keyboard-properties (or click
Desktop->Preferences->Keyboard). Select the
"Layout options" tab. Under "Miscellaneous Keyboard
Options" the box
"Special keys (CTRL+ALT+<key>) handled in a server"
should NOT be checked. You might also verify that
the keyboard model matches the one you are using:
Click the "Layouts" tab and that should show you the
keyboard model.
(I'm running Gnome version 2.14.2. Older versions
of gnome-keyboard-properties may not have the
options described here. I'm sure KDE has something
similar and certainly worth looking into.)
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Feb 17, 2007 4:26 am    Post subject: Reply with quote

I found the solution of this problem on FreeBSD forum.
Thanks to that guys!

Put this into your xorg.conf:

Code:
Section "ServerFlags"

Option "DontVTSwitch" "false"
Option "HandleSpecialKeys" "Always"

Option "DontZap" "false"
Option "AllowMouseOpenFail" "true"

Option "XkbDisable" "true"

EndSection


That solved the problem for me.
_________________
Lefsha
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Feb 17, 2007 3:14 pm    Post subject: Reply with quote

Sorry. Actually it is not a solution.
I've got back Ctrl+Alt+F# functionality but I lost possibility to switch between
2 or more keyboard layouts - international support. Because of this option:
Code:
Option "XkbDisable" "true"

Without this option Ctrl+Alt+F# doesn't work.

Do I have file the bug about it?

I don't really understand whether it's a xorg or kde bug.
_________________
Lefsha
Back to top
View user's profile Send private message
rpodgorny
n00b
n00b


Joined: 02 Apr 2003
Posts: 56
Location: Praha, Czech Republic, Europe, Earth

PostPosted: Sat Apr 21, 2007 9:50 am    Post subject: Reply with quote

Found out the same "solution". Either disable Xkb or set only one map (ie. "us" instead of "us,cz")...

No idea how to make it work with multiple layouts... :-(
Back to top
View user's profile Send private message
monsieur-flibbel
n00b
n00b


Joined: 23 Apr 2007
Posts: 1

PostPosted: Mon Apr 23, 2007 3:43 am    Post subject: Option 2 of tijara's post worked for me.. Reply with quote

Quote:
Solution 2: Check your X config file:
Edit /etc/X11/xorg.conf and look at the Section that
describes your keyboard. Mine looks like this:
Section "InputDevice"

Identifier "Keyboard0"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"


EndSection


You rock...was searching for hours

flibbel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum