Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200609-14 ] ImageMagick: Multiple Vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1689

PostPosted: Tue Sep 26, 2006 5:26 pm    Post subject: [ GLSA 200609-14 ] ImageMagick: Multiple Vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: ImageMagick: Multiple Vulnerabilities (GLSA 200609-14)
Severity: normal
Exploitable: remote
Date: September 26, 2006
Bug(s): #144091, #143533
ID: 200609-14

Synopsis


Multiple buffer overflows have been discovered in ImageMagick, which could
potentially result in the execution of arbitrary code.


Background


ImageMagick is a free software suite to manipulate, convert, and create
many image formats.


Affected Packages

Package: media-gfx/imagemagick
Vulnerable: < 6.2.9.5
Unaffected: >= 6.2.9.5
Architectures: All supported architectures


Description


Tavis Ormandy of the Google Security Team discovered a stack and heap
buffer overflow in the GIMP XCF Image decoder and multiple heap and
integer overflows in the SUN bitmap decoder. Damian Put discovered a
heap overflow in the SGI image decoder.


Impact


An attacker may be able to create a specially crafted image that, when
processed with ImageMagick, executes arbitrary code with the privileges
of the executing user.


Workaround


There is no known workaround at this time.


Resolution


All ImageMagick users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=media-gfx/imagemagick-6.2.9.5"


References

CVE-2006-3743
CVE-2006-3744
CVE-2006-4144


Last edited by GLSA on Tue Mar 18, 2014 4:23 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum