Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird emerge error: OSError: [Errno 16] Device or resource b
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
g3n
Guru
Guru


Joined: 13 Dec 2003
Posts: 543
Location: México

PostPosted: Thu Sep 21, 2006 1:35 pm    Post subject: Weird emerge error: OSError: [Errno 16] Device or resource b Reply with quote

i left my computer doing a emerge --sync and a emerge -u wolrd yesterday, and i saw this message when i woke up this morning:
Quote:
xgl ~ # emerge -p world


Performing Global Updates: /usr/portage/profiles/updates/2Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
........................................


Performing Global Updates: /usr/portage/profiles/updates/3Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
.........
pppTraceback (most recent call last):
File "/usr/bin/emerge", line 4049, in ?
emerge_main()
File "/usr/bin/emerge", line 3770, in emerge_main
portage.global_updates(settings, trees, mtimedb["updates"])
File "/usr/lib/portage/pym/portage.py", line 6645, in global_updates
myupd)
File "/usr/lib/portage/pym/portage_update.py", line 198, in update_config_files
write_atomic(updating_file, "".join(file_contents[x]))
File "/usr/lib/portage/pym/portage_util.py", line 728, in write_atomic
f.close()
File "/usr/lib/portage/pym/portage_util.py", line 696, in close
os.rename(self.name, self._real_name)
OSError: [Errno 16] Device or resource busy
xgl ~ #


What does it means and how can i fix it?

I can't use emerge --sync or any other kind of emerge.
this is the content of the file that fails to update:
Code:
move sys-apps/hwdata sys-apps/hwdata-gentoo
move x11-misc/linuxwacom x11-drivers/linuxwacom
move app-misc/enotes x11-misc/enotes
slotmove =virtual/gnat-4.1 3.4 4.1
move app-text/ipcalc net-misc/ipcalc
move www-client/kazehakase-cvs www-client/kazehakase
slotmove =dev-java/diablo-jdk-1.5* 0 1.5
slotmove =dev-java/diablo-jre-bin-1.5* 0 1.5
move net-im/openmcu net-voip/openmcu

_________________
--[G]--
Back to top
View user's profile Send private message
g3n
Guru
Guru


Joined: 13 Dec 2003
Posts: 543
Location: México

PostPosted: Thu Sep 21, 2006 4:22 pm    Post subject: Reply with quote

i've just found the fix for that bug:[url]
https://bugs.gentoo.org/show_bug.cgi?id=147010[/url]
_________________
--[G]--
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Sat Oct 28, 2006 9:43 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic: portage fails - errno 16 Device or resource busy.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum