Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] could not emerge world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Beju
Apprentice
Apprentice


Joined: 30 Mar 2006
Posts: 171

PostPosted: Tue Sep 19, 2006 4:40 pm    Post subject: [SOLVED] could not emerge world Reply with quote

My emerge -Duv world stopped on wireshark because of the perl "minimal" flag. I've searched this forum and found that I should make emerge --sync to get fixed wireshark ebuild. After doing that and emerging a new portage, running emerge -Duv world causes this error:
Code:
Calculating world dependencies \
!!! All ebuilds that could satisfy "media-video/nvidia-glx" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-video/nvidia-glx-1.0.8756 (masked by: package.mask)
# Chris Gianelloni <wolf31o2@gentoo.org> (12 Sep 2006)
# These are being removed in favor of the x11-drivers/nvidia-drivers and
# x11-drivers/nvidia-legacy-drivers.  There should be no reason why you are
# still using these drivers.  Everyone should migrate to the new driver set.
# This is masked for removal and will be removed on Septermber 29th.

- media-video/nvidia-glx-1.0.7676-r3 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.6629-r7 (masked by: package.mask)
- media-video/nvidia-glx-1.0.7667-r1 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7174-r5 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8762 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7167-r3 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8178-r1 (masked by: package.mask)
- media-video/nvidia-glx-1.0.6111-r3 (masked by: package.mask)
- media-video/nvidia-glx-1.0.8174-r2 (masked by: package.mask, ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "media-libs/glitz-0.4.4" [ebuild])


I don't even know what this "glitz" is :) but it seems that it wants the old nvidia drivers. Could someone tell me what's going on?


Last edited by Beju on Wed Sep 20, 2006 10:23 am; edited 1 time in total
Back to top
View user's profile Send private message
slotik
n00b
n00b


Joined: 04 Sep 2006
Posts: 20

PostPosted: Tue Sep 19, 2006 5:33 pm    Post subject: Reply with quote

You could try to unmask the old drivers and do "emerge -avuDNt world" to find out what brings in the glitz package. If you need that on your system, you can try to mask the old driver again and unmask a new version of glitz...
Back to top
View user's profile Send private message
Beju
Apprentice
Apprentice


Joined: 30 Mar 2006
Posts: 171

PostPosted: Wed Sep 20, 2006 10:22 am    Post subject: Reply with quote

Hmm I dont know how but switching to new kernel solved it.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4838
Location: Gothenburg, Sweden

PostPosted: Tue Oct 24, 2006 8:20 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 498027.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum