Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
databusx
n00b
n00b


Joined: 31 Mar 2006
Posts: 27

PostPosted: Mon Sep 18, 2006 8:51 pm    Post subject: portage problem Reply with quote

Hi !

i have a problem with my portage , when i make emerge --update world give me this :

Calculating world dependencies -
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
media-video/nvidia-glx virtual/opengl
... done!
>>> Auto-cleaning packages...

How can it happen? i dont use nvidia and is not on my make.conf . I have tried download a new portage and extract but the problem continues.

if i do a emerge -Du world :

Calculating world dependencies \
!!! All ebuilds that could satisfy "media-video/nvidia-glx" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-video/nvidia-glx-1.0.8756 (masked by: package.mask)
# Chris Gianelloni <wolf31o2@gentoo.org> (12 Sep 2006)
# These are being removed in favor of the x11-drivers/nvidia-drivers and
# x11-drivers/nvidia-legacy-drivers. There should be no reason why you are
# still using these drivers. Everyone should migrate to the new driver set.
# This is masked for removal and will be removed on Septermber 29th.

- media-video/nvidia-glx-1.0.7676-r3 (masked by: package.mask, package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.6629-r7 (masked by: package.mask)
- media-video/nvidia-glx-1.0.7667-r1 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7174-r5 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8762 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7167-r3 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8178-r1 (masked by: package.mask)
- media-video/nvidia-glx-1.0.6111-r3 (masked by: package.mask)
- media-video/nvidia-glx-1.0.8174-r2 (masked by: package.mask, ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-libs/qt-3.3.6-r1" [ebuild])



!!! Problem resolving dependencies for kde-base/kde
!!! Depgraph creation failed.


i dont use nvidia :? ... any help are welcome !

Regards!
Back to top
View user's profile Send private message
slotik
n00b
n00b


Joined: 04 Sep 2006
Posts: 20

PostPosted: Mon Sep 18, 2006 8:58 pm    Post subject: Reply with quote

Try to run

Code:

equery d media-video/nvidia-glx


to find out what packages depend on that one...
Back to top
View user's profile Send private message
databusx
n00b
n00b


Joined: 31 Mar 2006
Posts: 27

PostPosted: Mon Sep 18, 2006 9:03 pm    Post subject: Reply with quote

thanks for help-me but :

[ Searching for packages depending on media-video/nvidia-glx... ]
and nothing else. :(
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Sep 18, 2006 9:15 pm    Post subject: Reply with quote

Try the usual command:
Code:
emerge --pretend --tree --verbose --update --newuse --deep world
Back to top
View user's profile Send private message
databusx
n00b
n00b


Joined: 31 Mar 2006
Posts: 27

PostPosted: Mon Sep 18, 2006 9:20 pm    Post subject: Reply with quote

thanks m8!

but no luck.

emerge --pretend --tree --verbose --update --newuse --deep world

These are the packages that would be merged, in reverse order:

Calculating world dependencies /
!!! All ebuilds that could satisfy "media-video/nvidia-glx" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-video/nvidia-glx-1.0.8756 (masked by: package.mask)
# Chris Gianelloni <wolf31o2@gentoo.org> (12 Sep 2006)
# These are being removed in favor of the x11-drivers/nvidia-drivers and
# x11-drivers/nvidia-legacy-drivers. There should be no reason why you are
# still using these drivers. Everyone should migrate to the new driver set.
# This is masked for removal and will be removed on Septermber 29th.

- media-video/nvidia-glx-1.0.7676-r3 (masked by: package.mask, package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.6629-r7 (masked by: package.mask)
- media-video/nvidia-glx-1.0.7667-r1 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7174-r5 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8762 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7167-r3 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8178-r1 (masked by: package.mask)
- media-video/nvidia-glx-1.0.6111-r3 (masked by: package.mask)
- media-video/nvidia-glx-1.0.8174-r2 (masked by: package.mask, ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "kde-base/kdenetwork-3.5.2" [ebuild])



!!! Problem resolving dependencies for kde-base/kde
!!! Depgraph creation failed.
Back to top
View user's profile Send private message
slotik
n00b
n00b


Joined: 04 Sep 2006
Posts: 20

PostPosted: Mon Sep 18, 2006 10:04 pm    Post subject: Reply with quote

all right... so try to temporarily unmask the package:

Code:

echo "media-video/nvidia-glx" >> /etc/portage/package.unmask


and see the result of emerge -pvuDNt world... now you should finally see what package brings in the dependency...
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Mon Sep 18, 2006 10:49 pm    Post subject: Reply with quote

Just check to see if you have nvidia-kernel or nvidia-glx installed. If you only have portage as a tool
Code:
emerge -pC nvidia-glx nvidia-kernel
Then if either package is installed you will need to uninstall them and do one of the following.
  • Use the nv driver in xorg
  • Use the new system to install nvidia's binary driver
  • Install the nvidia binary from the nvidia installer
If you pick one of the last 2 items, you will have accelerated graphics. If you pick the 1st item you will not have accelerated graphics.

PS:
You will need to stop xdm and work from console for much of this.
Back to top
View user's profile Send private message
tabanus
Guru
Guru


Joined: 11 Jun 2004
Posts: 580
Location: UK

PostPosted: Mon Sep 18, 2006 11:46 pm    Post subject: Reply with quote

You don't use nvidia but kde wants to install it? Which video card to you have? Please post the output of the following commands:

Code:
# eselect opengl show


Code:
# emerge --info

_________________
Never underestimate a hamster.
Back to top
View user's profile Send private message
databusx
n00b
n00b


Joined: 31 Mar 2006
Posts: 27

PostPosted: Tue Sep 19, 2006 7:11 pm    Post subject: Reply with quote

Hi..thanks for try to help-me.

sorry guys but i had nvidia installed...i dont know how... :(

Solved! my mistake!

Thanks again for your help!
Back to top
View user's profile Send private message
databusx
n00b
n00b


Joined: 31 Mar 2006
Posts: 27

PostPosted: Tue Sep 19, 2006 9:22 pm    Post subject: Re: portage problem - solved Reply with quote

databusx wrote:
Hi !

i have a problem with my portage , when i make emerge --update world give me this :

Calculating world dependencies -
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
media-video/nvidia-glx virtual/opengl
... done!
>>> Auto-cleaning packages...

How can it happen? i dont use nvidia and is not on my make.conf . I have tried download a new portage and extract but the problem continues.

if i do a emerge -Du world :

Calculating world dependencies \
!!! All ebuilds that could satisfy "media-video/nvidia-glx" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-video/nvidia-glx-1.0.8756 (masked by: package.mask)
# Chris Gianelloni <wolf31o2@gentoo.org> (12 Sep 2006)
# These are being removed in favor of the x11-drivers/nvidia-drivers and
# x11-drivers/nvidia-legacy-drivers. There should be no reason why you are
# still using these drivers. Everyone should migrate to the new driver set.
# This is masked for removal and will be removed on Septermber 29th.

- media-video/nvidia-glx-1.0.7676-r3 (masked by: package.mask, package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.6629-r7 (masked by: package.mask)
- media-video/nvidia-glx-1.0.7667-r1 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7174-r5 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8762 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.7167-r3 (masked by: package.mask, ~amd64 keyword)
- media-video/nvidia-glx-1.0.8178-r1 (masked by: package.mask)
- media-video/nvidia-glx-1.0.6111-r3 (masked by: package.mask)
- media-video/nvidia-glx-1.0.8174-r2 (masked by: package.mask, ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-libs/qt-3.3.6-r1" [ebuild])



!!! Problem resolving dependencies for kde-base/kde
!!! Depgraph creation failed.


i dont use nvidia :? ... any help are welcome !

Regards!
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Oct 24, 2006 8:22 pm    Post subject: Reply with quote

Moved from Gentoo on AMD64 to Duplicate Threads in favour of topic 498027.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum