Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mc doesnt shows lines
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rogerdv
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 185
Location: Santiago, Cuba

PostPosted: Sat Sep 16, 2006 2:18 pm    Post subject: mc doesnt shows lines Reply with quote

I have emerged mc and it looks ugly, no vertical or horizontal line characters are displyed, just spaces. I had a similar problem with another gentoo installation, can somebody please tell me the correct configuration and parameters to emerge a better looking mc?
_________________
Game programming news for newbies | The Ark, making an RPG the right way!
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1293
Location: Netherlands

PostPosted: Sat Sep 16, 2006 2:31 pm    Post subject: Reply with quote

Just emerge mc with the slang use-flag enabled ...

HTH
swimmer
Back to top
View user's profile Send private message
rogerdv
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 185
Location: Santiago, Cuba

PostPosted: Sat Sep 16, 2006 3:59 pm    Post subject: Reply with quote

It is the same.
_________________
Game programming news for newbies | The Ark, making an RPG the right way!
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1293
Location: Netherlands

PostPosted: Sat Sep 16, 2006 4:24 pm    Post subject: Reply with quote

Hmm - do you have utf-8 enabled? In this case you should go through the Gentoo UTF-8 Guide and see if that changes anything ...

HTH
swimmer
Back to top
View user's profile Send private message
neysx
Retired Dev
Retired Dev


Joined: 27 Jan 2003
Posts: 795

PostPosted: Sat Sep 16, 2006 4:42 pm    Post subject: Reply with quote

Can you run the following
Code:
locale && emerge -vp baselayout && grep UNIC /etc/rc.conf
It will likely look like
Code:
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/baselayout-1.12.4-r7  USE="unicode -bootstrap -build -static" 0 kB

Total size of downloads: 0 kB
# UNICODE specifies whether you want to have UNICODE support in the console. 
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
UNICODE="yes"
I suspect the problem is the unicode USE flag that is now on by default. The result is that when you upgrade baselayout, you end up with UNICODE="yes" in /etc/rc.conf. You could also try
Code:
LC_ALL=en_US.utf8 mc

Either define a unicode system locale, or disable unicode for baselayout.

Hth
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum