Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage broke for noe reason
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mariux2
Apprentice
Apprentice


Joined: 16 Sep 2003
Posts: 242

PostPosted: Sat Sep 16, 2006 8:25 am    Post subject: Portage broke for noe reason Reply with quote

Hi, today portage was suddenly broken, i havent been doing any updates lately so i dont see why it would be broken.

Code:
nylon ~ # emerge sync


Performing Global Updates: /usr/portage/profiles/updates/3Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  @='/var/db move'
  s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
........
pTraceback (most recent call last):
  File "/usr/bin/emerge", line 4049, in ?
    emerge_main()
  File "/usr/bin/emerge", line 3770, in emerge_main
    portage.global_updates(settings, trees, mtimedb["updates"])
  File "/usr/lib/portage/pym/portage.py", line 6656, in global_updates
    myupd)
  File "/usr/lib/portage/pym/portage_update.py", line 198, in update_config_files
    write_atomic(updating_file, "".join(file_contents[x]))
  File "/usr/lib/portage/pym/portage_util.py", line 728, in write_atomic
    f.close()
  File "/usr/lib/portage/pym/portage_util.py", line 696, in close
    os.rename(self.name, self._real_name)
OSError: [Errno 16] Device or resource busy


Anyone?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3056
Location: Redmond, WA

PostPosted: Sat Sep 16, 2006 8:29 am    Post subject: Reply with quote

device or resource busy is more likely an issue with the communication with your HD failing.
Back to top
View user's profile Send private message
mariux2
Apprentice
Apprentice


Joined: 16 Sep 2003
Posts: 242

PostPosted: Sat Sep 16, 2006 8:37 am    Post subject: Reply with quote

That would be weird, there are no other signs that it might fail.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3056
Location: Redmond, WA

PostPosted: Sat Sep 16, 2006 9:04 am    Post subject: Reply with quote

Does this error reproduce (as in it happens each time you try to sync)?

Otherwise, it could just be one of those intermittent errors.
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2946
Location: Valencia, Spain

PostPosted: Mon Sep 18, 2006 7:58 am    Post subject: Reply with quote

It's a problem with the file /usr/portage/profiles/updates/ 3Q-2006
It's been talked here https://forums.gentoo.org/viewtopic-t-497064-highlight-.html
and a bug with solution are in bugzilla https://bugs.gentoo.org/show_bug.cgi?id=147010
Portage 2.1.2_pre1 should fix the problem.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Sat Oct 28, 2006 9:43 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic: portage fails - errno 16 Device or resource busy.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum