Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EMERGE] Update du système impossible, packages bloqués ..
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Wed Sep 13, 2006 7:32 pm    Post subject: [EMERGE] Update du système impossible, packages bloqués .. Reply with quote

bonjour à tous, celà fait une plombe que je n'avait pas mis ma Gentoo à jours, et là quand je tentes de la mettre à jours, j'ai pleins de paqets bloqués

Voir plutôt :

Quote:

# emerge -- update world
Calculating dependencies ..... done!

!!! Error: the <=x11-base/xorg-x11-6.9 package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


These are the packages that would be merged, in order:

Calculating world dependencies ..... ..
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
media-plugins/xmms-xmmsd media-video/nvidia-glx app-admin/torsmo media-video/nvidia-kernel media-gfx/bootsplash-themes-livecd

... done!


ensuite :

Quote:

# emerge --pretend update world
... done!
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.1.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.7)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbfile-1.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/setxkbmap-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libICE-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libSM-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86dgaproto-2.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXext-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86miscproto-0.9.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86misc-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/liblbxutil-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/renderproto-0.9.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrender-0.9.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/dmxproto-2.2.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXt-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libxkbui-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/resourceproto-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXres-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/videoproto-2.2.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXmu-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXpm-3.5.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXaw-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/trapproto-3.4.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/recordproto-1.13.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXtst-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xineramaproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libdmx-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/rgb-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/iceauth-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fontsproto-2.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/mkfontscale-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libfontenc-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/encodings-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-util-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-75dpi-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/bdftopcf-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fontcacheproto-0.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXfont-1.2.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/mkfontdir-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-alias-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86rushproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-base/xorg-server-1.0.2-r7)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-misc-misc-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/damageproto-1.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-cursor-misc-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/glproto-1.4.7)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86vidmodeproto-2.2.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86vm-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/randrproto-1.1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xkbcomp-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/fixesproto-4.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/evieext-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xauth-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/xbitmaps-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/makedepend-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-libs/mesa-6.4.2-r2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86driproto-2.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXi-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libdrm-2.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXft-2.1.10)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xclock-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xinit-1.0.2-r6)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrdb-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-wm/twm-1.0.1)
[blocks B ] sys-apps/utempter (is blocking sys-libs/libutempter-1.1.2.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/compositeproto-0.3.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/scrnsaverproto-1.1.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-nsc-2.7.6.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-s3virge-1.8.6.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-i128-1.1.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXfixes-4.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXcomposite-0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-vmware-10.12.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-trident-1.0.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-neomagic-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-cirrus-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-input-evdev-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-sisusb-0.7.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-vesa-1.0.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-tga-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-100dpi-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking app-doc/xorg-docs-1.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-s3-0.3.5.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdamage-1.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xhost-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-glint-1.0.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-base/xorg-x11-7.0-r1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-tdfx-1.1.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXScrnSaver-1.1.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXxf86dga-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-adobe-utopia-type1-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-fbdev-0.1.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-i740-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-dummy-0.1.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xmodmap-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-voodoo-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-input-keyboard-1.0.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-imstt-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-savage-2.0.2.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXcursor-1.1.7)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-siliconmotion-1.3.1.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-ark-0.5.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrandr-1.1.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-apps/xrandr-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXv-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXvMC-1.0.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-via-0.1.33.2)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-mga-1.2.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-v4l-0.0.1.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-sis-0.8.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXinerama-1.0.1)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-tseng-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-vga-4.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-cyrix-1.0.0.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking media-fonts/font-bh-type1-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-chips-1.0.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/printproto-1.0.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXp-1.0.0)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-apm-1.0.1.5)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-rendition-4.0.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-input-mouse-1.0.4)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-i810-1.4.1.3)
[blocks B ] <=x11-base/xorg-x11-6.9 (is blocking x11-drivers/xf86-video-nv-1.0.2.0)
[blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)
[blocks B ] =x11-libs/openmotif-2.2.3-r3 (is blocking x11-libs/motif-config-0.9)
[blocks B ] media-video/nvidia-kernel (is blocking x11-drivers/nvidia-drivers-1.0.8762-r1)
[blocks B ] media-video/nvidia-glx (is blocking x11-drivers/nvidia-drivers-1.0.8762-r1)
[blocks B ] <dev-java/java-config-1.3 (is blocking dev-java/java-config-wrapper-0.12)
.
.
. Le reste semble normal ...


Comment débloquer tous ces paquets ?
Merci d'avance.

Bonne journée/soirée.
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1727
Location: 127.0.0.1

PostPosted: Wed Sep 13, 2006 7:36 pm    Post subject: Reply with quote

Salut,

Guide de migration vers X.Org modulaire

Quote:
[blocks B ] <dev-java/java-config-1.3 (is blocking dev-java/java-config-wrapper-0.12)

Gentoo Java Upgrade Guide

Quote:
[blocks B ] sys-apps/utempter (is blocking sys-libs/libutempter-1.1.2.1)

emerge -C utempter && emerge --ask --oneshot libutempter && revdep-rebuild --library=libutempter.so.0

Quote:
[blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)

emerge -C pam-login && emerge --ask --oneshot shadow

Quote:
[blocks B ] =x11-libs/openmotif-2.2.3-r3 (is blocking x11-libs/motif-config-0.9)

emerge -C openmotif && emerge --ask --oneshot openmotif

Quote:
[blocks B ] media-video/nvidia-kernel (is blocking x11-drivers/nvidia-drivers-1.0.8762-r1)
[blocks B ] media-video/nvidia-glx (is blocking x11-drivers/nvidia-drivers-1.0.8762-r1)

emerge -C nvidia-kernel nvidia-glx && emerge nvidia-drivers

Une fois tout ceci fait, c'est reparti pour un tour :lol:
Guide de mise a jour de GCC pour Linux Gentoo
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Wed Sep 13, 2006 7:56 pm    Post subject: Reply with quote

Mercipour tes réponses, mais pourrais tu m'expliquer brièvevement ces commandes ? histoire de ne pas mourrir idiot :)
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1727
Location: 127.0.0.1

PostPosted: Wed Sep 13, 2006 8:20 pm    Post subject: Reply with quote

Bah euh...

-C == --unmerge == désinstallation
--ask == demande confirmation
--oneshot == n'inscrit pas le paquet dans le fichier world

Après, pourquoi tel paquet bloque tel autre, chaque cas à son histoire.
Par exemple :
[blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)
pam-login a été intégré dans shadow, donc il faut désinstaller pam-login avant d'installer shadow.

Pour les drivers nvidia, avant il y avait 2 ebuilds séparés, maintenant il n'y en a plus qu'un ==> incompatibilité
donc désinstallation et réinstallation en utilisant le nouvel ebuild.

etc...
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Wed Sep 13, 2006 9:04 pm    Post subject: Reply with quote

Ok, merci beaucoup pour tes réponses :D
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Wed Sep 13, 2006 9:25 pm    Post subject: Reply with quote

J'ai un problème avec
Quote:
emerge -C utempter && emerge --ask --oneshot libutempter && revdep-rebuild --library=libutempter.so.0


Voir plutôt :

Quote:
Configuring search environment for revdep-rebuild

Environment mismatch from previous run, deleting temporary files...

Checking reverse dependencies...

Packages containing binaries and libraries using libutempter.so.0
will be emerged.

Collecting system binaries and libraries... done.
(/root/.revdep-rebuild.1_files)

Checking dynamic linking...
found /usr/bin/Esetroot
found /usr/bin/Etbg
found /usr/bin/Eterm
found /usr/bin/Ettable
found /usr/bin/xterm
found /usr/lib/libEterm-0.9.3.so
done.
(/root/.revdep-rebuild_bf98354d.3_rebuild)

Assigning files to ebuilds... done.
(/root/.revdep-rebuild_bf98354d.4_ebuilds)

Evaluating package order...
Warning: Failed to resolve package order.
Will merge in "random" order!
Possible reasons:
- An ebuild is no longer in the portage tree.
- An ebuild is masked, use /etc/portage/packages.keyword
and/or /etc/portage/package.unmask to unmask it
..... done.
(/root/.revdep-rebuild_bf98354d.5_order)

All prepared. Starting rebuild...
emerge --oneshot =x11-terms/eterm-0.9.3-r4 =x11-terms/xterm-204
..........
Calculating dependencies -
emerge: there are no ebuilds to satisfy "=x11-terms/xterm-204".


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
or
- use -X or --package-names as first argument (trys to rebuild package, not exact
ebuild)
or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
(and remove /root/.revdep-rebuild_bf98354d.5_order to be evaluated again)
or
- modify the above emerge command and run it manually
or
- compile or unmerge unsatisfied packages manually, remove temporary files and
try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*


Je ne comprends pas ce qu'il me veut :/
Saleté de biète à cornes.
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Wed Sep 13, 2006 9:55 pm    Post subject: Reply with quote

emerge --ask xterm eterm

C'est que l'ebuild correspondant à la version intallée sur ton pc n'existe plus donc là ca va mettre à jour ;)
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Wed Sep 13, 2006 10:09 pm    Post subject: Reply with quote

Ok, merci beaucoup j'essayerais

En attendant j'ai mieu ... pour changer >_<"
je me suis mis en vesa car avec nvidia c'était pire ...
apparement un foirage avec xkb mais ce qu'il y a dans "Guide de migration vers X.Org modulaire " ne correspond pas avec chez moi on dirait ...
Fiou la nuit va être longue :/

Code:
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.13-gentoo-r3 i686
Current Operating System: Linux desktop.lan 2.6.13-gentoo-r3 #1 SMP Wed Oct 12 14:02:56 CEST 2005 i686
Build Date: 13 September 2006
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 14 00:03:49 2006
(==) Using config file: "/etc/X11/xorg.conf"

dlopen: /usr/lib/xorg/modules/extensions/libGLcore.so: undefined symbol: __glXActiveScreens
(EE) Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so
(EE) Failed to load module "GLcore" (loader failed, 7)
    xkb_keycodes             { include "xfree86+aliases(azerty)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+fr" };
    xkb_geometry             { include "pc(pc105)" };
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
Could not init font path element unix/:7100, removing from list!

Fatal server error:
could not open default font 'fixed'
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Wed Sep 13, 2006 11:04 pm    Post subject: Reply with quote

l'erreur (EE) ne vient pas de xkb mais du module libGLcore.so

va falloir recompiler ce qui est en relation.

media-video/nvidia-glx et kernel ont été remplacé par nvidia-drivers (voir le post-it ;))
torsmo est remplacé par conky
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 7:57 am    Post subject: Reply with quote

CryoGen wrote:
l'erreur (EE) ne vient pas de xkb mais du module libGLcore.so

va falloir recompiler ce qui est en relation.

media-video/nvidia-glx et kernel ont été remplacé par nvidia-drivers (voir le post-it ;))
torsmo est remplacé par conky

je ne peux pas installer le paquet nvidia-drivers .. je dois installer nvidia-legacy-drivers car xorg-server le bloque ...

J'ai finalement réussi à démarer en vesa mais, c'est horrible, il y a un gros bug, si je veux faire un scroll d'une demi page dans firefox il me faut au moins 30secondes ... >_<" jme demandes pourquoi j'ai voulu mettre à jours, mon système fonctiionnait si bien depuis si longtemp :/
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Thu Sep 14, 2006 8:13 am    Post subject: Reply with quote

T'as deux problèmes :

1. xorg

Il y a quelques temps déjà, xorg 7.0 est passé en stable.
Va voir cette doc : http://www.gentoo.org/proj/en/desktop/x/x11/modular-x-howto.xml
Elle va t'expliquer commet passer en version 7.0 (xorg modulaire).

2. pam-login et shadow


shadow a intergé pam-login dans ses nouvelles versions (d'après ce que j'ai pu comprendre). il faut donc désinstaller pam-login.
Code:
emerge -C pam-login && emerge -1 shadow


Après tout ça, ça devrait être bon.
_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 8:20 am    Post subject: Reply with quote

nico_calais wrote:
T'as deux problèmes :

1. xorg

Il y a quelques temps déjà, xorg 7.0 est passé en stable.
Va voir cette doc : http://www.gentoo.org/proj/en/desktop/x/x11/modular-x-howto.xml
Elle va t'expliquer commet passer en version 7.0 (xorg modulaire).

2. pam-login et shadow


shadow a intergé pam-login dans ses nouvelles versions (d'après ce que j'ai pu comprendre). il faut donc désinstaller pam-login.
Code:
emerge -C pam-login && emerge -1 shadow


Après tout ça, ça devrait être bon.

Ce n'est pas le même que ce qui a été donné au dessus ? o_O
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 8:42 am    Post subject: Reply with quote

Arf, j'ai installé le paquet nvidia-drivers comme expliqué dans l'autre topic mais ...


Code:
X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.13-gentoo-r3 i686
Current Operating System: Linux desktop.lan 2.6.13-gentoo-r3 #1 SMP Wed Oct 12 14:02:56 CEST 2005 i686
Build Date: 14 September 2006
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 14 10:34:56 2006
(==) Using config file: "/etc/X11/xorg.conf"

Error: API mismatch: the NVIDIA kernel module has the version 7.1-0, but
this X module has the version 1.0-8774.  Please make sure that the kernel
module and all NVIDIA driver components have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly.
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.


Quote:
Please make sure that the kernel
module and all NVIDIA driver components have the same version.

Hein ? Quoi ??? de quoi il me parle :/

C'est sans doute encore une erreur à la con ...
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Thu Sep 14, 2006 8:57 am    Post subject: Reply with quote

BoOmSlAnGz wrote:
Arf, j'ai installé le paquet nvidia-drivers comme expliqué dans l'autre topic mais ...


Code:

Error: API mismatch: the NVIDIA kernel module has the version 7.1-0, but
this X module has the version 1.0-8774.  Please make sure that the kernel
module and all NVIDIA driver components have the same version.


Quote:
Please make sure that the kernel
module and all NVIDIA driver components have the same version.



Bonjour, j'ai peut-être lu rapidos tes déboires :lol:

mais à vu de pif tu peux être confronté à deux problèmes :

une version de GCC différente entre le noyau et des drivers nvidia

Xorg trop récent / driver nvidia propriétaire.

A+
Back to top
View user's profile Send private message
nico_calais
l33t
l33t


Joined: 09 Jun 2005
Posts: 628
Location: Saint Julien en Genevois

PostPosted: Thu Sep 14, 2006 9:39 am    Post subject: Reply with quote

BoOmSlAnGz wrote:
nico_calais wrote:
T'as deux problèmes :

1. xorg

Il y a quelques temps déjà, xorg 7.0 est passé en stable.
Va voir cette doc : http://www.gentoo.org/proj/en/desktop/x/x11/modular-x-howto.xml
Elle va t'expliquer commet passer en version 7.0 (xorg modulaire).

2. pam-login et shadow


shadow a intergé pam-login dans ses nouvelles versions (d'après ce que j'ai pu comprendre). il faut donc désinstaller pam-login.
Code:
emerge -C pam-login && emerge -1 shadow


Après tout ça, ça devrait être bon.

Ce n'est pas le même que ce qui a été donné au dessus ? o_O


Possible mais j'ai pas tout lu :D
_________________
"Unix IS user friendly... It's just selective about who its friends are." — Tollef Fog Heen tollef@add.no
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 10:07 am    Post subject: Reply with quote

Bon ca y est, j'ai résulu le problème, X se lance avec le driver nvidia, mais, mon interface est un peu floue ...? >_<"

Comment cela se fait t'il ? il y a une option du xorg qui règle ça ?
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Thu Sep 14, 2006 11:45 am    Post subject: Reply with quote

BoOmSlAnGz wrote:
Bon ca y est, j'ai résulu le problème, X se lance avec le driver nvidia

Dire comment et pourquoi pourrait servir à d'autres :wink:
Quote:
mais, mon interface est un peu floue ...? >_<"
Comment cela se fait t'il ? il y a une option du xorg qui règle ça

Mauvaise fréquence de rafraichissement dans xorg.conf :?: :idea:
A+
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 12:49 pm    Post subject: Reply with quote

nemo13 wrote:
BoOmSlAnGz wrote:
Bon ca y est, j'ai résulu le problème, X se lance avec le driver nvidia

Dire comment et pourquoi pourrait servir à d'autres :wink:
Quote:
mais, mon interface est un peu floue ...? >_<"
Comment cela se fait t'il ? il y a une option du xorg qui règle ça

Mauvaise fréquence de rafraichissement dans xorg.conf :?: :idea:
A+


- J'avais du désordre dans mes sources de kernel :P et le lien linux ne pointait pas vers les bonnes sources >_<"

- Heu en fait j'ai fait une reconfiguraion auto de mon ecran et ça fonctionne ...

Mais minute, c'est pas fini, j'ai encore pleins de foirages >_< jvai essayer d'en résoudre un max avant de poster...
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 1:21 pm    Post subject: Reply with quote

Quand je lances firefox, ou thunderbird ou gkrellm j'obtiens ça en plus d'un crash de l'applic :
Quote:
symbol lookup error: /usr/lib/libgdk-x11-2.0.so.0: undefined symbol: cairo_xlib_surface_create


Et je ne vois pas de libgdk dans portage ...

C'est grave docteur ?
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
Apsforps
Guru
Guru


Joined: 27 Sep 2004
Posts: 520
Location: Belgium

PostPosted: Thu Sep 14, 2006 1:49 pm    Post subject: Reply with quote

Alors, le libgdk il vient de gtk+ mais je me demande si ce n'est pas un problème de cairo plutôt... Essaye en réémergeant cairo et gtk+
_________________
Apsforps
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 2:28 pm    Post subject: Reply with quote

Apsforps wrote:
Alors, le libgdk il vient de gtk+ mais je me demande si ce n'est pas un problème de cairo plutôt... Essaye en réémergeant cairo et gtk+

Ah, ca va tout de suite mieu, merci :)

Bon je continues à essayer de réparer le reste, si j'y arrive pas je posterais. je vous tiens au courrant de toute manière :)
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 8:59 pm    Post subject: Reply with quote

Au secours !!! :cry: :cry:
la commande emerge ne fonctionne plus !!

que je fasse n'importe quoi j'ai :
Quote:
desktop src # emerge --sync

Performing Global Updates: /usr/portage/profiles/updates/3Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
.........
pTraceback (most recent call last):
File "/usr/bin/emerge", line 4049, in ?
emerge_main()
File "/usr/bin/emerge", line 3770, in emerge_main
portage.global_updates(settings, trees, mtimedb["updates"])
File "/usr/lib/portage/pym/portage.py", line 6656, in global_updates
myupd)
File "/usr/lib/portage/pym/portage_update.py", line 198, in update_config_files
write_atomic(updating_file, "".join(file_contents[x]))
File "/usr/lib/portage/pym/portage_util.py", line 728, in write_atomic
f.close()
File "/usr/lib/portage/pym/portage_util.py", line 696, in close
os.rename(self.name, self._real_name)
OSError: [Errno 16] Device or resource busy


Arf j'en ai marre :( Quelle idée d'aller vouloir mettre mon système à jours jvous jure >_<"
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Thu Sep 14, 2006 9:01 pm    Post subject: Reply with quote

Ça ressemble à ça
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Thu Sep 14, 2006 9:08 pm    Post subject: Reply with quote

kernel_sensei wrote:
Ça ressemble à ça

Fiouuuu j'ai failli faire une attaque ... :/
Merci ça refonctionne.

Bon, je retourne continuer la merveilleuse aventure de la mise à jours de Gentoo.

A (très) bientôt...

--> []

// EDIT : au fait, rapide la réponse :P :wink:
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
BoOmSlAnGz
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2005
Posts: 123
Location: /usr/src/linux

PostPosted: Fri Sep 15, 2006 8:01 pm    Post subject: Reply with quote

Come back :/

Quote:
/usr/include -I/usr/include -I/usr/include -I/usr/include -I./missing -c ./sshcrypto.c
./sshcrypto.c:25: erreur: field 'key' has incomplete type
./sshcrypto.c:30: erreur: expected specifier-qualifier-list before 'des_key_schedule'
./sshcrypto.c: In function 'blowfish_encrypt':
./sshcrypto.c:131: erreur: 'BF_ENCRYPT' undeclared (first use in this function)
./sshcrypto.c:131: erreur: (Each undeclared identifier is reported only once
./sshcrypto.c:131: erreur: for each function it appears in.)
./sshcrypto.c: In function 'blowfish_decrypt':
./sshcrypto.c:143: erreur: 'BF_DECRYPT' undeclared (first use in this function)
./sshcrypto.c: In function 'des3_init':
./sshcrypto.c:156: erreur: 'struct des3_state' has no member named 'k1'
./sshcrypto.c:157: erreur: 'struct des3_state' has no member named 'k2'
./sshcrypto.c:160: erreur: 'struct des3_state' has no member named 'k3'
./sshcrypto.c:162: erreur: 'struct des3_state' has no member named 'k3'
./sshcrypto.c:164: erreur: 'struct des3_state' has no member named 'iv1'
./sshcrypto.c:165: erreur: 'struct des3_state' has no member named 'iv2'
./sshcrypto.c:166: erreur: 'struct des3_state' has no member named 'iv3'
./sshcrypto.c: In function 'des3_encrypt':
./sshcrypto.c:176: erreur: 'struct des3_state' has no member named 'iv1'
./sshcrypto.c:176: erreur: 'struct des3_state' has no member named 'iv2'
./sshcrypto.c:178: erreur: 'struct des3_state' has no member named 'k1'
./sshcrypto.c:178: erreur: 'struct des3_state' has no member named 'iv1'
./sshcrypto.c:178: erreur: 'DES_ENCRYPT' undeclared (first use in this function)
./sshcrypto.c:179: erreur: 'struct des3_state' has no member named 'k2'
./sshcrypto.c:179: erreur: 'struct des3_state' has no member named 'iv2'
./sshcrypto.c:179: erreur: 'DES_DECRYPT' undeclared (first use in this function)
./sshcrypto.c:180: erreur: 'struct des3_state' has no member named 'k3'
./sshcrypto.c:180: erreur: 'struct des3_state' has no member named 'iv3'
./sshcrypto.c: In function 'des3_decrypt':
./sshcrypto.c:189: erreur: 'struct des3_state' has no member named 'iv1'
./sshcrypto.c:189: erreur: 'struct des3_state' has no member named 'iv2'
./sshcrypto.c:191: erreur: 'struct des3_state' has no member named 'k3'
./sshcrypto.c:191: erreur: 'struct des3_state' has no member named 'iv3'
./sshcrypto.c:191: erreur: 'DES_DECRYPT' undeclared (first use in this function)
./sshcrypto.c:192: erreur: 'struct des3_state' has no member named 'k2'
./sshcrypto.c:192: erreur: 'struct des3_state' has no member named 'iv2'
./sshcrypto.c:192: erreur: 'DES_ENCRYPT' undeclared (first use in this function)
./sshcrypto.c:193: erreur: 'struct des3_state' has no member named 'k1'
./sshcrypto.c:193: erreur: 'struct des3_state' has no member named 'iv1'
make: *** [sshcrypto.o] Erreur 1

!!! ERROR: net-analyzer/dsniff-2.3-r10 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
dsniff-2.3-r10.ebuild, line 62: Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


A chaque fois j'ai toujours ce genre d'erreur quand je veux mettre à jours mes paquets ... pratiquement avec tous ... :s

Une idée ?

Merci.
_________________
[img:2e23a27e21]http://img100.exs.cx/img100/6808/logo59ea.jpg[/img:2e23a27e21]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum