Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XFCE 4.4 RC 1, Overlays et paquets bloquants...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
FrekoDing
n00b
n00b


Joined: 28 Feb 2006
Posts: 30
Location: Paris, France

PostPosted: Mon Sep 11, 2006 5:29 pm    Post subject: XFCE 4.4 RC 1, Overlays et paquets bloquants... Reply with quote

Bonjour,
c'est mon premier post sur ce forum etant habitué à utiliser Gentoo en version stable...
Voulant tester XFCE (que je recommande à tout le monde ! :D ) en version 4.4rc1 sortie recemment, je me penche sur les overlays.
Je trouve les 2 depots suivants :
- http://dev.gentoo.org/~moloh/ebuilds/ (suggéré par les devs de XFCE : http://thunar.xfce.org/pwiki/documentation/installation_gentoo)
- http://overlays.gentoo.org/proj/xfce
Meme probleme : paquets bloquants ! :(

emerge xfce4 xfce4-extras me donne :
[blocks B ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-minicmd-0.3.0-r1)
[blocks B ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-showdesktop-0.4.0-r2)
[blocks B ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-battery-0.3.0-r1)
[blocks B ] >=xfce-base/xfce4-panel-4.3 (is blocking xfce-extra/xfce4-cpugraph-0.2.2-r2)
[...]

Je precise que j'ai bien demasqué tous les paquets necessaires (package.keywords et package.unmask) et que le test se fait sur une install propre, il n'y a que Xorg de fonctionnel... :roll:
Une idée ? Quelqu'un est parvenu à tester cette version ou pourrait me suggerer un autre depot ?
Merci encore.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Mon Sep 11, 2006 6:09 pm    Post subject: Reply with quote

Ce n'est rien ça, lorsqu'emerge t'affiche te tels paquets c'est juste qu'il te demande de les désinstaller par toi-même (il n'en prend pas la responsabilité donc).

Là il te faut faire un emerge -C xfce-base/xfce4-panel

C'est tout :wink:
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Mon Sep 11, 2006 6:13 pm    Post subject: Reply with quote

kwenspc wrote:
Ce n'est rien ça, lorsqu'emerge t'affiche te tels paquets c'est juste qu'il te demande de les désinstaller par toi-même (il n'en prend pas la responsabilité donc).

Là il te faut faire un emerge -C xfce-base/xfce4-panel

C'est tout :wink:

C'est plutot l'inverse !

Il faut désinstaller :
xfce-extra/xfce4-minicmd-0.3.0-r1
xfce-extra/xfce4-showdesktop-0.4.0-r2
xfce-extra/xfce4-battery-0.3.0-r1
xfce-extra/xfce4-cpugraph-0.2.2-r2

Ils ne sont pas compatibles avec le nouveau panel xfce
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Mon Sep 11, 2006 6:17 pm    Post subject: Reply with quote

guilc wrote:
kwenspc wrote:
Ce n'est rien ça, lorsqu'emerge t'affiche te tels paquets c'est juste qu'il te demande de les désinstaller par toi-même (il n'en prend pas la responsabilité donc).

Là il te faut faire un emerge -C xfce-base/xfce4-panel

C'est tout :wink:

C'est plutot l'inverse !


relis ce que tu viens de mettre et corriges :lol:
(parce que je me plante pas...pour une fois ^^)
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Mon Sep 11, 2006 6:39 pm    Post subject: Reply with quote

kwenspc wrote:
guilc wrote:
kwenspc wrote:
Ce n'est rien ça, lorsqu'emerge t'affiche te tels paquets c'est juste qu'il te demande de les désinstaller par toi-même (il n'en prend pas la responsabilité donc).

Là il te faut faire un emerge -C xfce-base/xfce4-panel

C'est tout :wink:

C'est plutot l'inverse !


relis ce que tu viens de mettre et corriges :lol:
(parce que je me plante pas...pour une fois ^^)

Non non, je corrige pas.
Je suis d'accord que les messages de portage sont pas top, mais si tu veux installer xfce-4.4rc1 (>=4.3, tu notes ;)), c'est bien les 4 paquets de xfce-plugin a virer, je maintiens !
Ils se bloquent mutuellement, mais si tu enlèves >=xfce-panel-4.3, ça sera dur d'installer xfce 4.4-rc1 ;)

[EDIT]
d'autant plus que certains de ces plugins pour xfce-panel sont intégrés à xfce-panel dans la nouvelle version
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Mon Sep 11, 2006 6:47 pm    Post subject: Reply with quote

je confirme, les message de portage sont à chier. mais pourquoi moi quand je fais emerge -pvDuN world il me marque ça :

Code:

net-misc/dhcpcd-2.0.0 (is blocking sys-apps/baselayout-1.12.4-r7


et dans la liste plus bas il met sys-apps/baselayout-1.12.4-r7
et pas net-misc/dhcpcd-2.0.0... Et en effet si je vire dhcpcd il me dit plus qu'il y a un paquet bloquant.
et je me souviens bien qu'à ma mise à jour de xorg-6.8 vers xorg-7.0 j'avais xorg-6.9 qui revenait constamment en partie gauche et qui "bloquait" tous les ptits paquets de xorg-7.0...

je comprends plus rien moua :lol:

[mavie](je devrais ptet arreter de faire 10h de taf par jour...heureusement demain dernier jour!)[/mavie]
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Mon Sep 11, 2006 7:12 pm    Post subject: Reply with quote

Perso, j'ai arreté de chercher a comprendre les messages de blocage.
Je me fie plutot au contexte : la dans ce cas, on veut installer xfce 4.4-rc1, donc ce n'est certainement pas xfce > 4.3 qu'il faut virer, mais les paquets opposés dans le blocage, donc les plugins.

Dans ton cas de dhcp : si il tente de mettre a jour baselayout, c'est donc pas baselayout qui bloque, mais dhcpcd.

Bref, au feeling :lol:
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
FrekoDing
n00b
n00b


Joined: 28 Feb 2006
Posts: 30
Location: Paris, France

PostPosted: Mon Sep 11, 2006 7:14 pm    Post subject: Reply with quote

Bonsoir,
j'avais mailé dans la journée le mainteneur du depot http://dev.gentoo.org/~moloh/ebuilds :
Il vient de me repondre : on doit installer xfce4 et les plugins un par un.
Voici une partie de sa reponse :

"That is because these panel plugins are incompatible with new panel, i don't
provide xfce-extra ebuild, but there are some plugins in my package like
xfce4-verve (replacement for xfce4-minicmd), xfce4-battery is there,
xfce4-showdesktop is provided by xfce4-panel itself.
You can find list of plugins in my package from CHANGELOG file, all added
plugins should be listed there.
Now it is impossible to use xfce-extras ebuild from any sources... but most
of its functionality should be present in my ebuilds, but separate ones."

En esperant que ca en aide certains qui se cassent les dents ! :lol:
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Mon Sep 11, 2006 7:34 pm    Post subject: Reply with quote

guilc wrote:
Perso, j'ai arreté de chercher a comprendre les messages de blocage.
Je me fie plutot au contexte : la dans ce cas, on veut installer xfce 4.4-rc1, donc ce n'est certainement pas xfce > 4.3 qu'il faut virer, mais les paquets opposés dans le blocage, donc les plugins.

Dans ton cas de dhcp : si il tente de mettre a jour baselayout, c'est donc pas baselayout qui bloque, mais dhcpcd.

Bref, au feeling :lol:


oué je vais continuer à me fier à mon pif moi aussi :lol:
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Mon Sep 11, 2006 8:15 pm    Post subject: Reply with quote

guilc wrote:
kwenspc wrote:
Ce n'est rien ça, lorsqu'emerge t'affiche te tels paquets c'est juste qu'il te demande de les désinstaller par toi-même (il n'en prend pas la responsabilité donc).

Là il te faut faire un emerge -C xfce-base/xfce4-panel

C'est tout :wink:

C'est plutot l'inverse !

Il faut désinstaller :
xfce-extra/xfce4-minicmd-0.3.0-r1
xfce-extra/xfce4-showdesktop-0.4.0-r2
xfce-extra/xfce4-battery-0.3.0-r1
xfce-extra/xfce4-cpugraph-0.2.2-r2

Ils ne sont pas compatibles avec le nouveau panel xfce


je rajoute mon grain de sel :wink: !

Pour moi ce message de portage veut dire que les paquets entre () sont entrain de bloqué les paquets sur la gauche qui ne sont pas entre () (la parenthèse a son importance car portage nous installe jamais de paquet entre () [un peu tordu mais bon :P ...] donc dans nôtre cas :
Code:
xfce-base/xfce4-panel-4.3 (est "entrain d'être" bloqué par xfce-extra/xfce4-minicmd-0.3.0-r1)


J'ai tjrs raisonné ainsi pour traiter cette situation ...


@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Sep 12, 2006 5:49 am    Post subject: Reply with quote

Certes man_in_the_hill certes :wink: c'est en effet comme ça qu'il faut voir la chose...mais les developpeurs de portage savent pas écrire anglais, y a un truc c'est pas possible 8O
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum