Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge libsdl failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
jesso
Guru
Guru


Joined: 27 Oct 2004
Posts: 397
Location: Canada

PostPosted: Mon Sep 11, 2006 12:03 pm    Post subject: emerge libsdl failed Reply with quote

Quote:

i686-pc-linux-gnu-gcc -O2 -march=i686 -pipe -I./include -D_GNU_SOURCE=1 -fvisibility=hidden -I/usr/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DXTHREADS -D_REENTRANT -DHAVE_LINUX_VERSION_H -c ./src/loadso/dlopen/SDL_sysloadso.c -o build/SDL_sysloadso.o >/dev/null 2>&1
/bin/sh ./libtool --tag=CC --mode=compile ./build-scripts/strip_fPIC.sh /usr/bin/yasm -f elf -i ./src/hermes/ ./src/hermes/mmxp2_32.asm -o build/mmxp2_32.lo
./build-scripts/strip_fPIC.sh /usr/bin/yasm -f elf -i ./src/hermes/ ./src/hermes/mmx_main.asm -fPIC -DPIC -o build/.libs/mmx_main.o
/usr/bin/yasm -f elf -i ./src/hermes/ ./src/hermes/mmx_main.asm -o build/.libs/mmx_main.o
yasm: unrecognized option `-i'
yasm: warning: can open only one input file, only the last file will be processed
make: *** [build/mmx_main.lo] Error 1
make: *** Waiting for unfinished jobs....
./build-scripts/strip_fPIC.sh /usr/bin/yasm -f elf -i ./src/hermes/ ./src/hermes/mmxp2_32.asm -fPIC -DPIC -o build/.libs/mmxp2_32.o
/usr/bin/yasm -f elf -i ./src/hermes/ ./src/hermes/mmxp2_32.asm -o build/.libs/mmxp2_32.o
yasm: unrecognized option `-i'
yasm: warning: can open only one input file, only the last file will be processed
make: *** [build/mmxp2_32.lo] Error 1

!!! ERROR: media-libs/libsdl-1.2.11 failed.
Call stack:
ebuild.sh, line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
libsdl-1.2.11.ebuild, line 154: Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


Looks like some incompatibilty with "yasm":
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722
Location: Cluj-Napoca, Romania

PostPosted: Mon Sep 11, 2006 12:50 pm    Post subject: Reply with quote

Yup. Is there any particular reason you're using yasm and not nasm? What happens if you emerge nasm first, then retry libsdl?
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
philippo
n00b
n00b


Joined: 20 Jun 2005
Posts: 12

PostPosted: Wed Sep 20, 2006 3:33 pm    Post subject: Reply with quote

I ran into the same problem now.
I have installed both nasm and yasm, because I'm using yasm for one of my own projects. Is there a way to tell configure to use nasm instead of yasm, without having to deinstall yasm? Shouldn't it avoid using yasm anyway if it isn't compatable? ;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum