Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[DMA] Impossible d'activer le DMA [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Fri Sep 08, 2006 5:44 pm    Post subject: [DMA] Impossible d'activer le DMA [résolu] Reply with quote

Salut !

Mon ordi rââââme depuis qques temps. Ce soir ca m'enerve, je commence par jeter un oeil au DMA et bingo !

Code:

# hdparm /dev/hda

/dev/hda:
 multcount    = 16 (on)
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  0 (off)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 16383/255/63, sectors = 156301488, start = 0


No problemo, j'active le DMA, mais :

Code:

# hdparm -d1 /dev/hda

/dev/hda:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)


ne trouvant rien dans le 'man hdparm', je vais jeter un oeil au noyau :

Code:

# grep DMA /usr/src/linux/.config

CONFIG_GENERIC_ISA_DMA=y
CONFIG_ISA_DMA_API=y
# CONFIG_BLK_DEV_IDEDMA is not set
# CONFIG_IDEDMA_AUTO is not set


mon soucis, c'est que :
- je ne sais pas quelles options sont nécessaires (le BLK_DEV_IDEDMA ou le IDEDMA_AUTO sont tout de même assez attirants)
- je ne vois nulle part ou les activer !!!

Merci pour votre aide :D
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE


Last edited by gbetous on Sat Sep 09, 2006 8:35 am; edited 1 time in total
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Fri Sep 08, 2006 9:06 pm    Post subject: Reply with quote

Salut,

J'ai ça pour ta commande :
Code:
crazy_gentoo eclass %
 grep DMA /usr/src/linux/.config
CONFIG_GENERIC_ISA_DMA=y
CONFIG_ISA_DMA_API=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
# CONFIG_BLK_DEV_IDEDMA_FORCED is not set
CONFIG_IDEDMA_PCI_AUTO=y
# CONFIG_IDEDMA_ONLYDISK is not set
CONFIG_BLK_DEV_IDEDMA=y
# CONFIG_IDEDMA_IVB is not set
CONFIG_IDEDMA_AUTO=y



Code:
crazy_gentoo eclass %
 hdparm  /dev/hdb

/dev/hdb:
 multcount    = 16 (on)
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 24321/255/63, sectors = 390721968, start = 0



@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Ey
l33t
l33t


Joined: 07 Apr 2005
Posts: 863
Location: Paris

PostPosted: Fri Sep 08, 2006 9:15 pm    Post subject: Re: [DMA] Impossible d'activer le DMA Reply with quote

Tu ne dois pas avoir ton chipset IDE dans ton noyau.
Back to top
View user's profile Send private message
gbetous
l33t
l33t


Joined: 15 Jan 2004
Posts: 679
Location: Toulouse

PostPosted: Sat Sep 09, 2006 8:07 am    Post subject: Reply with quote

Oui, ca venait de là : mon chipset !!!

Il me fallait activer : PCI IDE chpsiet support, puis Generic PCI bus-master DMA support, et enfin VIA 82Cxxx dans mon cas.

Merci :D
_________________
Core2Quad Q6600
ASUS P5B-V (i965 video intégrée)
~amd64 / KDE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum