Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde problems after gcc 4.1 upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
MacFlecknoe
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 189
Location: Ann Arbor, MI

PostPosted: Sun Sep 03, 2006 1:06 pm    Post subject: kde problems after gcc 4.1 upgrade Reply with quote

I just updraded by gcc from 3.4.6 to 4.1.1 following this guide:

http://www.gentoo.org/doc/en/gcc-upgrading.xml

But now many of my KDE apps will no longer launch. Both amarok and kopete fail with this message:

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /usr/kde/3.5/lib64/libkhtml.so.4)


I have both re-emerged kde-libs and the broken applications and ran revdep-rebuild; nothing has solved have the problem. Most other applications work fine... what could be the trouble?


:(
Back to top
View user's profile Send private message
MacFlecknoe
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 189
Location: Ann Arbor, MI

PostPosted: Sun Sep 03, 2006 1:28 pm    Post subject: Reply with quote

consolodating thread here:

https://forums.gentoo.org/viewtopic-t-494821.html
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Sep 03, 2006 1:50 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4730
Location: Angra do Heroísmo (PT)

PostPosted: Sun Sep 03, 2006 1:54 pm    Post subject: Reply with quote

[mod]The correct thread to discuss these issues is the Sticky GCC 4.1.1 and GLIBC 2.4 stable in P&P.[/mod]
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum