Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Still points to gcc 3.4.6 after upgrading to 4.1.1...?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
bjorntj
Guru
Guru


Joined: 01 Jun 2005
Posts: 402

PostPosted: Sun Sep 03, 2006 1:00 pm    Post subject: Still points to gcc 3.4.6 after upgrading to 4.1.1...? Reply with quote

I have just upgraded to gcc 4.1.1 but kde apps still point to the old 3.4.6 directory after recomiling...

E.g. when trying to start amarok I get the following error (after re-emerging):

Code:

amarokapp: /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /usr/kde/3.5/lib64/libkhtml.so.4)


I have tried running revdep-rebuild and fix_libtool_files.sh 3.4.6 but still get the same error...

I solved this by making a link under /usr/lib/gcc/x86_64-pc-linux-gnu from 3.4.6 pointing to 4.1.1 but I am guessing that there should be a better way to fix this?


Regards,

BTJ
_________________
Someone wrote:
"I understand that if you play a Windows CD backwards you hear strange Satanic messages"
To which someone replied:
"It's even worse than that; play it forwards and it installs Windows"
Back to top
View user's profile Send private message
MacFlecknoe
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 189
Location: Ann Arbor, MI

PostPosted: Sun Sep 03, 2006 1:27 pm    Post subject: Reply with quote

I am having the exact same problem.
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Sun Sep 03, 2006 1:38 pm    Post subject: Reply with quote

You both did not follow the Gentoo Linux GCC Upgrade Guide. See also this thread.
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4726
Location: Angra do Heroísmo (PT)

PostPosted: Sun Sep 03, 2006 1:50 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

[mod]Read Carlo's post. The correct thread to discuss these issues is the Sticky GCC 4.1.1 and GLIBC 2.4 stable in P&P.[/mod]
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum