Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI]Ni fglrx ni radeon ne veulent marcher(résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
guitoo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2004
Posts: 136

PostPosted: Sun Sep 03, 2006 11:29 am    Post subject: [ATI]Ni fglrx ni radeon ne veulent marcher(résolu) Reply with quote

Bonjour,
J'ai une x800 sur port agp. Si j'utilise le driver radeon, je me retrouve avec une definition de 640x480 et les polices sont illisible. Si j'utilise les drivers fglrx la machine se bloque sur un écran noir au démarrage de X. Plus rien ne repond et je doit redemarrer la machine.
mon xorg.conf:

Code:

Section "Monitor"
    Identifier  "l90d+"
    HorizSync   30 - 64
    VertRefresh 40-150
EndSection

Section "Device"
    Identifier  "x800"
#    Driver      "fglrx"
    Driver   "vesa"
#    Driver   "radeon"
    Option "UseInternalAGPGART" "no"
    Option "ForceMonitors" "notv"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device   "x800"
    Monitor     "l90d+"
    DefaultDepth 16

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Dans un premier temps je voudrais arriver a faire marcher le driver radeon. C'est plus facile a tester et je ne suis pas obliger de redemarer la machine a chaque fois. mon moniteur est un ecran plat hyundai l90d+.

mes log xorg vont 30000 lignes :/ le plus important a l'air d'etre ça
Code:

(II) VESA(0): Total Memory: 256 64KB banks (16384kB)
(WW) VESA(0): config file hsync range 30-64kHz not within DDC hsync ranges.
(WW) VESA(0): config file vrefresh range 40-150Hz not within DDC vrefresh ranges.
(II) VESA(0): l90d+: Using hsync range of 30.00-64.00 kHz
(II) VESA(0): l90d+: Using vrefresh range of 40.00-150.00 Hz
(--) VESA(0): Virtual size is 1280x1024 (pitch 1280)
(**) VESA(0): *Built-in mode "1280x1024"
(**) VESA(0): *Built-in mode "1024x768"
(**) VESA(0): *Built-in mode "800x600"
(**) VESA(0): *Built-in mode "640x480"
(**) VESA(0):  Built-in mode "1280x1024"
(**) VESA(0):  Built-in mode "720x400"
(**) VESA(0):  Built-in mode "640x400"
(**) VESA(0):  Built-in mode "640x400"
(**) VESA(0):  Built-in mode "640x350"
(--) VESA(0): Display dimensions: (370, 300) mm
(--) VESA(0): DPI set to (87, 86)
(WW) (1280x1024,l90d+) mode clock 108MHz exceeds DDC maximum 0MHz
(WW) (1280x1024,l90d+) mode clock 135MHz exceeds DDC maximum 0MHz
(WW) (1280x1024,l90d+) mode clock 157.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 60Hz refresh for mode "1280x1024" (11a)
(WW) (1024x768,l90d+) mode clock 65MHz exceeds DDC maximum 0MHz
(WW) (1024x768,l90d+) mode clock 75MHz exceeds DDC maximum 0MHz
(WW) (1024x768,l90d+) mode clock 78.8MHz exceeds DDC maximum 0MHz
(WW) (1024x768,l90d+) mode clock 94.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 75Hz refresh for mode "1024x768" (117)
(WW) (800x600,l90d+) mode clock 36MHz exceeds DDC maximum 0MHz
(WW) (800x600,l90d+) mode clock 40MHz exceeds DDC maximum 0MHz
(WW) (800x600,l90d+) mode clock 50MHz exceeds DDC maximum 0MHz
(WW) (800x600,l90d+) mode clock 49.5MHz exceeds DDC maximum 0MHz
(WW) (800x600,l90d+) mode clock 56.3MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 85Hz refresh for mode "800x600" (114)
(WW) (640x480,l90d+) mode clock 25.2MHz exceeds DDC maximum 0MHz
(WW) (640x480,l90d+) mode clock 31.5MHz exceeds DDC maximum 0MHz
(WW) (640x480,l90d+) mode clock 31.5MHz exceeds DDC maximum 0MHz
(WW) (640x480,l90d+) mode clock 36MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 85Hz refresh for mode "640x480" (111)
(WW) (1280x1024,l90d+) mode clock 108MHz exceeds DDC maximum 0MHz
(WW) (1280x1024,l90d+) mode clock 135MHz exceeds DDC maximum 0MHz
(WW) (1280x1024,l90d+) mode clock 157.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 60Hz refresh for mode "1280x1024" (165)
(WW) (720x400,l90d+) mode clock 35.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 85Hz refresh for mode "720x400" (135)
(WW) (640x400,l90d+) mode clock 31.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 85Hz refresh for mode "640x400" (185)
(WW) (640x400,l90d+) mode clock 31.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 85Hz refresh for mode "640x400" (185)
(WW) (640x350,l90d+) mode clock 31.5MHz exceeds DDC maximum 0MHz
(II) VESA(0): Attempting to use 85Hz refresh for mode "640x350" (1c5)
(**) VESA(0): Using "Shadow Framebuffer"


En remerciant par avance ceux qui sauront m'aider :)


Last edited by guitoo on Sun Sep 03, 2006 5:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Sep 03, 2006 11:42 am    Post subject: Reply with quote

pour le radeon je peux pas t'aider
mais pour le drivers proprio, tu as essayé quelle version ?
ton xorg.conf tu l'as fait comment ?
avec le driver proprio il faut le générer avec l'utilitaire aticonfig
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
guitoo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2004
Posts: 136

PostPosted: Sun Sep 03, 2006 12:00 pm    Post subject: Reply with quote

Arf c'est bon merci :). Avec aticonfig ça marche nickel.

Zut c'est pas encore ça.
Code:

 $ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.2)


Finalement en desactivant le driver agp interne ça marche.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sun Sep 03, 2006 1:55 pm    Post subject: Reply with quote

Alors un petit (résolu), STP :)
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum