Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
framebuffer console curses corruption [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
mr_steve
n00b
n00b


Joined: 02 Sep 2006
Posts: 8

PostPosted: Sat Sep 02, 2006 3:24 am    Post subject: framebuffer console curses corruption [SOLVED] Reply with quote

Hey all,
I've just done a new install of Gentoo 2006.1 after a hard drive died on me. I've been having a really strange problem with curses-based applications like ufed, and even menuconfig. Whenever I start a curses application, I get text corruption, as if the last character or so of each line is wrapping around to the next line. Typing "reset" at the prompt will solve the problem until the next login. I'm using vesafb-tng at 1280x1024, but the problem occurs at every resolution I've tried, as well as with radeonfb. I am running ~x86 this time around, so I appreciate that I may have brought this on myself :D but any insight would be appreciated.

Some info that might be relevant:
Kernel is 2.6.17-gentoo-r7
using baselayout-1.12.4-r7
gcc-4.1.1
ncurses version is 5.5-r3
video card is a Radeon 8500

Thanks in advance,
-Steve


Last edited by mr_steve on Sun Sep 03, 2006 6:53 am; edited 1 time in total
Back to top
View user's profile Send private message
zietbukuel
l33t
l33t


Joined: 30 Dec 2005
Posts: 606
Location: /dev/peru/lima

PostPosted: Sat Sep 02, 2006 5:01 pm    Post subject: Reply with quote

Welcome to the forum!

Who can give as a hand? I have the same problem!

Thank you!
_________________
AMD FX 8350 8-core CPU
16GB Corsair Vengeance DDR3 RAM
ASUS M5A97 Motherboard
1TB (Gentoo) + 500GB (Windows 7 for games) HDDs
Nvidia 550 GTX Ti 1Gb Ram DDR5
Cooler Master CM690 Case
Back to top
View user's profile Send private message
mr_steve
n00b
n00b


Joined: 02 Sep 2006
Posts: 8

PostPosted: Sat Sep 02, 2006 7:49 pm    Post subject: update Reply with quote

Just to update this, my emerge gnome just finished, and starting curses apps in gnome-terminal works just fine, so this seems to be purely a console problem.
Back to top
View user's profile Send private message
dirge6
n00b
n00b


Joined: 02 Sep 2006
Posts: 1

PostPosted: Sun Sep 03, 2006 6:05 am    Post subject: Reply with quote

I was having the same problem with curses displaying in a console. I set UNICODE="no" in /etc/rc.conf, and it fixed the problem.
Back to top
View user's profile Send private message
mr_steve
n00b
n00b


Joined: 02 Sep 2006
Posts: 8

PostPosted: Sun Sep 03, 2006 6:52 am    Post subject: Reply with quote

Dirge, thanks much. That completely solved my problem as well. 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum