Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge of Frozen-bubble fails due to smpeg package
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
roguetech
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jan 2005
Posts: 82
Location: Canada

PostPosted: Mon Nov 13, 2006 9:09 pm    Post subject: Emerge of Frozen-bubble fails due to smpeg package Reply with quote

When I try to emerge frozen-bubble, supertux etc... The compile fails on the smpeg package. Here is the output:
Code:

# emerge -va smpeg

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] media-libs/smpeg-0.4.4-r8  USE="X gtk opengl -debug -mmx" 0 kB

Total size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y

>>> Emerging (1 of 1) media-libs/smpeg-0.4.4-r8 to /
 * smpeg-0.4.4-gtkm4.patch.bz2 MD5 ;-) ...                                [ ok ] * smpeg-0.4.4-gtkm4.patch.bz2 RMD160 ;-) ...                             [ ok ] * smpeg-0.4.4-gtkm4.patch.bz2 SHA1 ;-) ...                               [ ok ] * smpeg-0.4.4-gtkm4.patch.bz2 SHA256 ;-) ...                             [ ok ] * smpeg-0.4.4-gtkm4.patch.bz2 size ;-) ...                               [ ok ] * smpeg-0.4.4.tar.gz MD5 ;-) ...                                         [ ok ] * smpeg-0.4.4.tar.gz RMD160 ;-) ...                                      [ ok ] * smpeg-0.4.4.tar.gz SHA1 ;-) ...                                        [ ok ] * smpeg-0.4.4.tar.gz SHA256 ;-) ...                                      [ ok ] * smpeg-0.4.4.tar.gz size ;-) ...                                        [ ok ] * checking ebuild checksums ;-) ...                                      [ ok ] * checking auxfile checksums ;-) ...                                     [ ok ] * checking miscfile checksums ;-) ...                                    [ ok ] * checking smpeg-0.4.4.tar.gz ;-) ...                                    [ ok ] * checking smpeg-0.4.4-gtkm4.patch.bz2 ;-) ...                           [ ok ]>>> Unpacking source...
>>> Unpacking smpeg-0.4.4.tar.gz to /var/tmp/portage/smpeg-0.4.4-r8/work
>>> Unpacking smpeg-0.4.4-gtkm4.patch.bz2 to /var/tmp/portage/smpeg-0.4.4-r8/work
 * Applying smpeg-0.4.4-m4.patch ...                                      [ ok ] * Applying smpeg-0.4.4-gnu-stack.patch ...                               [ ok ] * Applying smpeg-0.4.4-config.patch ...                                  [ ok ] * Applying smpeg-0.4.4-PIC.patch ...                                     [ ok ] * Applying smpeg-0.4.4-gcc41.patch ...                                   [ ok ] * Applying smpeg-0.4.4-flags.patch ...                                   [ ok ] * Applying smpeg-0.4.4-automake.patch ...                                [ ok ] * Applying smpeg-0.4.4-mmx.patch ...                                     [ ok ] * Applying smpeg-0.4.4-malloc.patch ...                                  [ ok ] * Applying smpeg-0.4.4-gtkm4.patch.bz2 ...                               [ ok ] * Running eautoreconf in '/var/tmp/portage/smpeg-0.4.4-r8/work/smpeg-0.4.4' ... * Requested autoconf 2.5
 * Using
 * Using
 * Requested automake latest: 1.9
 * Using automake (GNU automake) 1.9.6
 * Using aclocal (GNU automake) 1.9.6
 * Running aclocal -I /var/tmp/portage/smpeg-0.4.4-r8/work/smpeg-0.4.4/m  [ !! ]
 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/smpeg-0.4.4-r8/temp/aclocal-10392.out


!!! ERROR: media-libs/smpeg-0.4.4-r8 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  smpeg-0.4.4-r8.ebuild, line 48:   Called eautoreconf
  autotools.eclass, line 83:   Called eaclocal
  autotools.eclass, line 121:   Called autotools_run_tool 'aclocal' '-I' '/var/tmp/portage/smpeg-0.4.4-r8/work/smpeg-0.4.4/m4'
  autotools.eclass, line 242:   Called die

!!! Failed Running aclocal !
!!! If you need support, post the topmost build error, and the call stack if relevant.


Why does this occur and what is a possible solution, I have read it is autoconf-wrapper but did not understand the solutions...
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Nov 13, 2006 10:14 pm    Post subject: Reply with quote

Do what's asked :wink:
Code:
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/smpeg-0.4.4-r8/temp/aclocal-10392.out
Back to top
View user's profile Send private message
roguetech
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jan 2005
Posts: 82
Location: Canada

PostPosted: Mon Nov 13, 2006 11:07 pm    Post subject: Reply with quote

Well I restarted the computer so I re-emerged smpeg to regenerate the file, which was /var/tmp/portage/smpeg-0.4.4-r8/temp/aclocal-11438.out


Code:

***** aclocal *****

/var/tmp/portage/smpeg-0.4.4-r8/work/smpeg-0.4.4/m4/socklen.m4:11: warning: underquoted definition of AC_TYPE_SOCKLEN_T
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/pth.m4:43: warning: underquoted definition of _AC_PTH_ERROR
/usr/share/aclocal/pth.m4:55: warning: underquoted definition of _AC_PTH_VERBOSE
/usr/share/aclocal/pth.m4:61: warning: underquoted definition of AC_CHECK_PTH
ac-wrapper: /usr/bin/autom4te-2.60 is missing or not executable.
            Please try emerging the correct version of autoconf.
aclocal-1.9: autom4te failed with exit status: 1
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Nov 13, 2006 11:13 pm    Post subject: Reply with quote

roguetech wrote:
ac-wrapper: /usr/bin/autom4te-2.60 is missing or not executable.

To install it: emerge =autoconf-2.60
Back to top
View user's profile Send private message
roguetech
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jan 2005
Posts: 82
Location: Canada

PostPosted: Tue Nov 14, 2006 4:34 am    Post subject: Reply with quote

That worked! but I also had to re-compile [/b]libsdl[b] in order for it to build the games... which is not a big deal. Thanks a lot!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum