Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UTF-8] affichage avec gmplayer et man erroné.
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Thu Aug 24, 2006 12:49 pm    Post subject: [UTF-8] affichage avec gmplayer et man erroné. Reply with quote

Salut tout le monde!

J'ai passé a utf8 en suivant la doc, mais j'ai toujours quelques problèmes d'affichage avec les accents dans mon terminal avec man. L'affichage d'un fichier sous vi ou avec less ne pose aucun problème..
gmplayer a aussi des problèmes avec les accents..


Code:

$ locale
LANG=fr_CH.utf8
LC_CTYPE="fr_CH.utf8"
LC_NUMERIC="fr_CH.utf8"
LC_TIME="fr_CH.utf8"
LC_COLLATE="fr_CH.utf8"
LC_MONETARY="fr_CH.utf8"
LC_MESSAGES="fr_CH.utf8"
LC_PAPER="fr_CH.utf8"
LC_NAME="fr_CH.utf8"
LC_ADDRESS="fr_CH.utf8"
LC_TELEPHONE="fr_CH.utf8"
LC_MEASUREMENT="fr_CH.utf8"
LC_IDENTIFICATION="fr_CH.utf8"
LC_ALL=fr_CH.utf8


# Dans mon /etc/conf.d/consolefont
CONSOLEFONT="lat9w-16"

# Dans mon /etc/rc.conf
UNICODE=yes

# Dans mon /etc/man.conf
NROFF /usr/bin/nroff -c -mandoc

Mon make.conf contient le useflag unicode

Je ne sais plus trop quoi essayer, même si ça risque d'être très bête..
Merci d'avance pour vos conseils avisés :wink:
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..


Last edited by daiji on Thu Aug 24, 2006 9:07 pm; edited 2 times in total
Back to top
View user's profile Send private message
-KuRGaN-
Veteran
Veteran


Joined: 05 Dec 2004
Posts: 1142
Location: Besançon (25) [FRANCE]

PostPosted: Thu Aug 24, 2006 12:51 pm    Post subject: Reply with quote

Et dans ton kernel tu a bien coché l'utf8 et mis par défaut ?
_________________
Knight Gent00 Industries RiDeR !!!!
Back to top
View user's profile Send private message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Thu Aug 24, 2006 12:53 pm    Post subject: Reply with quote

# .config
CONFIG_NLS_DEFAULT="utf8"

Si c'est de cela dont tu parles.
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..
Back to top
View user's profile Send private message
-KuRGaN-
Veteran
Veteran


Joined: 05 Dec 2004
Posts: 1142
Location: Besançon (25) [FRANCE]

PostPosted: Thu Aug 24, 2006 2:12 pm    Post subject: Reply with quote

voui
_________________
Knight Gent00 Industries RiDeR !!!!
Back to top
View user's profile Send private message
Poch
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2006
Posts: 105
Location: Namur, Belgique

PostPosted: Thu Aug 24, 2006 2:36 pm    Post subject: Reply with quote

Salut,

Pour les man pages il faut changer la ligne commençant par NROFF.... de /etc/man.conf comme recommandé ici

Code:

NROFF           iconv -f utf8 -t iso8859-1 | /usr/bin/nroff -Tlatin1 -c -mandoc



Après ça je n'avais plus aucun problèmes avec les accents...
_________________
Microsoft is not the answer. Microsoft is the question. NO, is the answer.
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Thu Aug 24, 2006 2:57 pm    Post subject: Reply with quote

même problème ici et la dernière commande ne résoud pas le problème.

Au liue d'avoir des caractères bizarres je me retoruve avec des <c9> ... à la place des accents.
Back to top
View user's profile Send private message
Fifre
n00b
n00b


Joined: 29 Jul 2003
Posts: 61

PostPosted: Thu Aug 24, 2006 5:43 pm    Post subject: Reply with quote

j'ai exactement le meme probleme, et je ne sais pas quoi faire non plus ...
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Thu Aug 24, 2006 5:51 pm    Post subject: Reply with quote

Code:
NROFF           iconv -f utf8 -t iso8859-1 | /usr/bin/nroff -c -mandoc


Comme ça, ça fonctionne chez moi.
Back to top
View user's profile Send private message
palatin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2004
Posts: 113
Location: Paris

PostPosted: Thu Aug 24, 2006 8:57 pm    Post subject: Reply with quote

Est-ce que vous utilisez une console avec support de l'utf-8 ?
personnellement j'utilise ça sous Terminal (xfce), qui utilise VTE et donc supporte l'utf8 :
Code:
NROFF      /usr/bin/nroff -Tutf8 -mandoc -c

Parmis les autres terminaux à supporter l'utf8, il y a gnome-terminal (vte), urxvt et uxterm. Je ne sais pas si le choix de la police change quelque chose, il me semble que toute les polices actuelles ont support utf-8, du moins pour les symboles fr.
_________________
fumo~
Back to top
View user's profile Send private message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Thu Aug 24, 2006 8:59 pm    Post subject: Reply with quote

EDIT : Ha ben pas résolu du tout en fait..
Quote:
NROFF /usr/bin/nroff -Tutf8 -mandoc -c

fonctionne en faisant man man p.ex mais pas avec man fprintf

Avec
Quote:
NROFF iconv -f utf8 -t iso8859-1 | /usr/bin/nroff -c -mandoc

même problème que Il turisto et fifre..


J'ai gnome-terminal, donc compatible utf8.
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..
Back to top
View user's profile Send private message
palatin
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2004
Posts: 113
Location: Paris

PostPosted: Fri Aug 25, 2006 5:50 am    Post subject: Reply with quote

Effectivement, ça ne marche pas pour printf, c'est louche. C'est peut-être un problème d'encodage du man, à priori il devrait être en utf-8 mais le fichier à l'intérieur du .gz ne l'est peut-être pas.
_________________
fumo~
Back to top
View user's profile Send private message
Il turisto
l33t
l33t


Joined: 12 May 2004
Posts: 968
Location: Battincourt - Belgique

PostPosted: Fri Aug 25, 2006 8:05 am    Post subject: Reply with quote

Trapamoosch wrote:
Code:
NROFF           iconv -f utf8 -t iso8859-1 | /usr/bin/nroff -c -mandoc


Comme ça, ça fonctionne chez moi.



cela fonctionne chez moi.

Merci bcp pour l'aide.


edit : sauf que :

Code:

man man

iconv: Séquence d'échappement illégale à la position 286
Back to top
View user's profile Send private message
Trapamoosch
Apprentice
Apprentice


Joined: 08 May 2004
Posts: 203

PostPosted: Fri Aug 25, 2006 8:10 am    Post subject: Reply with quote

Oui exact j'ai le même soucis que toi pour le man man.
Back to top
View user's profile Send private message
nemo13
Veteran
Veteran


Joined: 08 Oct 2004
Posts: 1016
Location: France/Istres

PostPosted: Fri Aug 25, 2006 8:31 am    Post subject: Reply with quote

Bonjour,

Cà commence à dater, mais essaye toujours

cette bidouille

A+
Back to top
View user's profile Send private message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Fri Aug 25, 2006 9:37 am    Post subject: Reply with quote

nemo13 wrote:
Bonjour,

Cà commence à dater, mais essaye toujours

cette bidouille

A+


J'ai essayé tout ce que j'ai pu trouver.. Il n'y a aucune des proposition qui fontionne pleinement chez moi.. je commence à désespérer.

Sinon quelqu'un utilise gmplayer et a le même problème que moi ?
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8528
Location: ~Brussels - Belgique

PostPosted: Fri Aug 25, 2006 11:01 am    Post subject: Reply with quote

Code:
LC_ALL="" man ...

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Fri Aug 25, 2006 11:04 am    Post subject: Reply with quote

XavierMiller wrote:
Code:
LC_ALL="" man ...



En effet, c'est un moyen :)
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..
Back to top
View user's profile Send private message
TTK
Guru
Guru


Joined: 02 Mar 2004
Posts: 523

PostPosted: Fri Aug 25, 2006 12:42 pm    Post subject: Reply with quote

Passer à l'UTF-8 c'est un bon moyen de tout casser un système qui marche nickel.

J'ai eu la flemme de revenir en iso, pour le moment, mais dès que j'ai le courage je le fais. Contrairement à ce qui se lit partout ce n'est pas prêt du tout. Plein d'applis ont des pbs. (slang, curses, mediawiki + mysql, Eterm, fluxbox ...)

Mébon, je suis un peu aigri, ça passera.
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 115

PostPosted: Sun Aug 27, 2006 11:28 am    Post subject: Reply with quote

Un an à lire ce merveilleux forum, je me décide enfin a poster

J'avais aussi ce problème, et toutes les solutions proposées ne marchais pas.

Donc après avoir abusé de "man iconv" et "man nroff"
et torturé "/etc/man.conf"

j'en suis arrivé à
Quote:
NROFF iconv -f utf8 -t iso8859-15 | /usr/bin/nroff -Tuft8 -c -mandoc


J'ai virer tous ce qui utilisait gtk+-1*, (xmms...), mais gmplayer chez moi est en gtk+2 , donc pas de pb d'accents.

J'avais ce problème aussi avec les fortunes "fr"
j'ai donc fait un alias de fortune en "fortune | iconv -f iso8859-15 -t uft8" en ca marche nikel
Back to top
View user's profile Send private message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Sun Aug 27, 2006 11:51 am    Post subject: Reply with quote

ceric35 wrote:


Quote:
NROFF iconv -f utf8 -t iso8859-15 | /usr/bin/nroff -Tutf8 -c -mandoc



J'ai personellement toujours un problème en faisant man man

ceric35 wrote:

J'ai virer tous ce qui utilisait gtk+-1*, (xmms...), mais gmplayer chez moi est en gtk+2 , donc pas de pb d'accents.


Pareil, je pensait que mon gmplayer était en gtk2, comment en être certain ?
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..
Back to top
View user's profile Send private message
Fifre
n00b
n00b


Joined: 29 Jul 2003
Posts: 61

PostPosted: Sun Aug 27, 2006 12:56 pm    Post subject: Reply with quote

Quote:
bastien@crust ~ % ldd /usr/bin/gmplayer | grep gtk
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb761c000)
libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0xb6e8a000)


Mais j'avoue avoir du mal a interpréter le résultat : pour moi, il utilise les deux (sic)
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 115

PostPosted: Sun Aug 27, 2006 2:03 pm    Post subject: Reply with quote

dans l'ebuild la dependance est gtk2
de plus je n'ai plus gtk1 sur mon systeme
(gros bidouillage des uses flag)

pour "man man" j'ai le meme probleme !
ca le fait aussi avec "man apropos" et "man whatis"

en fait, toutes les pages fr qui marchent sont issue du package "app-i18n/man-pages-fr"

les pages man, apropos, et whatis (en fr) viennent du package "sys-app/man"

donc surrement un probleme d'encodage de ces fichiers...
en attendant, je vais m'en passer :wink:
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Aug 27, 2006 2:11 pm    Post subject: Reply with quote

[mode ma_vie] En ce qui me concerne, je viens de passer tout mon système en anglais, donc je risque plus d'avoir ce genre de problème ^^, l'UTF-8 ne me sert plus que pour les noms de fichiers et les fichiers écrits en français (et pour quand je me mettrai sérieusement au japonais, ça sera plus facile :) ).
make.conf:
USE="... -nls ..."
LINGUAS=""

locale:
LANG=en_US.utf8
LC_CTYPE=fr_FR.utf8
LC_NUMERIC=fr_FR.utf8
LC_TIME=fr_FR.utf8
LC_COLLATE=fr_FR.utf8
LC_MONETARY=fr_FR.utf8
LC_MESSAGES=en_US.utf8
LC_PAPER=fr_FR.utf8
LC_NAME=fr_FR.utf8
LC_ADDRESS=fr_FR.utf8
LC_TELEPHONE=fr_FR.utf8
LC_MEASUREMENT=fr_FR.utf8
LC_IDENTIFICATION=fr_FR.utf8
LC_ALL=

[/mode ma_vie]
Back to top
View user's profile Send private message
daiji
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 101
Location: Lausanne, Suisse

PostPosted: Sun Aug 27, 2006 3:09 pm    Post subject: Reply with quote

Fifre wrote:
Quote:
bastien@crust ~ % ldd /usr/bin/gmplayer | grep gtk
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb761c000)
libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0xb6e8a000)


Mais j'avoue avoir du mal a interpréter le résultat : pour moi, il utilise les deux (sic)


Moi j'ai uniquement libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0, donc je suis ne gtk2, mais j'ai des problèmes d'accents.. décidément..
_________________
Le problème avec le cerveau c'est que le seul outil qui permette de l'étudier et d'améliorer son fonctionnement c'est.. le cerveau lui-même..
Back to top
View user's profile Send private message
ceric35
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2006
Posts: 115

PostPosted: Fri Sep 01, 2006 8:38 am    Post subject: Reply with quote

peut etre les uses flags alors ...

ou les locales generées

avoir "fr_FR.UTF-8 UTF-8" dans /etc/locale.gen
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum