Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dynamic linking consistency: broken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
crazyzed
Apprentice
Apprentice


Joined: 26 Mar 2004
Posts: 154

PostPosted: Sun Aug 27, 2006 9:30 pm    Post subject: dynamic linking consistency: broken Reply with quote

I'm running revdep-rebuild and get

Quote:
Checking dynamic linking consistency...
broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplay.la)
broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplay.la)
broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib/libmpeg2encpp.la (requires /usr/lib/libmjpegutils.la)
broken /usr/lib/libmplex2.la (requires /usr/lib/libmjpegutils.la)
broken /usr/lib/xmms/Input/libmp4.la (requires /usr/lib/libfaad.la)
broken /usr/lib64/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplay.la)
broken /usr/lib64/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib64/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib64/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplay.la)
broken /usr/lib64/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib64/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib64/libmpeg2encpp.la (requires /usr/lib/libmjpegutils.la)
broken /usr/lib64/libmplex2.la (requires /usr/lib/libmjpegutils.la)
broken /usr/lib64/xmms/Input/libmp4.la (requires /usr/lib/libfaad.la)
done.
(/root/.revdep-rebuild.3_rebuild)

but he doesn't want to emerge any packages.
Now I have 2 questions, why donesn't he try to emerge the packages that contain the missing files?
And how is the the easiest way to manually find out what packages that own these missing files?
Back to top
View user's profile Send private message
grenwald
n00b
n00b


Joined: 05 Aug 2006
Posts: 21
Location: Clermont-Ferrand / France

PostPosted: Sun Aug 27, 2006 9:35 pm    Post subject: Reply with quote

I've currently have no idea for the first question :(
For the second one, I think that
Code:
equery belongs $file
will do the work
_________________
there's only 10 types of people
Those who understand binary and the others
Back to top
View user's profile Send private message
crazyzed
Apprentice
Apprentice


Joined: 26 Mar 2004
Posts: 154

PostPosted: Sun Aug 27, 2006 10:56 pm    Post subject: Reply with quote

ah ok, thanx!

I have fixed some of the broken dependencies but I stil need the files:
libaviplay.la
libaviplayavformat.la
libaviplayavcodec.la
but I don't find what packages to emerge??

Quote:
Checking dynamic linking consistency...
broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplay.la)
broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplay.la)
broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib64/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplay.la)
broken /usr/lib64/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib64/avifile-0.7/ac3pass.la (requires /usr/lib/libaviplayavcodec.la)
broken /usr/lib64/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplay.la)
broken /usr/lib64/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavformat.la)
broken /usr/lib64/avifile-0.7/mp3lame_audioenc.la (requires /usr/lib/libaviplayavcodec.la)
done.
(/root/.revdep-rebuild.3_rebuild)
Back to top
View user's profile Send private message
hielvc
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2801
Location: Oceanside, Ca

PostPosted: Sun Aug 27, 2006 11:51 pm    Post subject: Reply with quote

These are all part of avifile. It is no longer in portage. Try " emerge -C avifile ". If that doesnt work
Code:

rm -r /usr/lib/avifile-0.7
rm -r /usr/lib64/avifile-0.7

You can go here, google "libaviplay.la" lib64avifile0.7-devel-0.7.43-3.20050620.3mdk.x86_64 RPM for a file listing . Then run " locate libavi " and " lacate avifile " and remove those occurences.

Then run revdep-rebuild again.
_________________
An A-Z Index of the Linux BASH command line
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Fri Sep 29, 2006 8:26 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 495514, post 3563723 in particular.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum