Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] media-libs/openal-0.0.8 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
boerns
Tux's lil' helper
Tux's lil' helper


Joined: 18 Mar 2004
Posts: 103

PostPosted: Sun Aug 27, 2006 9:21 am    Post subject: [solved] media-libs/openal-0.0.8 failed Reply with quote

Hi,

I changed my keyword from ~x86 to x86 and now emerg wants to downgrade openal.

I get this error. Does anybody know why?:

s/alc_backend.c' || echo './'`backends/alc_backend.c; \
then mv -f ".deps/libopenal_la-alc_backend.Tpo" ".deps/libopenal_la-alc_backend.Plo"; else rm -f ".dep
s/libopenal_la-alc_backend.Tpo"; exit 1; fi
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../common/include -I../include -I../src/arch/i38
6 -Wall -ansi -pedantic -finline-functions -ffast-math -fomit-frame-pointer -I/usr/include/alsa -I/usr
/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/SDL
-D_REENTRANT -I/usr/include/smpeg -I/usr/include/SDL -D_REENTRANT -O2 -march=i686 -mmmx -msse -fomit-
frame-pointer -pipe -MT libopenal_la-alc_backend.lo -MD -MP -MF .deps/libopenal_la-alc_backend.Tpo -c
backends/alc_backend.c -fPIC -DPIC -o .libs/libopenal_la-alc_backend.o
backends/alc_backend.c: In function `alcBackendSetAudioChannel_':
backends/alc_backend.c:462: warning: statement with no effect
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../common/include -I../include -I../src/arch/i38
6 -Wall -ansi -pedantic -finline-functions -ffast-math -fomit-frame-pointer -I/usr/include/alsa -I/usr
/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/SDL
-D_REENTRANT -I/usr/include/smpeg -I/usr/include/SDL -D_REENTRANT -O2 -march=i686 -mmmx -msse -fomit-
frame-pointer -pipe -MT libopenal_la-alc_backend.lo -MD -MP -MF .deps/libopenal_la-alc_backend.Tpo -c
backends/alc_backend.c -o libopenal_la-alc_backend.o >/dev/null 2>&1
if /bin/sh ../libtool --tag=CC --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..
/common/include -I../include -I../src/arch/i386 -Wall -ansi -pedantic -finline-functions -ffast-math
-fomit-frame-pointer -I/usr/include/alsa -I/usr/kde/3.5/include/artsc -pthread -I/usr/include/glib-2
.0 -I/usr/lib/glib-2.0/include -I/usr/include/SDL -D_REENTRANT -I/usr/include/smpeg -I/usr/include/
SDL -D_REENTRANT -O2 -march=i686 -mmmx -msse -fomit-frame-pointer -pipe -MT libopenal_la-x86_floatmul.
lo -MD -MP -MF ".deps/libopenal_la-x86_floatmul.Tpo" -c -o libopenal_la-x86_floatmul.lo `test -f 'arch
/i386/x86_floatmul.c' || echo './'`arch/i386/x86_floatmul.c; \
then mv -f ".deps/libopenal_la-x86_floatmul.Tpo" ".deps/libopenal_la-x86_floatmul.Plo"; else rm -f ".d
eps/libopenal_la-x86_floatmul.Tpo"; exit 1; fi
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../common/include -I../include -I../src/arch/i38
6 -Wall -ansi -pedantic -finline-functions -ffast-math -fomit-frame-pointer -I/usr/include/alsa -I/usr
/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/SDL
-D_REENTRANT -I/usr/include/smpeg -I/usr/include/SDL -D_REENTRANT -O2 -march=i686 -mmmx -msse -fomit-
frame-pointer -pipe -MT libopenal_la-x86_floatmul.lo -MD -MP -MF .deps/libopenal_la-x86_floatmul.Tpo -
c arch/i386/x86_floatmul.c -fPIC -DPIC -o .libs/libopenal_la-x86_floatmul.o
arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
arch/i386/x86_floatmul.c: In function `_alFloatMul':
arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i38
6.c:13224
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:https://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /var/tmp/portage/openal-0.0.8/temp/cc7P5xyq.out file, please attach th
is to your bugreport.
make[3]: *** [libopenal_la-x86_floatmul.lo] Fehler 1
make[3]: Leaving directory `/var/tmp/portage/openal-0.0.8/work/openal-0.0.8/src'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/openal-0.0.8/work/openal-0.0.8/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/openal-0.0.8/work/openal-0.0.8'
make: *** [all] Fehler 2

!!! ERROR: media-libs/openal-0.0.8 failed.
Call stack:
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
openal-0.0.8.ebuild, line 45: Called die

!!! emake failed
!!! If you need support, post the topmost build error, and the call stack if relevant.



Greetings

Alexander


Last edited by boerns on Sun Aug 27, 2006 9:48 am; edited 2 times in total
Back to top
View user's profile Send private message
boerns
Tux's lil' helper
Tux's lil' helper


Joined: 18 Mar 2004
Posts: 103

PostPosted: Sun Aug 27, 2006 9:48 am    Post subject: Reply with quote

sorry for the double-post

found the solution here https://forums.gentoo.org/viewtopic-t-488539-highlight-openal.html
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Aug 27, 2006 10:46 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum