Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[amarok] encore dead :( (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sat Aug 26, 2006 9:34 am    Post subject: [amarok] encore dead :( (résolu) Reply with quote

Bonjour, voilou, j'ai encore kc mon amarok. Une première fois au passage à gcc 4.1, puis maintenant, c'est du à l'installation d'un packet pour le support multilangue de kde (j'ai du recompilé kdelibs) et j'ai ceci à la compilation de amarok :

Code:

/libplugin.la ../../amarok/src/statusbar/libstatusbar.la ../../amarok/src/metadata/libmetadata.la -lkutils -lkio -lkdeui -lkdecore -lkhtml -lknewstuff -L/usr/lib -ltag -lGL  ../../amarok/src/sqlite/libsqlite.la
/usr/kde/3.5/lib/libkhtml.so: undefined reference to `__cxa_get_exception_ptr@CXXABI_1.3.1'
collect2: ld returned 1 exit status
make[4]: *** [amarokapp] Error 1
make[4]: Leaving directory `/var/tmp/portage/amarok-1.4.1-r3/work/amarok-1.4.1/amarok/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/amarok-1.4.1-r3/work/amarok-1.4.1/amarok/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/amarok-1.4.1-r3/work/amarok-1.4.1/amarok'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/amarok-1.4.1-r3/work/amarok-1.4.1'
make: *** [all] Error 2

!!! ERROR: media-sound/amarok-1.4.1-r3 failed.
Call stack:
  ebuild.sh, line 1543:   Called dyn_compile
  ebuild.sh, line 938:   Called src_compile
  amarok-1.4.1-r3.ebuild, line 77:   Called kde_src_compile
  kde.eclass, line 164:   Called kde_src_compile 'all'
  kde.eclass, line 323:   Called kde_src_compile 'myconf' 'configure' 'make'
  kde.eclass, line 319:   Called die

!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! This ebuild is from an overlay: '/usr/portage'


et ceci au démarrage :
Code:

loopx@loop-nb ~ $ amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarokapp: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /usr/kde/3.5/lib/libkhtml.so.4)


Tiens, peut etre reemerger libstdc++ :o

Le fichier libkhtml.so existe bien.
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org


Last edited by loopx on Sat Aug 26, 2006 9:42 am; edited 1 time in total
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sat Aug 26, 2006 9:41 am    Post subject: Reply with quote

Oki, je pense que j'ai trouvé :

Quote:
My problem is now solved. For anybody who has the same problem it was solved
by removing previous gcc's by emerge --prune gcc.
I have now successfully installed amarok and all is working.
Paul


donc emerge --prune gcc :D

EDIT: et ca fonctionne en plus !!!
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
PabOu
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1088
Location: Hélécine - Belgium

PostPosted: Sat Aug 26, 2006 2:08 pm    Post subject: Reply with quote

loopx wrote:
Oki, je pense que j'ai trouvé :

Quote:
My problem is now solved. For anybody who has the same problem it was solved
by removing previous gcc's by emerge --prune gcc.
I have now successfully installed amarok and all is working.
Paul


donc emerge --prune gcc :D

EDIT: et ca fonctionne en plus !!!


Si t'avais correctement suivi le guide de mise à jour GCC, tu n'aurais pas eu ce problème..

http://www.gentoo.org/doc/fr/gcc-upgrading.xml wrote:
# emerge -aC "<sys-devel/gcc-VOTRE-NOUVELLE-VERSION-DE-GCC"

_________________
Mangez du poulet !
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Aug 27, 2006 9:34 pm    Post subject: Reply with quote

Oh, merci pour l'info :)
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum