Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error emerging icewm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
godzilla
n00b
n00b


Joined: 26 Aug 2005
Posts: 29

PostPosted: Sat Aug 26, 2006 3:22 pm    Post subject: Error emerging icewm Reply with quote

I am trying to emerge icewm on my U5 box and it errors out like this:
Code:

if sparc-unknown-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -DGNOMELOCALEDIR=\""/usr/share/locale\"" -DGNOME_DESKTOP_SYSCONFDIR=\""/etc"\" -DGNOME_DESKTOP_PIXMAPDIR=\""/usr/share/pixmaps"\" -DGNOME_DESKTOP_ICONDIR=\""/usr/share/icons"\" -DGNOME_CORE_INTERNAL -Wall -Wmissing-prototypes   -DORBIT2=1 -pthread -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/gnome-keyring-1 -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/freetype2 -I/usr/include/libxml2 -I/usr/include/startup-notification-1.0      -O2 -mcpu=ultrasparc -pipe -MT test-ditem-edit.o -MD -MP -MF ".deps/test-ditem-edit.Tpo" -c -o test-ditem-edit.o test-ditem-edit.c; \
then mv -f ".deps/test-ditem-edit.Tpo" ".deps/test-ditem-edit.Po"; else rm -f ".deps/test-ditem-edit.Tpo"; exit 1; fi
/bin/sh ../libtool --tag=CC --mode=link sparc-unknown-linux-gnu-gcc  -O2 -mcpu=ultrasparc -pipe   -o libgnome-desktop-2.la -rpath /usr/lib -version-info 4:17:2 -no-undefined gnome-desktop-item.lo gnome-ditem-edit.lo gnome-hint.lo -pthread -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnome-keyring -lxml2 -lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgnomevfs-2 -lbonobo-2 -lgconf-2 -lgobject-2.0 -lbonobo-activation -lORBit-2 -lm -lgmodule-2.0 -ldl -lgthread-2.0 -lglib-2.0 -lstartup-notification-1
grep: /usr/lib/libXrender.la: No such file or directory
/bin/sed: can't read /usr/lib/libXrender.la: No such file or directory
libtool: link: `/usr/lib/libXrender.la' is not a valid libtool archive
make[3]: *** [libgnome-desktop-2.la] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/gnome-desktop-2.14.2/work/gnome-desktop-2.14.2/libgnome-desktop'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-desktop-2.14.2/work/gnome-desktop-2.14.2/libgnome-desktop'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-desktop-2.14.2/work/gnome-desktop-2.14.2'
make: *** [all] Error 2

!!! ERROR: gnome-base/gnome-desktop-2.14.2 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  ebuild.sh, line 1248:   Called gnome2_src_compile
  gnome2.eclass, line 64:   Called die

!!! compile failure
!!! If you need support, post the topmost build error, and the call stack if relevan


for some reason gnome-desktop-2.14.2 thinks that libXrender is installed, but it is not:
Code:

sparc ~ # emerge -s libXrender
Searching...
[ Results for search key : libXrender ]
[ Applications found : 1 ]

*  x11-libs/libXrender
      Latest version available: 0.9.1
      Latest version installed: [ Not Installed ]
      Size of files: 234 kB
      Homepage:      http://xorg.freedesktop.org/
      Description:   X.Org Xrender library
      License:       libXrender


Also, libXrender may not be installed according to emerge:
Code:

sparc ~ # emerge -pvD libXrender

These are the packages that would be merged, in order:

Calculating dependencies... done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.1.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.7)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/renderproto-0.9.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrender-0.9.1)
[ebuild  N    ] x11-misc/util-macros-1.1.0  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/kbproto-1.0.3  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xextproto-7.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xf86bigfontproto-1.1.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/inputproto-1.3.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xproto-7.0.7  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXau-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/bigreqsproto-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXdmcp-1.0.1  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xcmiscproto-1.1.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/xtrans-1.0.1  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libX11-1.0.3  USE="-debug -ipv6" 0 kB
[ebuild  N    ] x11-proto/renderproto-0.9.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXrender-0.9.1  USE="-debug" 0 kB

Total size of downloads: 0 kB


emerge --info
Code:

sparc ~ # emerge --info
Portage 2.1-r2 (default-linux/sparc/sparc64/2006.0/2.4, gcc-3.4.6, glibc-2.3.6-r4, 2.4.32-sparc-r6 sparc64)
=================================================================
System uname: 2.4.32-sparc-r6 sparc64 sun4u
Gentoo Base System version 1.12.4
ccache version 2.3 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.4.26-r1
ACCEPT_KEYWORDS="sparc"
AUTOCLEAN="yes"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=ultrasparc -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -mcpu=ultrasparc -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.mirrors.tds.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="sparc X apache2 arts avi berkdb bitmap-fonts cli crypt cups dba dlloader dri eds encode esd fbcon foomaticdb fortran gcc64 gd gdbm gif gnome gstreamer gtk gtk2 imlib isdnlog jpeg kde libwww mad mikmod motif mpeg ncurses nls ogg opengl oss pam pcre pdflib perl png pppd python qt3 readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts unicode v4l vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_mach64 video_cards_fbdev video_cards_ati"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Any Ideas how to fix this ?

Thanks...
Back to top
View user's profile Send private message
cyblord
Guru
Guru


Joined: 22 May 2006
Posts: 424
Location: Vancouver, Canada

PostPosted: Sat Aug 26, 2006 11:19 pm    Post subject: Reply with quote

try remerging libXrender?

Code:

emerge libXrender

_________________
'mmmmm Thinkpad...
Back to top
View user's profile Send private message
godzilla
n00b
n00b


Joined: 26 Aug 2005
Posts: 29

PostPosted: Sun Aug 27, 2006 1:14 am    Post subject: Reply with quote

does exactly the same as I mentioned before:
Code:

sparc ~ # emerge libXrender
Calculating dependencies... done!

!!! Error: the <=x11-base/xorg-x11-6.9 package conflicts with another package;
!!!        the two packages cannot be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

sparc ~ # emerge libXrender -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-misc/util-macros-1.1.0)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/kbproto-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xextproto-7.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xf86bigfontproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/inputproto-1.3.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libX11-1.0.3)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xproto-7.0.7)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXau-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/bigreqsproto-1.0.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXdmcp-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/xcmiscproto-1.1.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/xtrans-1.0.1)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-proto/renderproto-0.9.2)
[blocks B     ] <=x11-base/xorg-x11-6.9 (is blocking x11-libs/libXrender-0.9.1)
[ebuild  N    ] x11-misc/util-macros-1.1.0  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/kbproto-1.0.3  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xextproto-7.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xf86bigfontproto-1.1.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/inputproto-1.3.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xproto-7.0.7  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXau-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/bigreqsproto-1.0.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXdmcp-1.0.1  USE="-debug" 0 kB
[ebuild  N    ] x11-proto/xcmiscproto-1.1.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/xtrans-1.0.1  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libX11-1.0.3  USE="-debug -ipv6" 0 kB
[ebuild  N    ] x11-proto/renderproto-0.9.2  USE="-debug" 0 kB
[ebuild  N    ] x11-libs/libXrender-0.9.1  USE="-debug" 0 kB

Total size of downloads: 0 kB
Back to top
View user's profile Send private message
cyblord
Guru
Guru


Joined: 22 May 2006
Posts: 424
Location: Vancouver, Canada

PostPosted: Sun Aug 27, 2006 1:31 am    Post subject: Reply with quote

libXrender requires a number of other packages. However, these packages are blocked by xorg-x11.

you might have to unmerge xorg-x11, emerge libXrender, and then emerge xorg-x11.
_________________
'mmmmm Thinkpad...
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sun Aug 27, 2006 10:56 pm    Post subject: Reply with quote

I think that modular X.org is part of your problem. Taking a peak at the Migrating to Modular X HOWTO may help a bit.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum