Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"Удачно" обновился ), sos!sos!sos
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Vitas61
n00b
n00b


Joined: 24 Aug 2006
Posts: 12
Location: /Europe/Russia/Rostov region/Shakhty

PostPosted: Thu Aug 24, 2006 11:21 am    Post subject: "Удачно" обновился ), sos!sos!sos Reply with quote

ай нид хелп!!! у меня катастрофа!!! не могу афторизоваться под root'ом после не совсем удачного обновления.
обновил дерево:
Code:
#emerge --sync

всё ок.
потом обновляю систему без компиляции пакетов:
Code:
#emerge --update --deep --newuse --fetchonly world

после того как всё необходимое закачалось в distfiles. я начал прцесс компиляции.
Code:
#emerge --update --deep --newuse world

у меня выскочила предупреждение: блокировка пакетов. xorg 6.8 мешал 7.0
я разрешил эту проблему:
Code:
#emerge -Ca xorg-x11 virtual/x11
#emerge --deepclean

затем продолжил компиляцию.
брат попросил меня включить кину посматреть, ну я не отказал Ctrl+C... думаю да потом на ночь поставлю компилится и всё будет ОК! успело компильнутся кажись пакета 3 их 178 от силы.
затем ночью загружаю гентушну систему....
Code:
vitas login:root<Enter>

vitas login:

дык.... а афроризоваться не могу вот касяк.....
2 недели собирал систему себе и всё тут :'-(
Потом я загрузился у себя в основной системе (Zenwalk Linux).
и продолжил незаконченное дело (обновление генты).
Code:
#chroot /mnt/gentoo
# env-update
>> Regenerating /etc/ld.so.cache...
# source /etc/profile
и заново
Code:
#emerge --update --deep --newuse world

вся эта музыка закончилась ошибкой ... не помню что там точно
но что-то жаловалось на /usr/lib/X11/xkb....
перезагрузаюсь... и всё равно не могу авторизоваться...

Уважаемые эксперты!!! помогите!!! две недели моих стараний пропадают!!! что можно сделать в этом случае???
я в гентушных доках по переходу на xorg 7 http://www.gentoo.org/proj/en/desktop/x/x1...lar-x-howto.xml читал:
Quote:
Finally, if /usr/lib/X11/xkb (/usr/lib64/X11/xkb for 64-bit users) exists, it should be removed. This is a requirement for the xkeyboard-config package to install.

но я этого не сделал... т.к. не нашёл /usr/lib/X11/xkb...
может быть в этом проблема?
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Thu Aug 24, 2006 12:09 pm    Post subject: Re: "Удачно" обновился ), sos!sos!s Reply with quote

Vitas61 wrote:

Code:
#emerge --update --deep --newuse world

вся эта музыка закончилась ошибкой ... не помню что там точно
но что-то жаловалось на /usr/lib/X11/xkb....
перезагрузаюсь... и всё равно не могу авторизоваться...

Телепаты в отпуске... Подробнее!
Back to top
View user's profile Send private message
Vitas61
n00b
n00b


Joined: 24 Aug 2006
Posts: 12
Location: /Europe/Russia/Rostov region/Shakhty

PostPosted: Thu Aug 24, 2006 2:24 pm    Post subject: Re: "Удачно" обновился ), sos!sos!s Reply with quote

Laitr Keiows wrote:
Vitas61 wrote:

Code:
#emerge --update --deep --newuse world

вся эта музыка закончилась ошибкой ... не помню что там точно
но что-то жаловалось на /usr/lib/X11/xkb....
перезагрузаюсь... и всё равно не могу авторизоваться...

Телепаты в отпуске... Подробнее!

пожалуйста:
Code:
>>> emerge (3 of 70) x11-misc/xkeyboard-config-0.8 to /
>>> md5 files   ;-) xkeyboard-config-0.8.ebuild
>>> md5 files   ;-) files/digest-xkeyboard-config-0.8
>>> md5 src_uri ;-) xkeyboard-config-0.8.tar.bz2
 * Directory /usr/lib/X11/xkb should be
 * manually deleted/renamed/relocated before installing!

!!! ERROR: x11-misc/xkeyboard-config-0.8 failed.
!!! Function pkg_setup, Line 26, Exitcode 0
!!! Manually remove /usr/lib/X11/xkb
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
Vitas61
n00b
n00b


Joined: 24 Aug 2006
Posts: 12
Location: /Europe/Russia/Rostov region/Shakhty

PostPosted: Thu Aug 24, 2006 2:33 pm    Post subject: Reply with quote

как было сказано удалить... я и удалил /usr/lib/X11/xkb...
и вроде бы всё дальше пошло )))
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Thu Aug 24, 2006 2:58 pm    Post subject: Reply with quote

Продолжая ставить систему из основной системы сделать passwd root была попытка?..
Back to top
View user's profile Send private message
Vitas61
n00b
n00b


Joined: 24 Aug 2006
Posts: 12
Location: /Europe/Russia/Rostov region/Shakhty

PostPosted: Thu Aug 24, 2006 4:41 pm    Post subject: Reply with quote

зато выскачила новая ошибка:
Code:

In file included from src/libXNVCtrlAttributes/NvCtrlAttributes.c:26:
src/libXNVCtrlAttributes/NvCtrlAttributesPrivate.h:142: error: syntax error before "XvPortID"
src/libXNVCtrlAttributes/NvCtrlAttributesPrivate.h:144: error: syntax error before "XvPortID"
src/libXNVCtrlAttributes/NvCtrlAttributesPrivate.h:146: warning: no semicolon at end of struct or union
src/libXNVCtrlAttributes/NvCtrlAttributesPrivate.h:152: error: syntax error before "XvAdaptorInfo"
src/libXNVCtrlAttributes/NvCtrlAttributesPrivate.h:158: error: syntax error before '}' token
src/libXNVCtrlAttributes/NvCtrlAttributes.c: In function `NvCtrlGetDisplayAttribute':
src/libXNVCtrlAttributes/NvCtrlAttributes.c:306: error: dereferencing pointer to incomplete type
src/libXNVCtrlAttributes/NvCtrlAttributes.c:308: error: dereferencing pointer to incomplete type
src/libXNVCtrlAttributes/NvCtrlAttributes.c:310: error: dereferencing pointer to incomplete type
make: *** [.objs/NvCtrlAttributes.o] Ошибка 1

!!! ERROR: media-video/nvidia-settings-1.0.20051122-r3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  nvidia-settings-1.0.20051122-r3.ebuild, line 78:   Called die

!!! Failed to build nvidia-settings
!!! If you need support, post the topmost build error, and the call stack if relevant.
Back to top
View user's profile Send private message
Vitas61
n00b
n00b


Joined: 24 Aug 2006
Posts: 12
Location: /Europe/Russia/Rostov region/Shakhty

PostPosted: Thu Aug 24, 2006 4:42 pm    Post subject: Reply with quote

viy wrote:
Продолжая ставить систему из основной системы сделать passwd root была попытка?..

да... не помогло!
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Fri Aug 25, 2006 6:13 am    Post subject: Reply with quote

было такое у меня месяца 3 назад, возник конфликт между shadow и pam_login
система потребовала shadow, я убил pam_login, а shadow не поставил (не помню, почему)
результат описан выше
поэтому
Code:
emerge -С pam_login && emerge shadow
должны помочь
Back to top
View user's profile Send private message
Vitas61
n00b
n00b


Joined: 24 Aug 2006
Posts: 12
Location: /Europe/Russia/Rostov region/Shakhty

PostPosted: Tue Aug 29, 2006 6:09 am    Post subject: Reply with quote

fank wrote:
было такое у меня месяца 3 назад, возник конфликт между shadow и pam_login
система потребовала shadow, я убил pam_login, а shadow не поставил (не помню, почему)
результат описан выше
поэтому
Code:
emerge -С pam_login && emerge shadow
должны помочь

помогло
Back to top
View user's profile Send private message
Kee_Keekkenen
n00b
n00b


Joined: 01 Dec 2005
Posts: 34

PostPosted: Thu Aug 31, 2006 6:11 pm    Post subject: Reply with quote

я тоже так сглупил - собрал новую версию(7) Х, после выключил ноут - не было времени...
а система-то так и осталась не обновленной :(
а после залогиниться не смог, ливЦД помог - с него обновил систему и ОК
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum