Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[wget donc emerge] ne fonctionne plus !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Tue Aug 22, 2006 5:27 pm    Post subject: [wget donc emerge] ne fonctionne plus ! Reply with quote

Bonjour, j'ai un problème avec le portage, alors j'essaie actuellement un portage rescue, mais ca n'a pas l'air de fonctionner, en fait, je pense pas que portage soit mort, mais bien la commande wget :

Voici le début pour le portage rescue :

Code:

mouh loop # wget -P /usr/portage/distfiles http://distfiles.gentoo.org/distfiles/portage-2.1.tar.bz2
--19:36:21--  http://distfiles.gentoo.org/distfiles/portage-2.1.tar.bz2
           => `/usr/portage/distfiles/portage-2.1.tar.bz2.1'
Resolving distfiles.gentoo.org... 64.50.236.52, 64.50.238.52, 156.56.247.195, ...
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--19:36:23--  http://distfiles.gentoo.org/distfiles/portage-2.1.tar.bz2
  (try: 2) => `/usr/portage/distfiles/portage-2.1.tar.bz2.1'
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--19:36:25--  http://distfiles.gentoo.org/distfiles/portage-2.1.tar.bz2
  (try: 3) => `/usr/portage/distfiles/portage-2.1.tar.bz2.1'
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--19:36:28--  http://distfiles.gentoo.org/distfiles/portage-2.1.tar.bz2
  (try: 4) => `/usr/portage/distfiles/portage-2.1.tar.bz2.1'
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--19:36:32--  http://distfiles.gentoo.org/distfiles/portage-2.1.tar.bz2
  (try: 5) => `/usr/portage/distfiles/portage-2.1.tar.bz2.1'
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.


Le tout, avec la connexion internet active et fonctionnel ...

Une idée ? Parce la j'ai peur d'un coup, pas envie de réinstaller ce pc...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org


Last edited by loopx on Wed Aug 23, 2006 2:53 am; edited 1 time in total
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Tue Aug 22, 2006 11:26 pm    Post subject: Reply with quote

As tu résolu ton problème, au pire tu lances le cd d'installation et tu copies juste le binaire de wget si tu soupsonnes celui-ci d'être corrompu.
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Tue Aug 22, 2006 11:44 pm    Post subject: Reply with quote

Ils ont pas prévu une option pour utiliser curl par exemple ... tu peux tjrs le downloader et l'installer ou la version cvs aussi que j'utilises ...


@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Wed Aug 23, 2006 2:49 am    Post subject: Reply with quote

Oui, je vais essayer ca. Mais je me demande si ca provient pas d'ailleur, il parle de header ...

Je regarderai demain ;)


/etc/make.global
Code:

# Fetching command (5 tries, passive ftp for firewall compatibility)
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -P \${DISTDIR} \${URI}"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -P \${DISTDIR} \${URI}"


:s ... va falloir faire du man ...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
ryo-san
l33t
l33t


Joined: 17 Feb 2005
Posts: 729

PostPosted: Wed Aug 23, 2006 3:16 am    Post subject: Reply with quote

Quote:
...il parle de header


Dans ce cas la , je pense qu 'il te parle des entêtes http, j'suis pas expert mais il me semble bien qu'elles existent.
Le "1" a la fin des paquets est bizarre...
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Aug 23, 2006 3:43 am    Post subject: Reply with quote

ryo-san wrote:
Le "1" a la fin des paquets est bizarre...


Heuuu tu vois ça ou, j'ai beau relire je ne trouve pas, bon c'est vrai je resemble un peu à ça 8O
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 461
Location: Martinique

PostPosted: Wed Aug 23, 2006 4:41 am    Post subject: Reply with quote

ryo-san wrote:
Le "1" a la fin des paquets est bizarre...


Le 1 à la fin de /usr/portage/distfiles/portage-2.1.tar.bz2.1 c'est probablement parce que /usr/portage/distfiles/portage-2.1.tar.bz2 existe déjà.
Autant essayer avec l'option -c de wget, il poursuivra le téléchargement au lieu de le recommencer et de nommer le fichier autrement à chaque fois.

Enfin, si je ne dis pas trop de bêtise non plus.


Last edited by novazur on Wed Aug 23, 2006 3:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Wed Aug 23, 2006 2:06 pm    Post subject: Reply with quote

Il me faut autre chose que wget si je veux m'en sortir. Genre, sais pas quoi.

Qu'y a t'il d'aussi bien que wget ? Pour le ftp et http biensur ... ?
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8530
Location: ~Brussels - Belgique

PostPosted: Wed Aug 23, 2006 2:17 pm    Post subject: Reply with quote

Salut, c'est pas un problème wget, mais de serveurs temporairement indisponibles (en synchro ? surchargés ?)
réessaie et tout ira bien, avec wget ;)

Au mieux, vérifie ta liste de miroirs dans ton make.conf :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Wed Aug 23, 2006 2:17 pm    Post subject: Reply with quote

aHeum ! excusez cet intermède :)

mais ce matin j'ai eu des blocages sur certains paquets avec le mirroir par défaut
un chti coup de mirrorselect a résolu mon affaire

t'as essayé d'autres mirroirs loopx ?

EDIT: :lol: trop fort ! le même post à la même heure !
mais c'est moi qui suis deuz :cry:
_________________
benj

technicien professionnel, ascendant winner


Last edited by blasserre on Wed Aug 23, 2006 3:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Wed Aug 23, 2006 3:04 pm    Post subject: Reply with quote

novazur wrote:
ryo-san wrote:
Le "1" a la fin des paquets est bizarre...


Le 1 à la fin de /usr/portage/distfiles/portage-2.1.tar.bz2.1 c'est probablement parce que /usr/portage/distfiles/portage-2.1.tar.bz2 existe déjà.
Autant essayer avec l'option -c de wget, il poursuivra le téléchargement au lieu de le recommencer et de donner le fichier autrement à chaque fois.

Enfin, si je ne dis pas trop de bêtise non plus.


C'est exactement ça , j'ai eu pleins de problèmes avec cela pour des téléchargements intérrompus , il faut virer le fichier sinon tu risques de télécharger 3 ou 4 fichiers ds le genre, facile :lol: !!!! Je ne sais exactement d'ou cela vient mais les dev aurais pu nous mettre le choix de basculer sur un autre downloader ...

sinon , tu as curl qui est déjà sur ton système :
Code:
curl -f -L -O   URL


Il y a un soft sympa prozilla qui est en audit sécu , c'est dommage et je crois que sont developpement n'est pas très actif car depuis un moment j'ai installé la version svn qui est resté tjrs à la meme et maintenant j'arrive meme plus à me connecter à repository apparement ils doivent faire autre chose que régler ces problèmes de sécu :twisted: ...




@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Wed Aug 23, 2006 4:57 pm    Post subject: Reply with quote

ca commence très mal, j'ai pas curl sur le serveur !!!! Bizarre ca...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Wed Aug 23, 2006 5:01 pm    Post subject: Reply with quote

loopx wrote:
ca commence très mal, j'ai pas curl sur le serveur !!!! Bizarre ca...


Ben moi il a fallu que je l'emerge, il est pas par défaut sur le systeme...
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Wed Aug 23, 2006 5:08 pm    Post subject: Reply with quote

loopx wrote:
ca commence très mal, j'ai pas curl sur le serveur !!!! Bizarre ca...

t'as testé la soluce de XavierMiller (et accessoirement la mienne)
_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Wed Aug 23, 2006 7:30 pm    Post subject: Reply with quote

CryoGen wrote:
loopx wrote:
ca commence très mal, j'ai pas curl sur le serveur !!!! Bizarre ca...


Ben moi il a fallu que je l'emerge, il est pas par défaut sur le systeme...


C'est possible ... Sinon loopx , wget ne te fait quand meme pas cela avec tous le fichiers...
Tu peux aussi le downloader et le mettre ds le disttfiles , tu fais gaffe à la version et tu fais portage l'installer ...

Sinon, je viens d'écrire un script en ruby qui peut te l'installer si tu es téméraire :D :
http://www.guidelinux.org/phpBB/viewtopic.php?t=719&start=15


@ +
_________________
Get Up and Go !
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Wed Aug 23, 2006 8:31 pm    Post subject: Reply with quote

J'ai essayé d'emerger curl avec le mirroir belnet et avec un mirroir par défaut, ca change rien du tout 8O

Et oui, ca à l'air de le faire avec n'importe quel fichier ...

EDIT:
Code:

--22:48:33--  ftp://loopx:*password*@10.59.13.250/readme.txt
  (try: 3) => `readme.txt'
Connecting to 10.59.13.250:21... connected.
Logging in as loopx ...
Error in server response, closing control connection.
Retrying.

--22:48:36--  ftp://loopx:*password*@10.59.13.250/readme.txt
  (try: 4) => `readme.txt'
Connecting to 10.59.13.250:21... connected.
Logging in as loopx ...
Error in server response, closing control connection.
Retrying.


C'est un fichier qui se trouve à la racine : /readme.txt et je m'y suis connecté juste avant avec la commande ftp et j'ai téléchargé le fichier sans problème.


Une image : du serveur foireux :
Code:

mouh loop # wget http://www.gentoo.org.il/images/logo.png
--22:51:23--  http://www.gentoo.org.il/images/logo.png
           => `logo.png'
Resolving www.gentoo.org.il... 84.95.244.101
Connecting to www.gentoo.org.il|84.95.244.101|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.

--22:51:24--  http://www.gentoo.org.il/images/logo.png
  (try: 2) => `logo.png'
Connecting to www.gentoo.org.il|84.95.244.101|:80... connected.
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.


de mon portable:
Code:

loop-nb loopx # wget http://www.gentoo.org.il/images/logo.png
--22:41:41--  http://www.gentoo.org.il/images/logo.png
           => `logo.png'
Resolving www.gentoo.org.il... 84.95.244.101
Connecting to www.gentoo.org.il|84.95.244.101|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 29,260 (29K) [image/png]

100%[=======================================================================================================================================================>] 29,260        81.32K/s

22:41:41 (81.22 KB/s) - `logo.png' saved [29260/29260]


Je pense que je vais essayer de mettre les binaires ou truc du genre de wget ...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum