Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Message File size does not match (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lefoid
Apprentice
Apprentice


Joined: 05 Nov 2005
Posts: 232

PostPosted: Sun Aug 20, 2006 7:57 am    Post subject: [emerge] Message File size does not match (Résolu) Reply with quote

Salut
Lorsque j'essaie d'"emerger" qc-usb, la réponse que me donne :
Code:
emerge qc-usb

est :
Quote:
09:43:37 (267.49 KB/s) - « /usr/portage/distfiles/qc-usb-0.6.3.tar.gz » sauvegardé [148994]

>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking qc-usb-0.6.3.tar.gz
!!! Digest verification failed:
!!! /usr/portage/distfiles/qc-usb-0.6.3.tar.gz
!!! Reason: Filesize does not match recorded size
!!! Got: 148994
!!! Expected: 3712

Je suis passé à la version 0.6.4 avec :
Code:
ACCEPT_KEYWORDS="~x86" emerge qc-usb

Mais, dès lors que je fais un :
Code:
emerge --update --deep --newuse world

il veut revenir à la version 0.6.3 (ce qui est normal) et je me retrouve avec le même message.
Je pense savoir comment faire pour éviter le "downgrade" de qc-usb (en plaçant dans un fichier
~x86 media-video/qc-usb ou quelque chose d'équivalent !).
Ma question est plus de savoir comment réinitialiser portage pour qu'il retrouve la bonne valeur
de md5 pour, notamment, qc-usb ?
J'ai déjà fait :
Code:
emerge --sync
emerge -e portage

J'ai enlevé "à la mano" les versions téléchargées de qc-usb dans :
Quote:
/usr/portage/distfiles/

J'ai téléchargé qc-usb sur différents serveurs. Rien n'y a fait.
Il n'y a donc pas moyen de rétablir une liste correcte avec les bons fichiers md5 "simplement" ?
J'ai vu pas mal de fichiers "qui font pleins de choses" dans :
Quote:
/usr/lib/portage/bin

mais j'avoue ne pas trop savoir lequel utiliser (si tant est que l'un d'eux puisse avoir un quelconque
effet sur ce que je veux faire).
Y-a-t-il un fichier dans lequel sont stockés les "md5", fichier que l'on pourrait effacer et réinstaller
ensuite ?
Voila, c'est un peu long, désolé :wink:
Merci par avance.


Last edited by lefoid on Sun Aug 20, 2006 8:46 am; edited 1 time in total
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Sun Aug 20, 2006 8:19 am    Post subject: Re: [emerge] Message File size does not match Reply with quote

lefoid wrote:
Je suis passé à la version 0.6.4 avec :
Code:
ACCEPT_KEYWORDS="~x86" emerge qc-usb

Mais, dès lors que je fais un :
Code:
emerge --update --deep --newuse world

il veut revenir à la version 0.6.3 (ce qui est normal) et je me retrouve avec le même message.
Je pense savoir comment faire pour éviter le "downgrade" de qc-usb (en plaçant dans un fichier
~x86 media-video/qc-usb ou quelque chose d'équivalent !).

ACCEPT_KEYWORDS="~x86" c'est MAL
et comme tu as pu le remarquer c'est tout à fait inutile à moyen terme
il faut rajouter la ligne media-video/qc-usb ~x86 à /etc/portage/package.keywords
si tu veux que ce paquet reste instable
ou simplement ajouter =media-video/qc-usb-0.6.4 à ce même fichier
si tu veux utiliser la version instable en attendant qu'une version ultérieure stable apparaisse
Quote:

Ma question est plus de savoir comment réinitialiser portage pour qu'il retrouve la bonne valeur
de md5 pour, notamment, qc-usb ?
J'ai déjà fait :
Code:
emerge --sync
emerge -e portage

J'ai enlevé "à la mano" les versions téléchargées de qc-usb dans :
Quote:
/usr/portage/distfiles/

tu as employé la bonne méthode, mais il semble que l'ebuild n'ait pas été corrigé
(le mainteneur du paquet n'est peut-être pas au courant que le fichier téléchargé à changé)
le fait de régénérer le MD5 peut être dangereux car emerge va utiliser un fichier différent de celui qu'il attend
je te conseille donc d'utiliser la 0.6.4 si elle marche....

mais si tu désires vraiment utiliser la 0.6.3 tu peux régénérer les MD5 avec un :
ebuild /usr/portage/media-video/qc-usb/qc-usb-0.6.3.ebuild digest
_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sun Aug 20, 2006 8:25 am    Post subject: Reply with quote

+1 pour blasserre
Je suis en plein emerge -e world, et passer à la 0.6.4 a résolu le problème.
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
lefoid
Apprentice
Apprentice


Joined: 05 Nov 2005
Posts: 232

PostPosted: Sun Aug 20, 2006 8:46 am    Post subject: Reply with quote

Salut
Et bien, merci blasserre pour ton aide. J'ai quand même "régénérer" le md5 par :
Code:
ebuild /usr/portage/media-video/qc-usb/qc-usb-0.6.3.ebuild digest

Et tout fonctionne à nouveau. A vrai dire, j'aime bien être en "stable" et j'avoue
que passer par quelques ebuilds en "unstable" de temps à autre me cause plus
d'ennuis par la suite que si je reste en "stable". Donc, j'attendrai que la 0.6.4
passe en "stable", naturellement :wink:
En tous cas merci pour ta réponse claire et complète. Elle est gardée dans un coin pour
plus tard (oui, je ne désespère pas d'y avoir recours un de ces jours !!)
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Aug 20, 2006 9:12 pm    Post subject: Reply with quote

lefoid wrote:
Et bien, merci blasserre pour ton aide. J'ai quand même "régénérer" le md5 par

De toute les solutions c'est quand mème la plus dangeureuse, en effet, elle est pratique, mais on ne sait toujours pas pourquoi le MD5 ne correspond pas.
D'autant plus qu'il n'y a pas de rapport de bug la dessus et que vous semblez ètre plusieurs à rencontrer ce problème.
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)


Last edited by yuk159 on Sun Aug 20, 2006 9:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Aug 20, 2006 9:15 pm    Post subject: Re: [emerge] Message File size does not match Reply with quote

blasserre wrote:
ACCEPT_KEYWORDS="~x86" c'est MAL


Ah non, je t'assure, c'est bien :)

J'ai mis tout les desktop que j'install en instable 8)
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Aug 20, 2006 9:25 pm    Post subject: Re: [emerge] Message File size does not match Reply with quote

loopx wrote:
blasserre wrote:
ACCEPT_KEYWORDS="~x86" c'est MAL


Ah non, je t'assure, c'est bien :)

J'ai mis tout les desktop que j'install en instable 8)


Non, sous cette forme là c'est MAL, c'est le coté obscure de portage ;)
il faut utiliser les "package.keywords ect..", c'est ce que blasserre voulais dire.
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum