Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI-fglrx] Nouveau driver 8.28.8
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sat Aug 19, 2006 8:07 am    Post subject: [ATI-fglrx] Nouveau driver 8.28.8 Reply with quote

*Tadaaaaam*
Je ne fais pas chacune des sorties, mais celle là a un petit quelque chose qui me fait accélérer le palpitant:
ATI mon ami wrote:
ATI Pairmode Support

This release of the ATI Proprietary Linux driver introduces a new feature called Pairmode. This feature allows users to enable BigDesktop mode with two different screen resolutions. When using Xrandr, users can now dynamically switch between BigDesktop and Clone mode without having to restart the X Server.


Donc je vais pouvoir commencer à envisager sereinement de migrer mon dual-screen de 17" CRT vers du 19" TFT sans claquer 700€ minimum d'un coup :)

--
edit:
Vous savez quoi? Je me demande si je ne vais pas racheter une ATI, pour ma prochaine carte, sisi. Maintenant qu'on va avoir un dual screen avec xinerama et des résolution indépendantes sur les écrans, je ne vois plus trop ce qui manque en fonctionnalité. Nan, franchement, avoir une ATI sous linux, c'est plus la loose comme il y a 2 ans.
(pis en ce moment c'est ATI qui tire les prix vers le bas, alors bon, forcément, on aime bien :))
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Themis
n00b
n00b


Joined: 05 Feb 2005
Posts: 24

PostPosted: Sat Aug 19, 2006 8:49 am    Post subject: Reply with quote

Juste une question, je suis passé aux drivers libre ATI, parce qu'au passage à Xorg7.1 le drivers proprio ne marchait plus :/ Bien sur j'ai perdu en perff ... Quand est il avec ce nouveau drivers ?
( peut être que je suis completement à la masse et qu'on pouvais déjà le remettre, et dans ce cas je suis désolé de la question)
_________________
Neewb Gentoo
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sat Aug 19, 2006 9:10 am    Post subject: Re: [ATI-fglrx] Nouveau driver 8.28.8 Reply with quote

El_Goretto wrote:

--
edit:
Vous savez quoi? Je me demande si je ne vais pas racheter une ATI, pour ma prochaine carte, sisi. Maintenant qu'on va avoir un dual screen avec xinerama et des résolution indépendantes sur les écrans, je ne vois plus trop ce qui manque en fonctionnalité. Nan, franchement, avoir une ATI sous linux, c'est plus la loose comme il y a 2 ans.
(pis en ce moment c'est ATI qui tire les prix vers le bas, alors bon, forcément, on aime bien :))


+1 pareil si je dois me refaire un pc ce sera sans doute une ATI. (j'ai ati dans mon portable -drivers libres car radeon 7500 - mais sur mon pc la 9800pro est une trés bonne carte. Certes les débuts ont été difficiles mais par la suite : nickel.)
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Aug 19, 2006 9:17 am    Post subject: Reply with quote

Themis wrote:
Juste une question, je suis passé aux drivers libre ATI, parce qu'au passage à Xorg7.1 le drivers proprio ne marchait plus :/ Bien sur j'ai perdu en perff ... Quand est il avec ce nouveau drivers ?
( peut être que je suis completement à la masse et qu'on pouvais déjà le remettre, et dans ce cas je suis désolé de la question)

Les drivers ATi marchent avec xorg 7.1 depuis quelques temps déjà ;)
(GRRR, mais pourquoi j'ai une nvidia ! :cry: Dire qu'il y a quelques temps, c'était l'inverse... Mon prochain PC aura une ATI... )
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
matlerouge
n00b
n00b


Joined: 29 Aug 2004
Posts: 68

PostPosted: Sat Aug 19, 2006 11:58 am    Post subject: Reply with quote

Quote:
Les drivers ATi marchent avec xorg 7.1 depuis quelques temps déjà ;)
(GRRR, mais pourquoi j'ai une nvidia ! :cry: Dire qu'il y a quelques temps, c'était l'inverse... Mon prochain PC aura une ATI... )


mefie toi, j'ai une X1300 mobility et les drivers non libre. Pas moyen de faire fonctionner XVideo, et si tu met Composite tu n'as plus l'acceleration 3D. Bon j'ai pas fait encore beaucoup de recherche peut etre que ces problemes peuvent etre eliminer facilement

Alors que sur mon pc avec nvidia, tout marche nickel (sauf il est vrai, xorg 7.1 ;))
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sat Aug 19, 2006 9:49 pm    Post subject: Reply with quote

matlerouge wrote:
mefie toi, j'ai une X1300 mobility et les drivers non libre. Pas moyen de faire fonctionner XVideo, et si tu met Composite tu n'as plus l'acceleration 3D. Bon j'ai pas fait encore beaucoup de recherche peut etre que ces problemes peuvent etre eliminer facilement

Alors que sur mon pc avec nvidia, tout marche nickel (sauf il est vrai, xorg 7.1 ;))

Pour Xv:
ATI Mon pote wrote:
Known Issues (pour le 8.28.8 )
[...]
* Users with X Server X.org 7.1 can not play any video using XV. The ATI AVIVO Video adaptor is not present. Further details and the workaround can be found in topic number 737-22852


Pour Composite: http://fr.gentoo-wiki.com/TIP_Xorg_X11_et_transparence.

D'autres questions?

--
edit:
Désolé loopx, le lien automatique collait un pitit '.' a la fin.
Sinon moi j'utilise pas composite, alors faut demander à ceux qui savent :)
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312


Last edited by El_Goretto on Sun Aug 20, 2006 8:24 am; edited 2 times in total
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Aug 20, 2006 12:14 am    Post subject: Reply with quote

heu, c'est quoi le composite (le use xcomposite) ??? Faut le mettre ou non ?

J'ai pas appris grand chose avec ton lien :




TIP Xorg X11 et transparence.

(Il n'y a pour l'instant aucun texte sur cette page)

:D
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sun Aug 20, 2006 8:32 am    Post subject: Reply with quote

loopx wrote:
heu, c'est quoi le composite (le use xcomposite) ??? Faut le mettre ou non ?

J'ai pas appris grand chose avec ton lien :

TIP Xorg X11 et transparence.

(Il n'y a pour l'instant aucun texte sur cette page)

:D


Ben si il y a du texte. http://fr.gentoo-wiki.com/TIP_Xorg_X11_et_transparence moi j'ai bel est bien un mini howto qui explique comment avoir la transparence etc...
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
matlerouge
n00b
n00b


Joined: 29 Aug 2004
Posts: 68

PostPosted: Sun Aug 20, 2006 1:04 pm    Post subject: Reply with quote

Quote:
Pour Composite: http://fr.gentoo-wiki.com/TIP_Xorg_X11_et_transparence.

D'autres questions?


Ouais je l'ai bien sur lu cette page, mais bon ca ne resoud pas le problème de la désactivation de l'acceleration 3D quand composite est positionné.

Pour info

Code:
Option "AllowGLXWithComposite" "True"


Ne fonctionne qu'avec les driver nvidia
Back to top
View user's profile Send private message
theniaky
Guru
Guru


Joined: 23 Feb 2006
Posts: 452

PostPosted: Sun Aug 20, 2006 4:56 pm    Post subject: Reply with quote

Ouais, je reste septique sur ati quand même... J'ai une Radeon mobility 9700 SE sur mon pc portable et j'ai attendu longtemps avant que les drivers proprio ne soient compatible avec ma carte (à partir du 8.23) : avant il faillait bidouiller le driver pour que ça passe à peu près. Depuis la version 8.25 ça ne remarche plus lol, donc j'ai le choix entre le 8.23 et le 8.24 :cry:
Je sens que je vais connaître des moments de joies lorsque je serai obligé de passer à xorg 7.1
_________________
A New York les taxis sont jaunes, à Londres ils sont noirs et à Paris ils sont cons. Frédéric Beigbeder
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Aug 20, 2006 5:02 pm    Post subject: Reply with quote

theniaky wrote:
Ouais, je reste septique sur ati quand même... J'ai une Radeon mobility 9700 SE sur mon pc portable et j'ai attendu longtemps avant que les drivers proprio ne soient compatible avec ma carte (à partir du 8.23) : avant il faillait bidouiller le driver pour que ça passe à peu près. Depuis la version 8.25 ça ne remarche plus lol, donc j'ai le choix entre le 8.23 et le 8.24 :cry:
Je sens que je vais connaître des moments de joies lorsque je serai obligé de passer à xorg 7.1


et la 8.27 ? t'as pas essayé ?
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sun Aug 20, 2006 5:33 pm    Post subject: Reply with quote

theniaky wrote:
Ouais, je reste septique sur ati quand même... J'ai une Radeon mobility 9700 SE sur mon pc portable et j'ai attendu longtemps avant que les drivers proprio ne soient compatible avec ma carte (à partir du 8.23) : avant il faillait bidouiller le driver pour que ça passe à peu près. Depuis la version 8.25 ça ne remarche plus lol, donc j'ai le choix entre le 8.23 et le 8.24 :cry:
Je sens que je vais connaître des moments de joies lorsque je serai obligé de passer à xorg 7.1

Ben le mobility, faut savoir qu'ils refusent d'en assumer le support, ils renvoient vers les intégrateurs/constructeurs de portables. Ca, c'est pour Windows.
Donc si ya au moins qqs chose sous linux, et qui marchent (même bancale), j'en connais qui s'en sont satisfait d'aussi peu pendant pas mal de temps...
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
theniaky
Guru
Guru


Joined: 23 Feb 2006
Posts: 452

PostPosted: Sun Aug 20, 2006 5:59 pm    Post subject: Reply with quote

ah mais je ne jette pas la pierre a ATI : j'ai bien vu leurs efforts depuis quelques annees. Je trouvais juste bizzare qu'ils aient regle un problème juste pour 2 versions
Sinon, ca ne marche pas non plus avec les 8.27
Ca vient peut etre de mon xorg.conf que je n'ai pas fait evoluer avec les différentes versions
_________________
A New York les taxis sont jaunes, à Londres ils sont noirs et à Paris ils sont cons. Frédéric Beigbeder
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Aug 27, 2006 10:47 am    Post subject: Reply with quote

je pouvais pas me permettre de en pas poster ici :)
quelle bonne nouvelle en rentrant des vacances !!
il faut absolument que je teste si ça marche aussi avec la sortie TV !!
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sun Aug 27, 2006 12:34 pm    Post subject: Reply with quote

TVout-man is back, et en forme :)
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Aug 27, 2006 6:46 pm    Post subject: Reply with quote

Quand arrive t'il cet ebuild ...
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sun Aug 27, 2006 11:11 pm    Post subject: Reply with quote

oui entre temps j'ai syncé et j'ai pas vu l'ebuild :(
vivement qu'il arrive !!
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Sun Aug 27, 2006 11:13 pm    Post subject: Reply with quote

L'ebuild est ici : http://vipernicus.evolution-mission.org/files/ebuilds/ati-drivers-8.28.8.ebuild
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Mon Aug 28, 2006 5:47 am    Post subject: Reply with quote

Raaah, ca veut pas chez moi (cause noyau mm), et si j'utilise çà: https://forums.gentoo.org/viewtopic-t-479688-highlight-atidrivers+smp.html
ca marche guère mieux:
Code:
# emerge -av ati-drivers --digest

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-drivers/ati-drivers-8.28.8 [8.27.10-r1] USE="acpi opengl -doc" 0 kB [1]

Total size of downloads: 0 kB
Portage overlays:
 [1] /usr/local/portage

Would you like to merge these packages? [Yes/No]
>>> Creating Manifest for /usr/local/portage/x11-drivers/ati-drivers
>>> Emerging (1 of 1) x11-drivers/ati-drivers-8.28.8 to /
>>> checking ebuild checksums ;-)
>>> checking auxfile checksums ;-)
>>> checking miscfile checksums ;-)
>>> checking ati-driver-installer-8.28.8.run ;-)
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.18-rc4-mm2
 * Checking for MTRR support enabled ...                                                                    [ ok ]
 * Checking for AGP support enabled ...                                                                     [ ok ]
 * Checking for DRM support disabled ...                                                                    [ ok ]
 * X11 implementation is xorg-x11.
>>> Unpacking source...
 * Unpacking Ati drivers ...                                                                                [ ok ]
 * Applying ati-powermode.sh.patch ...                                                                      [ ok ]
 * Applying ati-drivers-mm.patch ...

 * Failed Patch: ati-drivers-mm.patch !
 *  ( /usr/local/portage/x11-drivers/ati-drivers/files/ati-drivers-mm.patch )
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/ati-drivers-8.28.8/temp/ati-drivers-mm.patch-15556.out


!!! ERROR: x11-drivers/ati-drivers-8.28.8 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_unpack
  ebuild.sh, line 711:   Called src_unpack
  ati-drivers-8.28.8.ebuild, line 158:   Called epatch '/usr/local/portage/x11-drivers/ati-drivers/files/ati-drivers-mm.patch'
  eutils.eclass, line 341:   Called die

!!! Failed Patch: ati-drivers-mm.patch!
!!! If you need support, post the topmost build error, and the call stack if relevant.


/var/tmp/portage/ati-drivers-8.28.8/temp/ati-drivers-mm.patch-15556.out:
Code:
***** ati-drivers-mm.patch *****

================================

PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch < /usr/local/portage/x11-drivers/ati-drivers/files/ati-drivers-mm.patch

================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- firegl_public.c.orig   2006-07-14 07:44:52.000000000 +0300
|+++ firegl_public.c   2006-07-14 07:46:25.000000000 +0300
--------------------------
No file to patch.  Skipping patch.
patch: **** malformed patch at line 15: /* The dirty-page-tracking patch included in NLD 9 SMP kernels defines

================================
[...]


Bon, j'essaierai un 2.6.18 pas mm, mais j'ai peur de ne pas booter du tout dans ce cas (faute à la carte mère trop récente).
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Mon Aug 28, 2006 6:03 am    Post subject: Reply with quote

guilc wrote:
Themis wrote:
Juste une question, je suis passé aux drivers libre ATI, parce qu'au passage à Xorg7.1 le drivers proprio ne marchait plus :/ Bien sur j'ai perdu en perff ... Quand est il avec ce nouveau drivers ?
( peut être que je suis completement à la masse et qu'on pouvais déjà le remettre, et dans ce cas je suis désolé de la question)

Les drivers ATi marchent avec xorg 7.1 depuis quelques temps déjà ;)
(GRRR, mais pourquoi j'ai une nvidia ! :cry: Dire qu'il y a quelques temps, c'était l'inverse... Mon prochain PC aura une ATI... )

c'est bon avec les nouveaux drivers nvidia, ce problème est réglé apparement.
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Fri Sep 01, 2006 10:43 am    Post subject: Reply with quote

voila c'est dans portage en ~
je teste très bientôt !!
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Fri Sep 01, 2006 11:56 pm    Post subject: Reply with quote

Heu, bete question, ou peut on connaitre les options à mettre dans le xorg.conf pour les drivers ATI ??? Il y a pas une liste avec explication de TOUTE les options ?
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Sep 02, 2006 5:21 am    Post subject: Reply with quote

Je viens de changer pour une Ati et je suis intéressé par la même chose que toi @loopx :D c'est pas évident de trouvé les options et surtout à quoi elles servent.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Sat Sep 02, 2006 11:41 am    Post subject: Reply with quote

HAhahaha. :twisted:

Ben si vous trouvez quelque chose dans le genre, vous me faites signe ;)
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Sat Sep 02, 2006 11:54 am    Post subject: Reply with quote

personnellement je touche pas trop au xorg.conf, mais j'utilise l'outil aticonfig qui le génère
la ya plein de possibilités, mais je les comprend pas toutes non plus
j'arrive à activer la tv sans redémarrer ma session X, mais j'arrive toujours pas à lui donner une autre résolution que mon écran...
mais je vais encore essayer !!
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum