Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to develop using kdevelop (ltmain version mismatch)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jmp_
Apprentice
Apprentice


Joined: 02 Oct 2005
Posts: 293
Location: BCN / Catalonia (Spain)

PostPosted: Tue Aug 15, 2006 7:20 pm    Post subject: Unable to develop using kdevelop (ltmain version mismatch) Reply with quote

Hi all,

I was trying to develop somethings using KDevelop 3.3.4 (under KDE 3.5.3) and Gentoo:
Quote:

2.6.16-hardened-r6 #14 PREEMPT Sun Jul 23 23:06:02 CEST 2006 i686 Mobile AMD Sempron(tm) Processor 3000+ AuthenticAMD GNU/Linux


The problem is there's no way to get something built and run it, while running "automake & friends" I always got this error:

Code:

checking for correct ltmain.sh version... no
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.22, ltmain.sh = 1.5a) ***

Please run:

libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.

*** Exited with status: 1 ***


y also got this error (when trying the default hello world from kdevelop):
Quote:

cd '/home/fluid/test' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir '/home/fluid/test/debug' && cd '/home/fluid/test/debug' && CXXFLAGS="-O0 -g3" "/home/fluid/test/configure" --enable-debug=full && cd '/home/fluid/test/debug/src' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k test.lo
aclocal
autoheader
autoheader-2.60: error: AC_CONFIG_HEADERS not found in configure.in
gmake: *** [all] Error 1
*** Exited with status: 2 ***


And I don't know how to solve that, I'm trying to find how to upgrade "ltmain".

My versions of automake, libtool, binutils, make and autoconf seems to be up to date.

Anyone knows how to solve that ? any advice?

thanks in advance, and greetings from Barcelona (Spain).

P.D.: I use x86 and ~x86
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7817

PostPosted: Fri Nov 02, 2007 4:00 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Libtool.m4 and ltmain.sh Problems". This problem has been reported in the KDE bug tracking system, where it has been marked as an invalid bug, though it is also mentioned in the kdevelop FAQ.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum