Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
update -> no internet
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Kaste
Guru
Guru


Joined: 21 Dec 2005
Posts: 535
Location: /home Sweet /home

PostPosted: Mon Aug 14, 2006 10:44 am    Post subject: update -> no internet Reply with quote

Yesterday I tried updating my machine after not using it for two weeks and everything seemed fine and i quit halfway through because i wanted to go to bed. Today I started and this is the error message i got :
Quote:

...
/etc/init.d/net.eth0: line34: /lib/rcscripts/net.modules.d/helpers.d/functions: No such file or directory
Starting
find: /lib/rcscripts/net.modules.d/: No such file or directory
...

This is extremly annoying since i have no access to the internet anymore and i don't quite see how to fix it without Internet. Following are the packages from /var/log/emerge.log that were updated so far:
Quote:

x11-misc/util-macros-1.1.0
x11-proto/kbproto-1.0.3
x11-libs/libXau-1.0.2
sys-apps/portage-2.1.1_pre5
sys-apps/man-pages-2.38
sys-apps/baselayout-1.12.4-r2
sys-kernel/suspend2-sources-2.6.17-r4
media-libs/mesa-6.5-r4
sys-libs/com_err-1.39
sys-libs/ss-1.39
sys-fs/e2fsprogs-1.39
media-libs/tiff-3.8.2-r2
app-arch/unzip-5.52-r1
sys-apps/gawk-3.1.5-r2
dev-db/sqlite-3.3.5-r1
app-text/acroread-7.0.8
sys-apps/findutils-4.3.0
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Mon Aug 14, 2006 10:48 am    Post subject: Reply with quote

Kaste,

Try etc-update *carefully*.

It looks like something has changed that needs an updated script. The script will be waiting for you to install it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Kaste
Guru
Guru


Joined: 21 Dec 2005
Posts: 535
Location: /home Sweet /home

PostPosted: Tue Aug 15, 2006 11:06 am    Post subject: Reply with quote

Thanks a lot, it helped. Should have thought about that first. I'll remember next time.
Back to top
View user's profile Send private message
Teiresias
n00b
n00b


Joined: 07 Jun 2005
Posts: 6

PostPosted: Tue Aug 15, 2006 3:57 pm    Post subject: Reply with quote

Hi, I'm having the same problem, but when I ran dispatch-conf did not help. Can you say what etc-update updated for you ?

Edit: Nevermind, found a solution to the problem my self. Needed to replace my net.ethX init scripts to be sym link to net.lo.

/lock
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Tue Aug 22, 2006 9:14 am    Post subject: Reply with quote

Moved from Networking & Security to Duplicate Threads in favour of Missing /lib/rcsripts/net.modules.d [SOLVED].
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum