Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] can't upgrade sandbox!! access_wr violation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
chrisduck
Apprentice
Apprentice


Joined: 30 Jun 2004
Posts: 283
Location: California

PostPosted: Mon Aug 14, 2006 4:14 am    Post subject: [SOLVED] can't upgrade sandbox!! access_wr violation Reply with quote

I tried emergeing qdvdauthor, and one of the dependencies (urt) failed to emerge, giving this error
Code:
ACCESS DENIED  access_wr: /
>>> Source unpacked.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-media-libs_-_urt-3.1b-r1-15017.log"

access_wr: /
--------------------------------------------------------------------------------


After searching the forums, I found the solution to this type of thing was to update sandbox, but when I try to update sandbox (I'm using 1.2.11 atm), I get this error
Code:
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-sys-apps_-_sandbox-1.2.18.1-15227.log"

access_wr: /
--------------------------------------------------------------------------------


what do I do?
The log files only contain the line "access_wr: /"


Last edited by chrisduck on Mon Aug 14, 2006 4:59 am; edited 1 time in total
Back to top
View user's profile Send private message
chrisduck
Apprentice
Apprentice


Joined: 30 Jun 2004
Posts: 283
Location: California

PostPosted: Mon Aug 14, 2006 4:59 am    Post subject: Reply with quote

sorry for wasting space here, but the solution was to unmerge the old sandbox before emerging the new one.
Back to top
View user's profile Send private message
saffsd
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2006
Posts: 139

PostPosted: Sun Aug 20, 2006 3:08 am    Post subject: Reply with quote

Not a waste of space actually. I faced the same problem, this solved it :)
Back to top
View user's profile Send private message
mars-red
Apprentice
Apprentice


Joined: 15 Sep 2004
Posts: 204
Location: New Hampshire

PostPosted: Sun Aug 20, 2006 6:32 pm    Post subject: Reply with quote

Amen to that! This just helped me out too. Thanks!
_________________
my wrench blog: http://www.digitaldownpour.com/blog
Back to top
View user's profile Send private message
Bionut
n00b
n00b


Joined: 29 Mar 2004
Posts: 34
Location: south australia

PostPosted: Wed Sep 13, 2006 4:26 pm    Post subject: Reply with quote

far from a waste of space actually... THANKS, it solved some very trying problems
Back to top
View user's profile Send private message
Theophile
Apprentice
Apprentice


Joined: 31 Mar 2004
Posts: 285

PostPosted: Thu Sep 14, 2006 2:28 pm    Post subject: Reply with quote

Yay! This solved 48 hours of frustration for me too! Thanks!
_________________
Monopedilos
Back to top
View user's profile Send private message
thepustule
Apprentice
Apprentice


Joined: 22 Feb 2004
Posts: 210
Location: Toronto, Canada

PostPosted: Fri Sep 15, 2006 12:41 pm    Post subject: Nice Reply with quote

And another one here too. Thanks!
Back to top
View user's profile Send private message
shanew
n00b
n00b


Joined: 16 Sep 2006
Posts: 34
Location: Austin, TX

PostPosted: Sat Sep 16, 2006 4:49 pm    Post subject: Reply with quote

You can also just run:

Code:
FEATURES="-sandbox" emerge sandbox
Back to top
View user's profile Send private message
Errtu
Apprentice
Apprentice


Joined: 12 Nov 2002
Posts: 155
Location: Brazil

PostPosted: Wed Sep 20, 2006 11:01 am    Post subject: Reply with quote

Big thank you from me too. I was about to start installing all over again. Now i can continue with the next box :D


Btw, for those who're interrested; this happened after i (accidently) installed from a 2005.0 cd and upgraded to a 2006.1 profile. Everything went fine until i tried to emerge vixie-cron.


edit: haha i just realized that after 4 years of using gentoo, i'm still noob status. Perhaps i should start answering questions or something :oops:
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4838
Location: Gothenburg, Sweden

PostPosted: Tue Oct 10, 2006 8:33 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of topic 496043.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum