Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How do I start adesklets??!?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
williamjonah
Apprentice
Apprentice


Joined: 16 Sep 2005
Posts: 163

PostPosted: Sun Aug 13, 2006 4:23 am    Post subject: How do I start adesklets??!? Reply with quote

I just emerged adesklets, and ran adesklets_install.... I installed a few of the desklets that I wanted and then ran adesklets, and nothing happened..... obviously i am doing someting wrong, can someone please help... how do I start these little turds off? Any help is appreciated.

Will :oops:
_________________
http://www.geekbin.net


Last edited by williamjonah on Tue Aug 15, 2006 8:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
Iced-Tux
Apprentice
Apprentice


Joined: 14 Apr 2004
Posts: 183
Location: Germany, Cologne

PostPosted: Sun Aug 13, 2006 10:03 am    Post subject: Reply with quote

Hi,
you have to register your adesklets. So run the python scripts of your desklets it will ask whether you want to test odr register it.
Register --> run adesklets --> new desklet shows up :)
_________________
!! The road to hell is full of good intentions !!
Back to top
View user's profile Send private message
williamjonah
Apprentice
Apprentice


Joined: 16 Sep 2005
Posts: 163

PostPosted: Sun Aug 13, 2006 4:06 pm    Post subject: Reply with quote

it worked!! thanks!
_________________
http://www.geekbin.net
Back to top
View user's profile Send private message
williamjonah
Apprentice
Apprentice


Joined: 16 Sep 2005
Posts: 163

PostPosted: Tue Aug 15, 2006 8:33 pm    Post subject: Reply with quote

New problem, I am trying to get the mailer to work, and for some reason, it doesnt want to check my mail. I keep getting a connection error. I posted below, my config.txt...
Code:
id0 = {'background_color': '1E1E1E',
 'background_gradient_cutpoint': 40,
 'background_opacity': 100,
 'caption': 'Geekbin Mail',
 'caption_color': 'FFFFFF',
 'caption_font': 'Vera',
 'caption_font_size': 10,
 'click_anytime': True,
 'delay': 60,
 'host': 'mail.geekbin.net',
 'icon_height': 48,
 'icon_width': 48,
 'icons': ['error.png', 'noemail.png', 'email.png'],
 'mailspool': '/dev/null',
 'message_color': None,
 'message_font': None,
 'message_font_size': None,
 'messages': ['not connected to mail server',
              'no new message on mail server',
              '1 new message on mail server',
              'new messages on mail server'],
 'messages_prepend': True,
 'method': 'pop3',
 'program_on_click': 'thunderbird',
 'program_on_new': 'beep.sh',
 'ssl': False,
 'text_padding': 5,
 'user_name': 'POP3 ACCOUNT NAME',     <--- I changed it
 'user_password': 'PASSWORD FOR POP3 ACCOUNT',  <--- I Changed it
 'window_never_shrink': False}


Any help is appreciated. I just want to see anything besides "not connected to mail server". Thanks
_________________
http://www.geekbin.net
Back to top
View user's profile Send private message
Iced-Tux
Apprentice
Apprentice


Joined: 14 Apr 2004
Posts: 183
Location: Germany, Cologne

PostPosted: Tue Aug 15, 2006 10:31 pm    Post subject: Reply with quote

What is the output when you run the desklet in test mode?

I tried the package available at adesklets.sourceforge.net and it worked fine with both imap4 and pop3 accounts. So perhaps the output of the plugin gives you some information?
_________________
!! The road to hell is full of good intentions !!
Back to top
View user's profile Send private message
williamjonah
Apprentice
Apprentice


Joined: 16 Sep 2005
Posts: 163

PostPosted: Wed Aug 16, 2006 1:11 am    Post subject: Reply with quote

Code:
delta@localhost ~/.desklets/mailer-0.0.8 $ ./mailer1.py
Do you want to (r)egister this desklet or to (t)est it? t
Now testing...
============================================================
If you do not see anything (or just an initial flicker
in the top left corner of your screen), try `--help',
and see the FAQ: `info adesklets'.
============================================================
./beep.sh: line 15: /dev/:0: Permission denied


I tried two different accounts, one worked, but the mail email didnt. the one that worked was pop3, the one that didnt was imap4. Any ideas why I could be getting "Permissions denied"?? BTW, thanks, I didn't even think to view the output from term. Appreciate the help thus far.

-Will
_________________
http://www.geekbin.net
Back to top
View user's profile Send private message
Iced-Tux
Apprentice
Apprentice


Joined: 14 Apr 2004
Posts: 183
Location: Germany, Cologne

PostPosted: Wed Aug 16, 2006 7:12 am    Post subject: Reply with quote

Ok I looked into beep.sh:
Code:

#!/bin/sh
#
# Written by S.Fourmanoit, 2005
#
# Small script, probably not portable across UNIXes,
# That sends a bell character (ascii 0x07) to the first writable terminal
# device (i.e. own by the current user). This has only been tested
# on linux systems, with GNU sed, cut from GNU coretutils, w from
# procps and GNU which. Bourne script by itself should be POSIX
# 1003.2 and 1003.2a compliant.

DEV=`w -hu \`whoami\` | \
      sed -n '1{s/[[:space:]]\+/\t/g;p}' | cut -f2`
: ${DEV:=null}
`which echo` -n -e '\a' > /dev/$DEV


And it seems to me, that whatever terminal device it finds, you havn't the appropriate permissions.
You could leave the beep out in your config.txt OR you can substitute it with your own script e.g where you execute `mpg123 YouGotMailBaby.mp3` or something similiar.

Quote:
I tried two different accounts, one worked, but the mail email didnt. the one that worked was pop3, the one that didnt was imap4. Any ideas why I could be getting "Permissions denied


Does that mean two different user on your system or just two different email accounts?
_________________
!! The road to hell is full of good intentions !!
Back to top
View user's profile Send private message
williamjonah
Apprentice
Apprentice


Joined: 16 Sep 2005
Posts: 163

PostPosted: Wed Aug 16, 2006 9:15 pm    Post subject: Reply with quote

First, to awnser your question, I have two email accounts, one for my website, and the other from aol... (i hate aol, but the wife "has" to have it)

Second, I cp'ed the the mailer-0.0.8 dir and put all of the second email account info into the config and it worked. I was trying to do id0 and id1 in just one config. All I had to do was register the sencond one, and voila!!

I really appreciate your help in this! Talk with you later bud.

Will
_________________
http://www.geekbin.net
Back to top
View user's profile Send private message
MickKi
Veteran
Veteran


Joined: 08 Feb 2004
Posts: 1128
Location: 51:45:20N, 0:40:44W

PostPosted: Wed Mar 07, 2007 4:42 pm    Post subject: Reply with quote

Hi All,

Am I supposed to run adesklets_installer as root? When I run it as a plain user and hit return on a chosen desklet it just says "Downloading weatherforecast desklet..." but nothing much happens thereafter. Am I supposed to run the installer as root?
_________________
Regards,
Mick
Back to top
View user's profile Send private message
otisranson
Apprentice
Apprentice


Joined: 17 May 2007
Posts: 188

PostPosted: Mon Aug 13, 2007 6:51 pm    Post subject: Reply with quote

MickKi wrote:
Hi All,

Am I supposed to run adesklets_installer as root? When I run it as a plain user and hit return on a chosen desklet it just says "Downloading weatherforecast desklet..." but nothing much happens thereafter. Am I supposed to run the installer as root?


No. Run as the user. They take a little while to install.
Back to top
View user's profile Send private message
MickKi
Veteran
Veteran


Joined: 08 Feb 2004
Posts: 1128
Location: 51:45:20N, 0:40:44W

PostPosted: Mon Aug 13, 2007 8:52 pm    Post subject: Reply with quote

Thanks.

There was a problem with some missing font, from what I recall. I changed the adesklet file to call a different font and was able to launch it thereafter.
_________________
Regards,
Mick
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum