Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't boot from SATA HD?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
reneviht
n00b
n00b


Joined: 09 Aug 2006
Posts: 53

PostPosted: Fri Aug 11, 2006 4:22 am    Post subject: Reply with quote

Well, this is odd. Rebuilding the kernel worked (and now I know a way to do it, too) but it turns out I was getting two distinct error messages. I fixed the one that the thread I linked to discussed, but I'm not sure what to do about the other one.
Code:
/etc/host.conf: line 24: bad command `mdns off'

I seem to have access to most - if not all - of my system now, though. Should I ask about this in the installation forum? The installation docs don't seem to mention host.conf explicitly anywhere.

Again, thank you, mno and FantomKnight for your assistance.
_________________
Never assume a mistake is too elementary for me to have made it.
Back to top
View user's profile Send private message
mno
Guru
Guru


Joined: 29 Dec 2003
Posts: 452
Location: Toronto, Canada

PostPosted: Fri Aug 11, 2006 11:26 am    Post subject: Reply with quote

Not quite sure what that means... so yes, you should prbably start a separate thread for that one.
_________________
"Hello and goodbye. As always." | You can't use   here?? | Unanswered
Back to top
View user's profile Send private message
Stijnsbox
n00b
n00b


Joined: 08 May 2006
Posts: 5

PostPosted: Sat Oct 07, 2006 7:17 am    Post subject: Reply with quote

Hi,

I have exactly the same problem as renevhit (at least a part of it).
(d975xbx motherboard with last bios versoin, E6600 CPU)
HD is recognized by the BIOS and by the gentoo Installer
Booting from SATA DVD-RW drive with gentoo 2006.1 live CD works (and everything seems to be detected)
I can partition the HD and install gentoo (manual install using the root shell on the Live CD) on a Samsumg Spinpoint 250GB SATA HD

I seem to be able to install GRUB and also LILO.
but when I reboot the Motherboard tells me that no bootable media is found.
(GRUB or LILO are not even started!)

Boot order in the BIOS is first CD-ROM, then HardDisk and the SATA harddisk is the only harddisk in the system => hd0 (I can change the order in the BIOS but there is only 1 ;-) ).
Both SATA devices (DVD and HD) are connected to the ICH7 SATA controller (not the extra SATA controller)

Any Idea what I'm doing wrong?
Should I change something in the BIOS on this MB before it will boot to my SATA HD?
Have some sata HDs a protected MBR?
...

All suggestions are welcome!!!
thanks
Stijn
Back to top
View user's profile Send private message
reneviht
n00b
n00b


Joined: 09 Aug 2006
Posts: 53

PostPosted: Sat Oct 07, 2006 3:46 pm    Post subject: Reply with quote

Hello, Stijnsbox.

The error you describe is exactly the one I got when I forgot to include the correct low-level device driver support in the kernel. With the 2.6.17-gentoo-r8, in the make menuconfig menu, it would be under

Device Drivers--> SCSI Device Support --> SCSI low-level drivers--> < > Serial ATA (SATA) Support

Once you select this (it seems it won't work if built as a module, so build it directly into the kernel) you would then select the specific controller you need. Since you have the same motherbord as me, that would be

< > Intel PIIX/ICH SATA support

If your error is caused by the same thing mine was caused by, then this should fix it.
_________________
Never assume a mistake is too elementary for me to have made it.
Back to top
View user's profile Send private message
Stijnsbox
n00b
n00b


Joined: 08 May 2006
Posts: 5

PostPosted: Sat Oct 07, 2006 9:15 pm    Post subject: Reply with quote

Thanks for the fast answer!

I forgot to enable that indeed but it does not seem to solve the boot issue.
I recompiled the kernel and GRUB (and reconfigured them).

It seems that the BIOS of the motherboard still does not recognize the MBR of the Harddisk.
Should I change something in the bios?

This is my setting in Advance/Drive:
Use Automatic Mode <Enable>
ATA/IDE Mode <Enhanced>
Configure SATA as <AHCI> (would like hot pluggable)
S.M.A.R.T <Enable>
SATA Port 0 SAMSUNG SP2504C - 250.0 GB
...
Gard Disk Pre-Delay [0]


I seem to be able to get the requested GRUB menu if I boot with a SUSE 10.0 DVD and select boot from HD.
I must have still configured something wrong there too since I get a kernel panic (root incorrect in grub).
Did you compile everyting for a 32-bit cpu or for a 64-bit cpu?

thanks!
Stijn
Back to top
View user's profile Send private message
reneviht
n00b
n00b


Joined: 09 Aug 2006
Posts: 53

PostPosted: Sat Oct 07, 2006 11:37 pm    Post subject: Reply with quote

Hmm, my processor should be a 64-bit cpu, but I can't find where in the installation instructions it asks me to specify (beyond which processor family) so I can't look it up. Sorry. Upon inspection, I may have chosen the wrong processor family for my machine, so I'll experiment with that a bit.

It occurred to me that I also had this problem when I forgot to make one of my partitions bootable during the "Preparing the Disks" stage. If you can't remember, it may be worth it to fire up fdisk and check.

Hopefully, one of the many people more experienced than me will find this problem worthy of their time.
_________________
Never assume a mistake is too elementary for me to have made it.
Back to top
View user's profile Send private message
Stijnsbox
n00b
n00b


Joined: 08 May 2006
Posts: 5

PostPosted: Mon Oct 09, 2006 7:07 am    Post subject: Reply with quote

Brilliant!
I seem to forgot to make the boot partition bootable :oops:
(why do I always look for the difficult explanations and miss the obvious ones?)

Thanks!!

System now boots perfectly.
I have to check the sound config in case I should need it, but next to that, everything seems to work.

I compiled for a 32-bit system (not realy need 64-bit and must be sure that I'm compatible with some 'closed source' legacy applications. Not that I think it realy matters but just to be sure.).
I took the first set of the Safe Cflags 32-bit settings.

Stijn
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum