Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xsession et login]connexion perdue après quelques secondes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Thu Aug 03, 2006 11:18 am    Post subject: [Xsession et login]connexion perdue après quelques secondes Reply with quote

salut,

j'utilise entrance(et de ce fait j'utilise /etc/X11/Sessions/Xsession) comme gestionnaire d'affichage...

je me loggue à l'aide d'entrance => enlightenment se lance => je vois son splashscreen => puis je vois le bureau...pendant deux secondes :? ...puis retour à l'écran de connection(d'entrance)
et un:
Code:
_______                     _______
|:::::| Enlightenment Error |:::::|
~~~~~~~                     ~~~~~~~
Lost X connection.
dans mon .xsession-error

pourtant ça marche parfaitement si je lance Xorg :1 & enlightenment-0.17 -display :1

mon script ~/.xsession (pour le moment très basique):
Code:
#!/bin/bash

echo "lancement d'e17"
enlightenment-0.17
echo "fin d'e17"


_________________
Ces informations seront visibles publiquement


Last edited by epsy on Fri Aug 04, 2006 10:50 am; edited 1 time in total
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Thu Aug 03, 2006 12:09 pm    Post subject: Reply with quote

tu viendrais pas de mettre à jour e17 y'a pas longtemps??
car suite à une maj j'ai eu la même chose remaj le lendemain et maintenant ça remarche.

pour mettre à jour j'utilise ce petit script:
Code:
#!/bin/sh
for prog in eet dev-db/edb evas ecore embryo imlib2 edje e epeg media-libs/epsilon esmart entrance emotion eclair ewl engrave e_utils e_modules etox erss entice engage evidence
do
        emerge $prog;
done

_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Thu Aug 03, 2006 1:00 pm    Post subject: Reply with quote

a vrai dire ça fait pas longtemps que je l'ai installé(ma gentoo est neuve)ça avait marché (à peu près) nickel jusqu'a ce que je fis je-ne-sais-quoi :?

de plus j'ai pas fini d'installer tout le bazar dont j'ai besoin

je vais essayer ça après que gnome ait fini de se compiler ;)
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Thu Aug 03, 2006 7:57 pm    Post subject: Reply with quote

malheureusement ça n'a rien changé
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Fri Aug 04, 2006 10:49 am    Post subject: Reply with quote

salut,

je crois que je tiens le responsable: login

ce matin quand j'ai allumé ma machine je n'ai meme pas eu d'entrance...alors qu' il était bien mentionné plus haut " * Strarting up entrance"
je me suis dis 'pas grave de toute façon si il marchait maintenant il ne marchera pas après' et j'ai tenté de me logguer

a peine ayant tapé les deux premières lettres de mon pseudo, il m'a coupé et a affiché une nouvelle invite de loggin...
je me suis demandé si cela se reproduisait aussi sur les autres terminaux...et oui

j'ai tenter d'éteindre ma machine ==> je me suis connecté en root le plus vite que j'ai pu et entré halt

et la je ne sais pas ce qu'il lui a pris, mais il a changé vers le runlevel 0(au lieu du 6)
il a dit les mot doux term, puis kill a toutes les applis
puis il a stopé 'local'
puis il m'a dit 'plus rien a faire pour ce runlevel' et il ne s'est plus rien passé :cry::cry::cry:
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Fri Aug 04, 2006 1:04 pm    Post subject: Reply with quote

en fait l'invite de login se réaffiche à chaque intervalle que quelques secondes
trouvé pas mal de resultats sur google groups:
http://groups.google.fr/groups?q=login+linux+impossible+secondes&hl=fr&lr=&client=firefox-a&rls=org.mozilla:fr:official&as_qdr=all&sa=X&oi=groups&ct=title

je vais tenter ceci: http://groups.google.fr/group/fr.comp.os.linux/browse_thread/thread/a35686805bc98ca7/0e1624fb15e5026d?lnk=st&q=&rnum=1&hl=fr#0e1624fb15e5026d
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Fri Aug 04, 2006 1:58 pm    Post subject: Reply with quote

une fois que j'ai arreté entrance, tout est reparti normalement...

je me suis dit, il y a peut-etre une trace de qqch dans les logs:

déja la raison que X ne démarrait pas:
Code:
Aug  4 15:27:48 couloirgentoo entranced: Starting X server.
Aug  4 15:27:48 couloirgentoo entranced: Failed to generate auth cookie for X Server.
Aug  4 15:27:48 couloirgentoo entranced: Failed to generate auth cookie for X Server.
Aug  4 15:27:48 couloirgentoo entranced: Failed to generate auth cookie for X Server.
Aug  4 15:27:48 couloirgentoo entranced: Failed to generate auth cookie for X Server.
Aug  4 15:27:48 couloirgentoo entranced: Failed to generate auth cookie for X Server.

puis une boucle qui coincidait avec les moments ou l'invite se réaffichait:
Quote:
Aug 4 15:28:16 couloirgentoo entrance: Cannot initialize requested display ":0". Exiting.
Aug 4 15:28:16 couloirgentoo entranced: The session has ended normally.
Aug 4 15:28:16 couloirgentoo syslog-ng[8480]: SIGHUP received, restarting syslog-ng
Aug 4 15:28:17 couloirgentoo syslog-ng[8480]: new configuration initialized
Aug 4 15:28:17 couloirgentoo syslog-ng[8480]: Changing permissions on special file /dev/tty12

Aug 4 15:28:19 couloirgentoo entrance: Debug: ipc_title = /var/lib/entrance_ipc_9290
Aug 4 15:28:19 couloirgentoo entrance: entrance_ipc_init: Success
Aug 4 15:28:21 couloirgentoo login(pam_unix)[9606]: session opened for user root by LOGIN(uid=0)

enfin, ce qui est réseau a lâché; en voici la cause
Code:
Aug  4 15:27:41 couloirgentoo ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug  4 15:27:41 couloirgentoo e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
Aug  4 15:27:41 couloirgentoo ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Aug  4 15:27:41 couloirgentoo dhcpcd[8895]: MAC address = 00:16:76:44:49:4c
Aug  4 15:27:46 couloirgentoo dhcpcd[8895]: verified 192.168.0.3 address is not in use
Aug  4 15:27:46 couloirgentoo dhcpcd[8895]: your IP address = 192.168.0.3
...
Code:
Aug  4 15:28:02 couloirgentoo dhcpcd[8897]: terminating on signal 1


et quant je coupe entrance et que ça repart normalement, il n'est pas le seul a s'arreter:
Code:
Aug  4 15:29:00 couloirgentoo entranced: Caught exit signal.
Aug  4 15:29:00 couloirgentoo entranced: Display and display manager are shutting down.
Aug  4 15:29:00 couloirgentoo syslog-ng[8480]: syslog-ng version 1.6.9 going down


je crois que tout est là, on peut maintenant essayer de résoudre ces probleses un a un ;)
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Sat Aug 05, 2006 2:32 pm    Post subject: Reply with quote

up
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sat Aug 05, 2006 2:48 pm    Post subject: Reply with quote

Ce qui n'est pas normal, c'est que ton X passe par ton interface réseau alors qu'il devrait utiliser le loopback. ifconfig lo est bien up ? Ton /etc/hosts est correct ?
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Sat Aug 05, 2006 4:31 pm    Post subject: Reply with quote

salut,

ifconfig lo:
Code:
# ifconfig lo
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2940 (2.8 Kb)  TX bytes:2940 (2.8 Kb)


ifconfig lo n'est pas lancé au démarrage si c'est ça que tu veux dire


/etc/hosts
Code:

# blahblahblah

127.0.0.1       localhost
192.168.0.2     salon


qu'appeles-tu un hosts incorrect ??? il y a localhost, c'est suffisant non?
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sat Aug 05, 2006 5:20 pm    Post subject: Reply with quote

epsy wrote:
salut,

ifconfig lo:
Code:
# ifconfig lo
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2940 (2.8 Kb)  TX bytes:2940 (2.8 Kb)


ifconfig lo n'est pas lancé au démarrage si c'est ça que tu veux dire

Il tourne donc c'est bon. Le principal, c'est que /etc/init.d/net.lo soit lancé au démarrage.


epsy wrote:
/etc/hosts
Code:

# blahblahblah

127.0.0.1       localhost
192.168.0.2     salon


qu'appeles-tu un hosts incorrect ??? il y a localhost, c'est suffisant non?

Rajoute ton hostname sur la ligne du localhost.
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Sat Aug 05, 2006 6:08 pm    Post subject: Reply with quote

eh bien ça n'a rien changé :(

Code:
#/etc/hosts
127.0.0.1       localhost couloirgentoo
192.168.0.2     bureaubernard


et net.lo est lancé(selon rc-update show) en période 'boot'
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Sun Aug 06, 2006 4:59 pm    Post subject: Reply with quote

up
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Tue Aug 08, 2006 8:44 pm    Post subject: Reply with quote

salut,

a ce qu'il parait entrance aurait des problemes si pas lancé en dernier(mais alors dernier de dernier)

je voudrais essayer ça...

...mais je sais pas comment metre xdm en dernier :) si qqn pourrait me dire comment :wink:
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
epsy
n00b
n00b


Joined: 20 Jul 2006
Posts: 33

PostPosted: Thu Aug 10, 2006 11:26 am    Post subject: Reply with quote

up
_________________
Ces informations seront visibles publiquement
Back to top
View user's profile Send private message
bouleetbil
Guru
Guru


Joined: 06 Jul 2004
Posts: 456
Location: Montpellier

PostPosted: Fri Aug 11, 2006 3:21 pm    Post subject: Reply with quote

Pour modifier le démarrage de xdm, regarde le dernier service qui est démarré pour moi c'est xinted par exemple. Puis éditer /etc/init.d/xdm
voila l'original
Code:

depend() {
        use xfs hotplug
}


il devient
Code:

depend() {
        after xinted
        use xfs hotplug

}


Cela devrait suffir.
_________________
L'homme n'est pas fait pour travailler ça le fatigue.
LiveCD Gentoo : http://www.frogdev.info
Gentoo/Freebsd : http://www.frogdev.info/gentoo_freebsd.php
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum