Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE] Problème avec kcontrol (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ratur
n00b
n00b


Joined: 23 Jul 2004
Posts: 54
Location: Belgium

PostPosted: Tue Jul 25, 2006 12:35 pm    Post subject: [KDE] Problème avec kcontrol (résolu) Reply with quote

Bonjour à tous,

J'ai un problème assez étrange lié à KDE et plus particulièrement à ce qui touche à kcontrol. Comme une image vaut mieux qu'un long discours :

http://img332.imageshack.us/img332/25/probkcontrolgq3.png

Comme vous pouvez le constater, il n'y a plus rien dans le panneau de kcontrol. De la même façon, si, sous KDE, j'essaie de modifier des propriétés quelconques, il m'affiche une fenetre vide. En gros, je ne peux plus parametrer mon KDE.
Le message affiché par le terminal est le suivant :

Quote:
kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/


A priori, ça daterais de ma dernière mise à jour de kdelibs, mais je ne suis pas certain. Comme je n'utilise pas souvent kcontrol, je ne sais pas exactement depuis quand ça le fait.

Mon emerge --info :

Code:
 emerge --info
Portage 2.1.1_pre3-r4 (default-linux/x86/2006.0, gcc-3.4.6/vanilla, glibc-2.4-r3, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 AMD Athlon(tm) 64 Processor 3700+
Gentoo Base System version 1.12.1
ccache version 2.4 [enabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ "
LANG="fr_FR"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr fr_FR fr_BE"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/xgl-coffee"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow X aac alsa apache2 apm arts asf avi berkdb bitmap-fonts bluetooth bogofilter cairo cdr cli crypt cups dlloader dri dvd dvdr eds emboss encode esd firefox foomaticdb fortran ftp gdbm gif glitz gnome gpm gstreamer gtk gtk2 hal howl icq ieee1394 imagemagick imlib ipod isdnlog java joystick jpeg kde kdeenablefinal kdepim libcaca libg++ libwww mad matroska mikmod mmx mono motif mp3 mpeg msn musicbrainz mysql ncurses nls nocd nptl nptlonly nvidia ogg opengl oss pam pcre pdf pdflib perl png pppd python qt qt3 qt4 quicktime readline reflection ruby samba sdl session spamassassin spell spl sse sse2 ssl svg tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb videos visualization vorbis win32codecs xcomposite xine xml xmms xorg xscreensaver xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_vmmouse kernel_linux linguas_fr linguas_fr_FR linguas_fr_BE userland_GNU video_cards_nvidia video_cards_vesa video_cards_fbdev video_cards_vmware"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Le problème apparait quelque soit le window manager et quelque soit l'utilisateur (root y compris).
Par contre, il n'apparait pas sur mon 2eme PC, où les mises à jours sont souvent effectuées en même temps.

Quelqu'un a une idée d'où ça pourait venir ?


Last edited by ratur on Fri Jul 28, 2006 8:18 am; edited 1 time in total
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3584
Location: Belgium

PostPosted: Tue Jul 25, 2006 2:25 pm    Post subject: Re: [KDE] Problème avec kcontrol Reply with quote

ratur wrote:
Quelqu'un a une idée d'où ça pourait venir ?

Peut-être une corruption de la base sycoca ?
Tu peux la reconstruire avec la commande kbuildsycoca
Si nécessaire, utilise les options --noincremental et/ou --global (kbuildsycoca --help pour plus d'info ;) )
Back to top
View user's profile Send private message
ratur
n00b
n00b


Joined: 23 Jul 2004
Posts: 54
Location: Belgium

PostPosted: Tue Jul 25, 2006 2:29 pm    Post subject: Reply with quote

Si je lance kcontrol en root, j'ai un message d'erreur un peu plus complet :

Quote:
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/


La première phrase apparait aussi quand je tente un kbuildsycoca
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3584
Location: Belgium

PostPosted: Tue Jul 25, 2006 7:41 pm    Post subject: Reply with quote

Peut-être un problème avec le fichier ~/.ICEauthority :?:

Essaie éventuellement ceci (un peu bourrin et sans garantie ! ) :
- ferme la session X et passe en mode texte.
- logue-toi en root
- Renomme le fichier ~/.ICEauthority en ~/.ICEauthority.BAK aussi bien pour root que pour ton user

Recrée ensuite le fichier comme ceci :
- lance startx puis clôture immédiatement la session après son initialisation et reviens au mode texte
- logue-toi en user et fais la même chose.
Back to top
View user's profile Send private message
ratur
n00b
n00b


Joined: 23 Jul 2004
Posts: 54
Location: Belgium

PostPosted: Thu Jul 27, 2006 4:03 pm    Post subject: Reply with quote

Ca n'a rien changé malheureusement
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Thu Jul 27, 2006 11:33 pm    Post subject: Reply with quote

Essayes de reconstruires ta kdelibs si tu pense que c'est depuis sa mise à jour que ça ne fonctionne plus.
Back to top
View user's profile Send private message
ratur
n00b
n00b


Joined: 23 Jul 2004
Posts: 54
Location: Belgium

PostPosted: Fri Jul 28, 2006 8:17 am    Post subject: Reply with quote

Tout est rentré dans l'ordre en downgradant kdelibs :)

Chui passé de la 3.5.3-r4 à la 3.5.3-r3, et ça a l'air de rouler
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Jul 29, 2006 12:57 am    Post subject: Reply with quote

C'est étrange ton histoire je tourne avec la kdelibs 3.5.3-r4 et kcontrol fonctionne correctement.
Back to top
View user's profile Send private message
mardi_soir
Apprentice
Apprentice


Joined: 08 Dec 2004
Posts: 215

PostPosted: Sat Jul 29, 2006 2:35 am    Post subject: Reply with quote

j'ai eu un problème qui ressemblait un peu a ca

j'ai ajouté le chemin vers les exécutables kde dans le fichier /etc/profile et c'est rentré dans l'ordre
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum