Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
native Lotus Notes client on gentoo?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Ulukay
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2002
Posts: 143

PostPosted: Mon Jul 24, 2006 9:34 am    Post subject: native Lotus Notes client on gentoo? Reply with quote

anyone got the new lotus notes client working with gentoo?
http://www-306.ibm.com/software/de/lotus/produkte/p-notesforlinux.html

xxx@xxx 32bit(~/notes)$ ./notes
Segmentation fault
_________________
Jeden Tag erhöht sich zwangsläufig die Anzahl derer, die mich
am Arsch lecken können... Das ist heute DEIN Tag!
Back to top
View user's profile Send private message
behd
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 155

PostPosted: Mon Jul 24, 2006 11:04 am    Post subject: Reply with quote

I was also really eager to have a linux version of the client !
I'll try it asap and keep you posted...

NB. It's normally primarly designed for RedHat, so there's maybe a few adjustment to do prior to use it.

[edit] aaargh I hate ibm website, can you provide me with a direct link to download the client in english ?
[edit 2]ok already found link to your page in english (but not yet the download link):
http://www-142.ibm.com/software/sw-lotus/products/product4.nsf/wdocs/linux
[edit 3]it seems that it's only avalaible trough "IBM Passport Advantage" download :(
I'll have to harass the Windows minded guys from my company untill they give the credentials or download it for me :roll:
Back to top
View user's profile Send private message
DCLXVI
n00b
n00b


Joined: 26 Jul 2006
Posts: 2

PostPosted: Wed Jul 26, 2006 11:55 am    Post subject: Reply with quote

I haven't even gotten that far.

during ./setup_wct_platform.bin it halts because it "can not validate mozilla version"

I've googled the problem and everything seems to suggest that I'm supposed to put something like.

[1.7.13]
GRE_PATH=/usr/lib/mozilla-1.7.13

into /etc/gre.conf or /etc/gre.d/gre.conf.

I even softlinked /opt/mozilla to that exact path but still it gives me the error. I tried installing it on a fedora box since every 3rd party linux product seems to be made with redhat exclusively in mind, and it worked like a charm without problems. Yet... I can't seem to locate the subtle difference between the two boxes that is causing the error to occur.

Has anyone gotten passed this?
Back to top
View user's profile Send private message
luqas
Guru
Guru


Joined: 02 Jan 2004
Posts: 588
Location: /US/Texas/Beaumont

PostPosted: Wed Jul 26, 2006 12:57 pm    Post subject: Reply with quote

So you have the english version DCLXVI? Can you post a link to the download as I have searched their site and couldn't find a trial etc for Linux. Thanks.
Back to top
View user's profile Send private message
DCLXVI
n00b
n00b


Joined: 26 Jul 2006
Posts: 2

PostPosted: Wed Jul 26, 2006 1:09 pm    Post subject: Reply with quote

Sorry, we got it from our vendor and don't have it hosted anywhere for download.

As for the problem.

I solved the "can not validate mozilla version" thing by adding /etc/gre.conf and copy-ing /usr/lib/mozilla-1.7.13 from the fedora box over to my gentoo box. After that everything went smoothly and the client installed without a hitch. I'll try to figure out the bare minimums needed and write up a howto later that hopefully won't require people to use the fedora mozilla binaries.
Back to top
View user's profile Send private message
makenoob
Apprentice
Apprentice


Joined: 19 Aug 2004
Posts: 272
Location: /Germany/Düsseldorf

PostPosted: Thu Jul 27, 2006 12:18 pm    Post subject: Reply with quote

Dryre wrote:
So you have the english version DCLXVI? Can you post a link to the download as I have searched their site and couldn't find a trial etc for Linux. Thanks.


don't they have a trial version? afaik they will keep working after the 90 days...
Back to top
View user's profile Send private message
behd
Apprentice
Apprentice


Joined: 11 Feb 2003
Posts: 155

PostPosted: Wed Aug 16, 2006 2:27 pm    Post subject: Re: native Lotus Notes client on gentoo? Reply with quote

Ulukay wrote:
anyone got the new lotus notes client working with gentoo?
http://www-306.ibm.com/software/de/lotus/produkte/p-notesforlinux.html

xxx@xxx 32bit(~/notes)$ ./notes
Segmentation fault


lol my colleagua had the same problem :roll:
I bet that you didn't read the readme.pdf that was coming with the zip file !
Installation is absolutely NOT intuitive !!!

it's smth like:
- unzip Personality.zip -d plugin
- copy the setup file somewhere else into the plugin directory (+ change permission)
- run another setup file (after changing permission) that will invoke the initial setup

not complicated, just not intuitive at all...

---
TRICKY PART:
----------------

YOU MUST CREATE an /etc/gre.conf file (writeable by your user)
content:
- where number between brackets is your version of mozilla (!!! must be >= 1.7.12 !!!)
- GRE_PATH is location of your mozilla binaries
Code:

[1.7.13]
GRE_PATH=/usr/lib/mozilla


Additionnaly, it may require that you set in your profile:
Code:

GRE_PATH=<path to your binaries>
export GRE_PATH



DCLXVI wrote:
that hopefully won't require people to use the fedora mozilla binaries.

no need of Fedora binaries (gentoo src & bin works perfectly ;) )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum