Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GRUB] Erreur 11 (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Mon Jul 24, 2006 12:20 am    Post subject: [GRUB] Erreur 11 (résolu) Reply with quote

Bonjour,

Donc comme vous pouvez le voir il est pres de 2H15 du matin, pourquoi? TOut simplement parce que j'ai passé mon temps à installer gentoo et à l'arrivé...? Dès le bootloader ça bug j'ai une erreur 11 : unrecognized device string.

Donc si y a quelqu'un qui peut m'aider ça serait pas mal.

Donc voici le fichier de GRUB /boot/grub/grub.conf :

Code:

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux
root (hd0,0)
kernel /boot/kernel-genkernel-x86-2.6.16-gentoo-r13
 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda5 udev
initrd /boot/initramfs-genkernel-x86-2.6.16-gentoo-r13


Puis les partitions

Code:

   Device Boot      Start         End      Blocks   Id  System              Mount
/dev/hda1   *           1         195       98248+  83  Linux               /boot
/dev/hda2             196        1188      500472   82  Linux swap/Solaris
/dev/hda3            1189       25232    12118176    5  Extended
/dev/hda5            1189        9126     4000720+  83  Linux               /
/dev/hda6            9127       13095     2000344+  83  Linux               /opt
/dev/hda7           13096       17064     2000344+  83  Linux               /usr
/dev/hda8           17065       25232     4116640+  83  Linux               /home


J'ai fais avec genkernel mais y a un an je l'avais fais manuellement, mais bon la je cherche juste à lancer le système normalement puis mettre une interface graphique comme fluxbox (comme j'avais juste installé le systeme rien de plus avant) pour ainsi avoir une installation type et modifier suivant mes besoins.

Merci


Last edited by raynox on Mon Jul 24, 2006 3:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Mon Jul 24, 2006 12:42 am    Post subject: Reply with quote

le root c'est pas plutot hd0,4 ?

Tu as une partition /boot (hd0,0) donc pas besion de mettre "(hd0,0)/boot/" ;) hd0,0 c'est /boot
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Mon Jul 24, 2006 12:50 am    Post subject: Reply with quote

Ah oui, c'est vrai c'est à partir de 0 mais la fatigue ca joue des tours j'ai bien mis boot à 0 mais j'ai oublié pour la racine sniff


Quote:
Tu as une partition /boot (hd0,0) donc pas besion de mettre "(hd0,0)/boot/" ;) hd0,0 c'est /boot


Bon je vois pas ce que tu veux dire par la, le mieux c'est que j'aille dormir et que je relis ton poste demain car la je suis HS j'ai passé presque toute ma journée (et debut de la nuit) dessus.

Donc Merci et bonne nuit 8)
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Mon Jul 24, 2006 12:56 am    Post subject: Reply with quote

Ah oui j'ai mal compri ton poste lol tu veux dire que je dois mettre

root (hd0,4)

Ah désolé, j'avais mal compri :?

Merci beaucoup
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Mon Jul 24, 2006 1:10 am    Post subject: Reply with quote

Tu as plusieurs erreures que j'ai corrigées je t'ai remis le code ci-dessous
Code:
default 0
timeout 30
splashimage=(hd0,0)/grub/splash.xpm.gz

title   Gentoo Linux
root    (hd0,0)
kernel  /kernel-genkernel-x86-2.6.16-gentoo-r13 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda5 udev
initrd  /initramfs-genkernel-x86-2.6.16-gentoo-r13
Back to top
View user's profile Send private message
raynox
Apprentice
Apprentice


Joined: 06 May 2005
Posts: 190
Location: Lille, Tourcoing

PostPosted: Mon Jul 24, 2006 2:21 pm    Post subject: Reply with quote

C'est bon il a booté niquel.... ethernet, serveur ssh..... tout niquel après la modif de GRUB.

Bon maintenant à l'interface graphique. Le systeme je le verai plus en détail après car la je cherche surtout à ne plus être sur Windows (Parce que avant en studio Linux ce n'etait pas vraiment la classe pour fairedes maj ou autre).


Je me suis mis un petit forum ici http://raynox.free.fr/forum/viewforum.php?f=1

Pour ne plus vous embeter par mes futurs installes :D

Grand merci
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Tue Jul 25, 2006 1:23 am    Post subject: Reply with quote

En tout cas moi tu ne m'embêtes pas dutout et c'est un peut dommage car ton forum fait un peu doublon avec celui-ci, je pense que tu devrais vraiment continuer à venir poser tes question ici.

Alors je te dis à la prochaine question, si je peux y répondre :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum