Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
'su' problems?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
heavydwitstyle
n00b
n00b


Joined: 24 Nov 2005
Posts: 44

PostPosted: Mon Jul 17, 2006 6:59 pm    Post subject: 'su' problems? Reply with quote

Hey everybody.

I had an odd problem and was wondering if you could help as doing a forum search gave me no luck.

I can't for some reason su to root when I use SSH to connect to my server, although I can seem to fine locally. (not verified yet though)

When I log on as my normal account through SSH and then try to 'su root' it doesn't work. However if I SSH and log in as root, it works perfectly.

What am I missing?


- Heavy-D
_________________
Dual Core - Pentium D 805 - 2 x 2.66Ghz
2048MB DDR533 Crucial Memory
2x 320Gb WD SATA2
---
MacBook Pro running OS X 10.4.8
Back to top
View user's profile Send private message
msalerno
Veteran
Veteran


Joined: 17 Dec 2002
Posts: 1336
Location: Sweating in South Florida

PostPosted: Mon Jul 17, 2006 7:28 pm    Post subject: Reply with quote

Here is what you are missing:

The answer to this
Quote:
I can't for some reason su to root when I use SSH to connect to my server, although I can seem to fine locally. (not verified yet though)

Did you look in the FAQ's?

Specifically the one titled "SA2: Why can't I su to root?"
_________________
When harmonious relationships dissolve
Then respect and devotion arise;
When a nation falls to chaos
Then loyalty and patriotism are born.
-Lao Tse
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Jul 17, 2006 7:31 pm    Post subject: Reply with quote

What do you mean with "does not work"? Is there any error or what? Is that user you try to su in the wheel group?
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
heavydwitstyle
n00b
n00b


Joined: 24 Nov 2005
Posts: 44

PostPosted: Mon Jul 17, 2006 7:43 pm    Post subject: Reply with quote

Sorry about that, I should have been more specific and actually said that it gave me a permission denied.

I have to apologise again as I seem to have missed that article containing the information about how newly created
users can't su by default for security reasons. I took the actions mentioned in that article and now I can su to root
without any problems.

Thanks for all your help!

- A very embarrased Heavy-D
_________________
Dual Core - Pentium D 805 - 2 x 2.66Ghz
2048MB DDR533 Crucial Memory
2x 320Gb WD SATA2
---
MacBook Pro running OS X 10.4.8
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Mon Jul 17, 2006 7:53 pm    Post subject: Reply with quote

Moved from Networking & Security to Duplicate Threads, please see this FAQ: SA2: Why can't I su to root?.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum