Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
imagemagick build problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
rtomisek
n00b
n00b


Joined: 01 Sep 2003
Posts: 9

PostPosted: Fri Jul 14, 2006 2:37 am    Post subject: imagemagick build problem Reply with quote

I am trying to install gnome 2.14 but there is an error when imagemagick is being merged. Here is the output:

coders/png.c: In function `ReadOnePNGImage':
coders/png.c:1755: warning: implicit declaration of function `png_access_version'
coders/png.c:1764: error: `png_ptr' undeclared (first use in this function)
coders/png.c:1764: error: (Each undeclared identifier is reported only once
coders/png.c:1764: error: for each function it appears in.)
make: *** [coders/coders_png_la-png.lo] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: media-gfx/imagemagick-6.2.5.5 failed.
Call stack:
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
imagemagick-6.2.5.5.ebuild, line 86: Called die

!!! compile problem
!!! If you need support, post the topmost build error, and the call stack if relevant.

This is a serious problem since imagemagick is a dependency for several gnome 2.14 components, in this particular instance, nautilus.

So two questions:
Is imagemagick really nessessary?
If it is, how can I get it to build?
Back to top
View user's profile Send private message
zontar
n00b
n00b


Joined: 23 Jan 2005
Posts: 68
Location: Seattle

PostPosted: Fri Jul 14, 2006 4:09 am    Post subject: Reply with quote

I had something similar when I upgraded to Xorg 7.0. I did an emerge -C imagemagick and then re-emerged it. That worked for me. (Imagemagick is a nice thing to have.)
Back to top
View user's profile Send private message
Laura
n00b
n00b


Joined: 14 Dec 2005
Posts: 18
Location: California

PostPosted: Fri Jul 14, 2006 5:38 am    Post subject: Reply with quote

I am having this same problem. Uninstalling and re-emerging imagemagick does not seem to help.
Back to top
View user's profile Send private message
Laura
n00b
n00b


Joined: 14 Dec 2005
Posts: 18
Location: California

PostPosted: Fri Jul 14, 2006 5:48 am    Post subject: Reply with quote

This thread is a duplicate of

https://forums.gentoo.org/viewtopic-t-479793-highlight-imagemagick.html

Also check out bug # 136452 at https://bugs.gentoo.org
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Fri Jul 14, 2006 7:14 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads. See thread Laura posted.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum