Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xserver blocks nvidia-glx?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
scone
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jun 2003
Posts: 78

PostPosted: Fri Jul 14, 2006 2:28 am    Post subject: Xserver blocks nvidia-glx? Reply with quote

Hey. I'm using X 7.0 (r1)

When i add the ACCEPT_KEYWORDS="~x86" to my make.conf (will now attempt to emerge x) it says that xorg-server 1.1.1 is blocked by nvidia-glx

is the nvidia suport now built into xserver (it tries to use the nv driver which the gentoo nvidia guide says NOT to use)

should i just not use the ACCEPT_KEYWORDS thing and do as i'm told?
_________________
peace, love (lots of love), linux (and anime!!!)
Back to top
View user's profile Send private message
Sourcecode
Guru
Guru


Joined: 25 Apr 2005
Posts: 392
Location: Germany, Kerpen in sew of Cologne

PostPosted: Fri Jul 14, 2006 3:52 am    Post subject: Reply with quote

There are new NIVIDIA Drivers for now :

Unmerge nvidia-kernel & nvidia-glx

and do :

emerge nvidia-drivers (GLX Included ;) )

should solve the problem.
_________________
Es gibt bloss eins, was wichtig ist: dass man sterben muss.

Suicide is man's way of telling God, "You can't fire me - I quit."

no one gets out here alive....
Back to top
View user's profile Send private message
mishmash
n00b
n00b


Joined: 14 Jul 2006
Posts: 17
Location: The East of England

PostPosted: Fri Jul 14, 2006 3:57 am    Post subject: Reply with quote

Taken from the xorg-server changelog:

Code:
17 Jun 2006; Joshua Baergen <joshuabaergen@gentoo.org>
  xorg-server-1.1.0.ebuild:
  Drop nvidia and fglrx flags for now and block all nvidia-glx and ati-drivers
  versions since neither of the binary drivers are supported currently.
  (Jakub Moc, bug #136788)


Code:
  06 Jul 2006; Chris Gianelloni <wolf31o2@gentoo.org>
  xorg-server-1.1.0-r1.ebuild:
  Added blocker on x11-drivers/nvidia-drivers and
  x11-drivers/nvidia-legacy-drivers since they don't work on 1.1 yet.


You also might be interested in the following thread which happens to be stickied in the DE forum (https://forums.gentoo.org/viewtopic-t-458721.html) for a more definitive answer.

P.S. First post 8O
Back to top
View user's profile Send private message
tuam
l33t
l33t


Joined: 04 May 2004
Posts: 763
Location: CGN, Germany

PostPosted: Fri Jul 14, 2006 6:56 am    Post subject: Re: Xserver blocks nvidia-glx? Reply with quote

scone wrote:
When i add the ACCEPT_KEYWORDS="~x86" to my make.conf (will now attempt to emerge x) it says that xorg-server 1.1.1 is blocked by nvidia-glx

Read the fine stickies on top of this forum: https://forums.gentoo.org/viewtopic-t-458721.html

scone wrote:
should i just not use the ACCEPT_KEYWORDS thing and do as i'm told?

Generally, ACCEPT_KEYWORDS is not a good idea. It makes you use EVERY semi-stable package, and is likely to break things. However, I don't know about your needs...

FF,

Daniel
_________________
Logic clearly dictates that the needs of the many outweigh the needs of the few. - Spock
The needs of the one outweigh the needs of the many. - Kirk
I refuse to let arithmetic decide questions like that. - Picard
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Fri Jul 14, 2006 7:10 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads. Sticky has details.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum