Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(resolvido)nao consigo atualizar o xorg 7.0-r1
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Jul 12, 2006 6:12 am    Post subject: (resolvido)nao consigo atualizar o xorg 7.0-r1 Reply with quote

ola pessoal

pesquisei no forum, mas nao acho uma solução


quando chega no pacote mesa, ferra tudo e nao passa de jeito nenhum
Code:
../../../include/GL/glxext.h:630: error: syntax error before '*' token
../../../include/GL/glxext.h:630: error: `PFNGLXWAITFORMSCOMLPROC' declared as function returning a function
../../../include/GL/glxext.h:631: error: syntax error before '*' token
../../../include/GL/glxext.h:631: error: `PFNGLXWAITFORSBCOMLPROC' declared as function returning a function
../../../include/GL/glxext.h:671: error: syntax error before '*' token
../../../include/GL/glxext.h:672: error: syntax error before '*' token
../../../include/GL/glxext.h:673: error: syntax error before '*' token
../../../include/GL/glxext.h:674: error: syntax error before '*' token
../../../include/GL/glxext.h:675: error: syntax error before '*' token
../../../include/GL/glxext.h:676: error: syntax error before '*' token
../../../include/GL/glxext.h:677: error: syntax error before '*' token
../../../include/GL/glxext.h:678: error: syntax error before '*' token
In file included from glcontextmodes.c:43:
../../../include/GL/glx.h:491: error: syntax error before '*' token
../../../include/GL/glx.h:492: error: syntax error before '*' token
../../../include/GL/glx.h:493: error: syntax error before '*' token
../../../include/GL/glx.h:494: error: syntax error before '*' token
../../../include/GL/glx.h:495: error: syntax error before '*' token
../../../include/GL/glx.h:496: error: syntax error before '*' token
../../../include/GL/glx.h:506: error: syntax error before '*' token
../../../include/GL/glx.h:506: error: `glXBindTexImageARB' declared as function returning a function
../../../include/GL/glx.h:507: error: syntax error before '*' token
../../../include/GL/glx.h:507: error: `glXReleaseTexImageARB' declared as function returning a function
../../../include/GL/glx.h:508: error: syntax error before '*' token
../../../include/GL/glx.h:508: error: `glXDrawableAttribARB' declared as function returning a function
../../../include/GL/glx.h:532: error: field `send_event' declared as a function
../../../include/GL/glx.h:533: error: syntax error before "Display"
../../../include/GL/glx.h:533: warning: no semicolon at end of struct or union
../../../include/GL/glx.h:534: error: `drawable' redeclared as different kind of symbol
../../../include/GL/glxext.h:324: error: previous declaration of `drawable'
../../../include/GL/glx.h:540: error: syntax error before '}' token
../../../include/GL/glx.h:540: warning: type defaults to `int' in declaration of `GLXPbufferClobberEvent'
../../../include/GL/glx.h:540: warning: data definition has no type or storage class
../../../include/GL/glx.h:543: error: syntax error before "GLXPbufferClobberEvent"
../../../include/GL/glx.h:543: warning: no semicolon at end of struct or union
../../../include/GL/glx.h:545: error: syntax error before '}' token
../../../include/GL/glx.h:545: warning: type defaults to `int' in declaration of `GLXEvent'
../../../include/GL/glx.h:545: warning: data definition has no type or storage class
glcontextmodes.c:44:24: GL/glxint.h: Arquivo ou diretório não encontrado
glcontextmodes.c:53:27: X11/Xlibint.h: Arquivo ou diretório não encontrado
In file included from ../../../include/GL/internal/glcore.h:41,
                 from ../../../src/mesa/drivers/dri/common/glcontextmodes.h:33,
                 from glcontextmodes.c:60:
/usr/include/sys/types.h:194: error: conflicting types for `int64_t'
../../../include/GL/glxext.h:629: error: previous declaration of `int64_t'
In file included from glcontextmodes.c:60:
../../../src/mesa/drivers/dri/common/glcontextmodes.h:39: warning: type defaults to `int' in declaration of `__GLXvisualConfig'
../../../src/mesa/drivers/dri/common/glcontextmodes.h:39: error: syntax error before '*' token
glcontextmodes.c: In function `_gl_convert_to_x_visual_type':
glcontextmodes.c:99: error: `TrueColor' undeclared (first use in this function)
glcontextmodes.c:99: error: (Each undeclared identifier is reported only once
glcontextmodes.c:99: error: for each function it appears in.)
glcontextmodes.c:99: error: initializer element is not constant
glcontextmodes.c:99: error: (near initialization for `x_visual_types[0]')
glcontextmodes.c:99: error: `DirectColor' undeclared (first use in this function)
glcontextmodes.c:99: error: initializer element is not constant
glcontextmodes.c:99: error: (near initialization for `x_visual_types[1]')
glcontextmodes.c:100: error: `PseudoColor' undeclared (first use in this function)
glcontextmodes.c:100: error: initializer element is not constant
glcontextmodes.c:100: error: (near initialization for `x_visual_types[2]')
glcontextmodes.c:100: error: `StaticColor' undeclared (first use in this function)
glcontextmodes.c:100: error: initializer element is not constant
glcontextmodes.c:100: error: (near initialization for `x_visual_types[3]')
glcontextmodes.c:101: error: `GrayScale' undeclared (first use in this function)
glcontextmodes.c:101: error: initializer element is not constant
glcontextmodes.c:101: error: (near initialization for `x_visual_types[4]')
glcontextmodes.c:102: error: `StaticGray' undeclared (first use in this function)
glcontextmodes.c:102: error: initializer element is not constant
glcontextmodes.c:102: error: (near initialization for `x_visual_types[5]')
glcontextmodes.c: At top level:
glcontextmodes.c:125: warning: type defaults to `int' in declaration of `__GLXvisualConfig'
glcontextmodes.c:125: error: syntax error before '*' token
glcontextmodes.c: In function `_gl_copy_visual_to_context_mode':
glcontextmodes.c:127: error: `mode' undeclared (first use in this function)
glcontextmodes.c:129: warning: implicit declaration of function `memset'
glcontextmodes.c:132: error: `config' undeclared (first use in this function)
glcontextmodes.c: In function `_gl_context_modes_create':
glcontextmodes.c:363: warning: implicit declaration of function `Xmalloc'
glcontextmodes.c: In function `_gl_context_modes_destroy':
glcontextmodes.c:404: warning: implicit declaration of function `Xfree'
make[3]: ** [glcontextmodes.o] Erro 1
make[3]: Leaving directory `/var/tmp/portage/mesa-6.4.2-r2/work/Mesa-6.4.2/src/glx/x11'
make[2]: ** [subdirs] Erro 1
make[2]: Leaving directory `/var/tmp/portage/mesa-6.4.2-r2/work/Mesa-6.4.2/src'
make[1]: ** [default] Erro 1
make[1]: Leaving directory `/var/tmp/portage/mesa-6.4.2-r2/work/Mesa-6.4.2'
make: ** [linux-dri-x86] Erro 2

!!! ERROR: media-libs/mesa-6.4.2-r2 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  mesa-6.4.2-r2.ebuild, line 235:   Called die

!!! Build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.




detalhes da maquina

Code:
*** otavio # emerge --info
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.3.6, glibc-2.3.6-r4, 2.6.16-gentoo-r3 i686)
=================================================================
System uname: 2.6.16-gentoo-r3 i686 AMD Athlon(tm)
Gentoo Base System version 1.6.15
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.3-r1, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pt_BR"
LC_ALL="pt_BR"
LINGUAS="pt_BR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 apm arts avi berkdb bitmap-fonts cli crypt cups dlloader dri eds emboss encode esd foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 isdnlog jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls nptl ogg opengl oss pam pcre pdflib perl png pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux linguas_pt_BR userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


abraço
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd


Last edited by domus-br on Sun Jul 16, 2006 12:13 am; edited 1 time in total
Back to top
View user's profile Send private message
iuri_BR
n00b
n00b


Joined: 16 Dec 2005
Posts: 64
Location: DF, Brasil

PostPosted: Thu Jul 13, 2006 3:33 am    Post subject: Reply with quote

Eu acho que você tem que recompilar o openmotif. Eu fiz isso aqui. Além de atualizar o openmotif ele compilou um programa novo.
Boa sorte.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Fri Jul 14, 2006 10:30 am    Post subject: Reply with quote

opa obrigado, consegui resolver o pacote mesa, dando emerge -e xorg-x11 ele recompilou gcc ate glibc e varios outros pacotes do system, e agora passou do mesa tranquilamente, vamos ver se conclui tranquilamente

obrigado
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
jrOliv
n00b
n00b


Joined: 13 Jul 2006
Posts: 9

PostPosted: Fri Jul 14, 2006 3:31 pm    Post subject: Reply with quote

Olá, tive problema com o Pacote mesa também.
Eu removi o nvidia-glx (emerge -Ca nvidia-glx), e passou, depois recompilei normalmente.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum