Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot login [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Aurisor
Guru
Guru


Joined: 20 Sep 2003
Posts: 361
Location: Boston MA

PostPosted: Tue Jul 11, 2006 2:31 pm    Post subject: cannot login [solved] Reply with quote

Hello all,

We have a new guy at our office here who just started. His first task was to build his own gentoo box, and he seems to have gotten through most of it just fine. The install is complete, and the system boots to the console login prompt just fine. However, whenever you enter your login name, the system just "thinks" for about 20 seconds, and then asks me for my username again without any error message. It looks like this:

hostname.localdomain login: root


hostname.localdomain login:

I bet if I just went through and redid the install step by step, I'd do whatever he forgot to do, but can anyone recognize what the problem is? It would save me many hours of recompiling.

Thanks!
_________________
The problem with seeing too much is that it makes you insane. --Phaedrus


Last edited by Aurisor on Tue Jul 11, 2006 6:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
elgato319
Guru
Guru


Joined: 15 Sep 2005
Posts: 546

PostPosted: Tue Jul 11, 2006 2:42 pm    Post subject: Reply with quote

Well...

is root allowed to login via shell?
Maybe root login is not permitted via ssh.

You don´t have to recompile everything, just boot up with the Live-CD, mount the drives and chroot into the system
(Gentoo Install Handbook)

Add a normal user and try to login with it.
Back to top
View user's profile Send private message
Aurisor
Guru
Guru


Joined: 20 Sep 2003
Posts: 361
Location: Boston MA

PostPosted: Tue Jul 11, 2006 2:49 pm    Post subject: Reply with quote

Root is allowed to login via shell. I ran:

Code:

echo "tts/0" >> /etc/securetty


I am not using ssh, I am logging in locally.

I added a user, and still no luck. No matter what I type into the login name prompt I never get prompted for my password.
_________________
The problem with seeing too much is that it makes you insane. --Phaedrus
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Tue Jul 11, 2006 2:53 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-449155.html

I had the same problem. (ignore the part about the mdns off, the rest applies.)
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
Aurisor
Guru
Guru


Joined: 20 Sep 2003
Posts: 361
Location: Boston MA

PostPosted: Tue Jul 11, 2006 3:10 pm    Post subject: Reply with quote

Awesome, I'm in!! Thank you SO MUCH!
_________________
The problem with seeing too much is that it makes you insane. --Phaedrus
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4726
Location: Angra do Heroísmo (PT)

PostPosted: Fri Aug 11, 2006 4:08 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.

[mod]Moved this thread to DT in favour of this one for the login issue and of this one for the mdns issue.[/mod]
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum