Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
samba host allow
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
Ilvalle
Guru
Guru


Joined: 07 Mar 2005
Posts: 325
Location: Gallarate - ITALY

PostPosted: Tue Jul 11, 2006 7:33 am    Post subject: samba host allow Reply with quote

Dopo prove e riprove non so + cosa altro fare, ho seguito tutte le guide del caso, ma nonostante questo ho seri problemi con samba. In prativa il demone fa la bind sull'interfaccia sbagliata, conseguenza, gli host allow non coincidono e ricevo sempre lo stesso errore:
Code:
ada ~ # smbclient  -L 192.168.0.1
Password:
tree connect failed: Call returned zero bytes (EOF)

Nel smb.conf ho messo:
Code:
   
interfaces = br0
         bind interfaces only = yes

Che si riferisce al bridge locale, sul quale deve girare il demone samba.
Cose buffe, se butto giu l'interfaccia esterna, tutto funziona.
valle
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Tue Jul 11, 2006 10:50 am    Post subject: Reply with quote

Con Samba in esecuzione, cosa ti restituisce
Code:

netstat -na|grep :139

?
Come sono configurate le tue interfacce di rete?
Magari posta il contenuto di /etc/samba/smb.conf (senza commenti, mi raccomando :roll: )
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Ilvalle
Guru
Guru


Joined: 07 Mar 2005
Posts: 325
Location: Gallarate - ITALY

PostPosted: Tue Jul 11, 2006 11:09 am    Post subject: Reply with quote

Code:
ada ~ # netstat -na|grep :139
tcp        0      0 192.168.0.1:139         0.0.0.0:*               LISTEN   

Il problema e' locale,le macchine delle lan non ricevono l'errore.
Code:
br0       Link encap:Ethernet  HWaddr 00:01:02:DF:C3:BC 
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::201:2ff:fedf:c3bc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:90243 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136919 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6101226 (5.8 Mb)  TX bytes:185513377 (176.9 Mb)

eth0      Link encap:Ethernet  HWaddr 00:01:02:DF:C3:BC 
          inet6 addr: fe80::201:2ff:fedf:c3bc/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:90243 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136925 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7370778 (7.0 Mb)  TX bytes:185520015 (176.9 Mb)
          Interrupt:3 Base address:0x2000

eth1      Link encap:Ethernet  HWaddr 00:A0:24:50:D3:B9 
          inet addr:151.37.21.137  Bcast:151.37.21.137  Mask:255.255.255.255
          inet6 addr: fe80::2a0:24ff:fe50:d3b9/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:150738 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101174 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:196219310 (187.1 Mb)  TX bytes:8699294 (8.2 Mb)
          Interrupt:10 Base address:0x4000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2727 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2727 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:221046 (215.8 Kb)  TX bytes:221046 (215.8 Kb)

sixxs     Link encap:IPv6-in-IPv4 
          inet6 addr: 2001:1418:1001:147::2/64 Scope:Global
          inet6 addr: fe80::9725:1589/64 Scope:Link
          inet6 addr: fe80::c0a8:1/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1280  Metric:1
          RX packets:1432 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1040 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:447570 (437.0 Kb)  TX bytes:124317 (121.4 Kb)

tap0      Link encap:Ethernet  HWaddr B2:F7:66:47:D4:F3 
          inet6 addr: fe80::b0f7:66ff:fe47:d4f3/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:20446 (19.9 Kb)

vde       Link encap:Ethernet  HWaddr 9A:58:24:24:88:C7 
          inet6 addr: fe80::9858:24ff:fe24:88c7/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:0 (0.0 b)  TX bytes:20446 (19.9 Kb)

le interfacce senza indirizzo sono gestite dal bridge.
Code:
ada ~ # /usr/bin/testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[public]"
Loaded services file OK.
WARNING: passdb expand explicit = yes is deprecated
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        workgroup = PROVA
        netbios name = PROVA
        server string = Samba Server %v
        interfaces = br0
        bind interfaces only = Yes
        map to guest = Bad User
        smb passwd file = /etc/samba/private/smbpasswd
        guest account = valle
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        load printers = No
        dns proxy = No
        hosts allow = 127., 192.168.0.1/24
        hosts deny = 0.0.0.0/0

[public]
        path = "/public"
        guest only = Yes
        guest ok = Yes

valle
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4489
Location: Somewere around the world

PostPosted: Tue Jul 11, 2006 11:12 am    Post subject: Reply with quote

Moved from Forum italiano (Italian) to Forum di discussione italiano.
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum