Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X.org и nVidia
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Sanches
n00b
n00b


Joined: 10 Jul 2006
Posts: 56
Location: Zheleznogorsk

PostPosted: Mon Jul 10, 2006 5:10 pm    Post subject: X.org и nVidia Reply with quote

Короче стоит X.org 7.1 и у меня видуха nVidia GeForce 6600, драва от nVidia (nvidia-glx) не ставятся, что делать?
Помогите пожалуйста.
Back to top
View user's profile Send private message
ladserg
n00b
n00b


Joined: 01 Nov 2004
Posts: 65

PostPosted: Mon Jul 10, 2006 7:16 pm    Post subject: Re: X.org и nVidia Reply with quote

Sanches wrote:
Короче стоит X.org 7.1 и у меня видуха nVidia GeForce 6600, драва от nVidia (nvidia-glx) не ставятся, что делать?
Помогите пожалуйста.


А что иксы 7.1 уже стабильными стали? Гм не знал.

Как дрова не ставятся? Не компилируются? Версия дров 8ххх (ниже работать не должны)? nvidia-kernel ставится?

Попробуй сделать так:

# echo nvidia-kernel >> /etc/portage/package.keywords
# echo nvidia-glx >> /etc/portage/package.keywords
# emerge -uD nvidia-kernel nvidia-glx

Именно:

# emerge -uD nvidia-kernel nvidia-glx

Библиотека MesaLib стоит?

# emerge -pv mesa

В USE есть флаги:

USE="opengl dri glut"

На счёт glut точно не знаю, у меня он просто есть.

У меня иксы 7.0 работают, но на форумах кто-то сталкивался со сложностью с дровами в иксах 7.1, и обязательно находились те, у кого всё работает как часы.
Back to top
View user's profile Send private message
Azik
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 149
Location: Russia, Ufa

PostPosted: Mon Jul 10, 2006 7:44 pm    Post subject: Reply with quote

Именно по этой причине, что с 7.1 не работают бинарные драйвера ведущих производителей ATI nVidia, они и замаскированы. Откатывайся назад до 7.0 и вперед на заглавную страницу www.gentoo.org за пояснениями.
_________________
From Siberia with Love!
Back to top
View user's profile Send private message
Sanches
n00b
n00b


Joined: 10 Jul 2006
Posts: 56
Location: Zheleznogorsk

PostPosted: Tue Jul 11, 2006 6:51 am    Post subject: вот, пытаюсь обновить! Reply with quote

Ща попробуем.

Кстати не знаете что вот это за лабуда, я на другом форуме уже спрашивал, стоял x.org 7.1:
Еле еле поставил x.org 7.1 вроде работал. И помойму после установки nvidia-glx, я снял с них блок, чтобы opengl нормально работал, начался глюк. Захожу в иксы, и не одной надписи нет. Вместо слов только одна черточка, и то не всегда. Иногда показывает шрифт. На рабочем столе все названия ярлыков затемнёными шрифтами отображаются. В центре управления kde в разделе смены шрифтов, когда выбираешь шрифт, и то не каждый, он вроде показывает пример, но когда его меняешь всё также, надписи не отображаются. В xmms если нажать правой кнопкой по нему, отобразится меню с настройками, там всё нормально. ПОМОГИТЕ ПЛИЗ ЭТО ИСПРАВИТЬ!!!
Back to top
View user's profile Send private message
Sanches
n00b
n00b


Joined: 10 Jul 2006
Posts: 56
Location: Zheleznogorsk

PostPosted: Tue Jul 11, 2006 7:33 am    Post subject: Reply with quote

Спасиба. Поставил X.org 7.0.0 и всё идёт.
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Tue Jul 11, 2006 10:56 am    Post subject: Reply with quote

Azik wrote:
Именно по этой причине, что с 7.1 не работают бинарные драйвера ведущих производителей ATI nVidia, они и замаскированы.


Если бы замаскированы... У меня xorg в package.unmask не размаскируются. Только ~arch. Так с недавних пор пришлось 7.1 в явном виде маскировать. Ибо их размаскировали... Сейчас штатными средствами 7.0 от 7.1 не отделить, только маскируя 7.1 вручную. То же самое - по кучи вспомогательных либ:

package.mask
Code:

=x11-base/xorg-server-1.1*
=x11-base/xorg-x11-7.1
=x11-drivers/xf86-input-evdev-1.1.2-r1
=x11-drivers/xf86-video-vesa-1.2.1
=x11-drivers/xf86-video-vesa-1.2.0
=x11-drivers/xf86-input-keyboard-1.1.0
=x11-drivers/xf86-video-ati-6.6.0_p20060525
=x11-drivers/xf86-video-ati-6.6.0
=x11-drivers/xf86-input-joystick-1.1.0
=x11-drivers/xf86-input-mouse-1.1.1
=x11-drivers/xf86-video-nv-1.1.2
=x11-base/xorg-server-1.0.99*
=x11-drivers/xf86-video-vga-4.1.0
=x11-drivers/xf86-input-hyperpen-1.1.0
=x11-drivers/xf86-input-digitaledge-1.1.0
=x11-drivers/xf86-input-tek4957-1.1.0
=x11-drivers/xf86-input-citron-2.2.0
=x11-drivers/xf86-input-fpit-1.1.0
=x11-drivers/xf86-input-elographics-1.1.0
=x11-drivers/xf86-input-void-1.1.0
=x11-drivers/xf86-input-ur98-1.1.0
=x11-drivers/xf86-input-spaceorb-1.1.0
=x11-drivers/xf86-input-dmc-1.1.0
=x11-drivers/xf86-input-penmount-1.2.0
=x11-drivers/xf86-input-penmount-1.1.0
=x11-drivers/xf86-input-aiptek-1.0.1
=x11-drivers/xf86-input-calcomp-1.1.0
=x11-drivers/xf86-input-palmax-1.1.0
=x11-drivers/xf86-input-summa-1.1.0
=x11-drivers/xf86-input-microtouch-1.1.0
=x11-drivers/xf86-input-magellan-1.1.0
=x11-drivers/xf86-input-dynapro-1.1.0
=x11-drivers/xf86-input-acecad-1.1.0
=x11-drivers/xf86-input-jamstudio-1.1.0
=x11-drivers/xf86-input-elo2300-1.1.0
=x11-drivers/xf86-input-mutouch-1.1.0
Back to top
View user's profile Send private message
Azik
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2005
Posts: 149
Location: Russia, Ufa

PostPosted: Tue Jul 11, 2006 2:27 pm    Post subject: Reply with quote

Quote:
Ибо их размаскировали... Сейчас штатными средствами 7.0 от 7.1 не отделить, только маскируя 7.1 вручную.


А у тебя какая архитектура? Маскированы только amd64 hppa и x86, для остальных, ввиду отсутствия бинарных драйверов 7.1 доступны.
_________________
From Siberia with Love!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum