Joined: 12 May 2004
|Posted: Sun Jul 09, 2006 6:26 pm Post subject: [ GLSA 200607-04 ] PostgreSQL: SQL injection
|Gentoo Linux Security Advisory
Title: PostgreSQL: SQL injection (GLSA 200607-04)
Date: July 09, 2006
Updated: June 26, 2007
A flaw in the multibyte character handling allows execution of arbitrary SQL statements.
PostgreSQL is an open source object-relational database management system.
Vulnerable: < 8.0.8
Vulnerable: < 7.4.13
Unaffected: >= 8.0.8
Unaffected: = 7.4*
Architectures: All supported architectures
PostgreSQL contains a flaw in the string parsing routines that allows certain backslash-escaped characters to be bypassed with some multibyte character encodings. This vulnerability was discovered by Akio Ishida and Yasuo Ohgaki.
An attacker could execute arbitrary SQL statements on the PostgreSQL server. Be aware that web applications using PostgreSQL as a database back-end might be used to exploit this vulnerability.
There is no known workaround at this time.
All PostgreSQL users should upgrade to the latest version in the respective branch they are using:
Note: While a fix exists for the 7.3 branch it doesn't currently work on Gentoo. All 7.3.x users of PostgreSQL should consider updating their installations to the 7.4 (or higher) branch as soon as possible!
|# emerge --sync
# emerge --ask --oneshot --verbose dev-db/postgresql
PostgreSQL technical information
Last edited by GLSA on Wed Jun 27, 2007 4:18 am; edited 2 times in total