Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cant emerge update because of gentoo-sources mask
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
retroman
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 207
Location: Stuttgart

PostPosted: Thu Jul 06, 2006 12:16 pm    Post subject: cant emerge update because of gentoo-sources mask Reply with quote

cant seem to do updates anymore becuase of this error. I checked package mask and no sign of any masking...


ultra60 ~ # cat /usr/portage/profiles/package.mask |grep sources
sys-kernel/kurobox-sources
=sys-kernel/rsbac-sources-2.6.99
=sys-kernel/rsbac-sources-2.4.99
sys-kernel/openblocks-sources
<sys-kernel/xen-sources-2.6.14
<sys-kernel/xen-sources-2.6.16
<=sys-kernel/openmosix-sources-2.4.30
>=sys-kernel/openmosix-sources-2.5



Quote:

Calculating dependencies
!!! All ebuilds that could satisfy "gentoo-sources" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-kernel/gentoo-sources-2.6.15-r7 (masked by: package.mask, ~sparc keyword)
# Gustavo Zacarias <gustavoz@gentoo.org>
# We mask core 2.6 stuff to avoid bootstrap issues


- sys-kernel/gentoo-sources-2.6.14-r7 (masked by: package.mask, missing keyword)
- sys-kernel/gentoo-sources-2.4.31-r1 (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.4.32-r5 (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.6.15-r1 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r10 (masked by: package.mask)
- sys-kernel/gentoo-sources-2.6.17 (masked by: package.mask)
- sys-kernel/gentoo-sources-2.6.16 (masked by: package.mask, missing keyword)
- sys-kernel/gentoo-sources-2.6.15-r8 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r7 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r6 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r5 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r4 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r3 (masked by: package.mask, missing keyword)
- sys-kernel/gentoo-sources-2.6.16-r2 (masked by: package.mask, missing keyword)
- sys-kernel/gentoo-sources-2.6.16-r1 (masked by: package.mask, missing keyword)
- sys-kernel/gentoo-sources-2.4.32-r4 (masked by: missing keyword)
- sys-kernel/gentoo-sources-2.6.16-r9 (masked by: package.mask, ~sparc keyword)
- sys-kernel/gentoo-sources-2.6.16-r8 (masked by: package.mask, ~sparc keyword)








any ideas???
Back to top
View user's profile Send private message
NaiL
Apprentice
Apprentice


Joined: 13 Feb 2003
Posts: 223
Location: Spain/BCN

PostPosted: Thu Jul 06, 2006 12:30 pm    Post subject: Reply with quote

maybe it's in /etc/portage/package.mask ?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Thu Jul 06, 2006 2:18 pm    Post subject: Reply with quote

Make sure you are using a 2.6 profile and not a 2.4 profile. For instance, if /etc/make.profile points to /usr/portage/profiles/default-linux/sparc/sparc64/2006.0/2.4, then you're using a 2.4 profile. If you want a 2.6 profile, change /etc/make.profile to point to /usr/portage/profiles/default-linux/sparc/sparc64/2006.0
Back to top
View user's profile Send private message
retroman
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 207
Location: Stuttgart

PostPosted: Fri Jul 07, 2006 10:25 am    Post subject: Solved Reply with quote

thanx
that worked
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum