Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Raid 5 crash. Plz help recovery
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
testlab
n00b
n00b


Joined: 06 Dec 2005
Posts: 15

PostPosted: Wed Jul 05, 2006 7:00 am    Post subject: Raid 5 crash. Plz help recovery Reply with quote

Hi All.

Gentoo decided to die on me yesterday. All was working fine (doing a telnet to my box from work and all ok) but unzipping a file it just stopped. I tried to re-connect and nothing. Checked when I got home and it had frozen on me. couldn't do a thing. So I ended up hitting the reset button (no other option).

Computer got back up ok, but the RAID does not work.

Bit of background on my RAID 5. 3 SATA hard drives sda, sdb, sdc (160gb each). This is what I've tried so far. Any help appreciated guys

---
mdadm --detail --scan
ARRAY /dev/md0 level=raid5 num-devices=3 UUID=dc846665:f54ebd97:88a939ab:112d9d65
---
mdadm --detail /dev/md0
/dev/md0:
Version : 00.90.03
Creation Time : Fri Apr 21 23:07:17 2006
Raid Level : raid5
Device Size : 156288256 (149.05 GiB 160.04 GB)
Raid Devices : 3
Total Devices : 2
Preferred Minor : 0
Persistence : Superblock is persistent

Update Time : Tue Jul 4 16:24:29 2006
State : active, degraded
Active Devices : 2
Working Devices : 2
Failed Devices : 0
Spare Devices : 0

Layout : left-symmetric
Chunk Size : 32K

UUID : dc846665:f54ebd97:88a939ab:112d9d65
Events : 0.4493881

Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
1 8 17 1 active sync /dev/sdb1
2 0 0 - removed
---
raidhotadd /dev/md0 /dev/sdc1
/dev/md0: can not hot-add disk: array not running!
---
mdadm -As /dev/md0
mdadm: device /dev/md0 already active - cannot assemble it
---
TRIED THIS INSTEAD OF RAIDHOTADD
mdadm /dev/md0 --add /dev/sdc1
mdadm: added /dev/sdc1
--- THEN CHECK THE STATUS BUT IT ALWAYS STAYS AT (REBUILDING). Left it for a day or so but no luck
mdadm --detail /dev/md0
Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
1 8 17 1 active sync /dev/sdb1
2 8 33 2 spare rebuilding /dev/sdc1
Back to top
View user's profile Send private message
testlab
n00b
n00b


Joined: 06 Dec 2005
Posts: 15

PostPosted: Wed Jul 05, 2006 8:54 am    Post subject: Reply with quote

Re-created the RAID and seemed to work (as explained here)

http://groups.google.co.uk/group/mlist.linux.raid/browse_thread/thread/78669e9d8553a743/9a2526a0f8bfd049?lnk=st&q=raid5%3A+cannot+start+dirty+degraded+array&rnum=2&hl=en#9a2526a0f8bfd049
Back to top
View user's profile Send private message
testlab
n00b
n00b


Joined: 06 Dec 2005
Posts: 15

PostPosted: Wed Jul 05, 2006 1:18 pm    Post subject: Reply with quote

hi, that did seem to help recovering the disk, but can't mount the drive now. I get


mount: /dev/md0: can't read superblock
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum