Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Voikko - Vapaa soikko
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
Juippisi
Apprentice
Apprentice


Joined: 30 Sep 2005
Posts: 171
Location: /home

PostPosted: Wed Feb 08, 2017 4:41 pm    Post subject: Reply with quote

Olen pitänyt voikkoa päivitettynä ja ainakin itselläni toimii vielä, ja tänään pystytin Github-accountin joten muutkin voi kokeilla:
https://github.com/juippis/jps-gentoo

Code:
layman -a jps-gentoo

emerge -av libreoffice-voikko
Back to top
View user's profile Send private message
Zucca
l33t
l33t


Joined: 14 Jun 2007
Posts: 953
Location: KUUSANKOSKI, Finland

PostPosted: Sun Feb 12, 2017 4:57 pm    Post subject: Reply with quote

Kiitosta. Vetäsen nuo tolle desktoppikoneelle jossa on ~amd64.
Jos muistan, niin annan myös palautetta. :P
Back to top
View user's profile Send private message
emagdnim
n00b
n00b


Joined: 03 Sep 2015
Posts: 2

PostPosted: Thu Apr 20, 2017 4:36 pm    Post subject: Reply with quote

Juippisi wrote:
Olen pitänyt voikkoa päivitettynä ja ainakin itselläni toimii vielä, ja tänään pystytin Github-accountin joten muutkin voi kokeilla:
https://github.com/juippis/jps-gentoo

Code:
layman -a jps-gentoo

emerge -av libreoffice-voikko


Kiitos!
Back to top
View user's profile Send private message
passst
n00b
n00b


Joined: 25 Apr 2016
Posts: 3

PostPosted: Sun Nov 05, 2017 10:28 am    Post subject: eapply_user herjaa Reply with quote

Moi,

yritin äsken asentaa voikkoa uudelle läppärille. Dev-libs/foma kohdalla herjaa, että
Quote:
ERROR: dev-libs/foma-0.9.18::jps-gentoo failed (prepare phase):
* eapply_user (or default) must be called in src_prepare()!


Osaako kukaan sanoa, mistä johtuu? Vai onkohan toi dev-libs/foman ebuild vielä ajan tasalla?
Ilmeisesti EAPI=6 määrittelee ton eapply_userin pakolliseksi, jos nyt oikein ymmärsin...
Tosin itsellä ei ole kokemusta ebuildien tekemisestä,
Googlen haku vain sylkäs linkin tonne Gentoon EAPI-ohjeisiin...



T: Patrick
Back to top
View user's profile Send private message
Juippisi
Apprentice
Apprentice


Joined: 30 Sep 2005
Posts: 171
Location: /home

PostPosted: Mon Nov 06, 2017 9:41 am    Post subject: Reply with quote

Moi!

Kävin muutama viikko sitten ebuildit Repomanin avulla läpi ja silloin tuli päiviteltyä nuo EAPIt, mutta se ei herjannut tuosta eapply_userin tai defaultin puuttumisesta mitään. Ne tarvitaan nykyään aina kun src_preparen alla tekee jotain.

Korjasin tuon foma-0.9.18 ebuildin ja koitin kahdella koneella, että se nyt toimii. Käänsin myös voikko-fi:n ja libreoffice-voikko -paketin ja testasin, että ne toimivat Libreofficessa. Eli seuraavan syncin tai layman -S -komennon jälkeen pitäisi onnistua libreoffice-voikko -paketin asennus!

Kiitos palautteesta!
Back to top
View user's profile Send private message
passst
n00b
n00b


Joined: 25 Apr 2016
Posts: 3

PostPosted: Tue Nov 07, 2017 10:47 am    Post subject: Reply with quote

Superb!


Nyt pelittää...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum