Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SLVD] Broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgij.la
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
palantir
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Trento, Italia

PostPosted: Thu Jun 29, 2006 7:21 pm    Post subject: [SLVD] Broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgij.la Reply with quote

I have switched to GCC 4.1.1. Following the howto in the wiki, I have done emerge -e system and emerge -e world. After this, however, revdep-rebuild keeps telling me that GCC is broken, and tries to recompile it. I have done so already twice, but it continues to tell it's broken.

The exact message of revdep-rebuild is:

Code:

Checking dynamic linking consistency...
  (some messages about openoffice and two about libquicktime)
  broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgij.la (requires /usr/lib/libgcj.la)
 done.


Then it tries to emerge sys-devel/gcc-4.1.1.

What's wrong? Is this a problem?


Last edited by palantir on Fri Jun 30, 2006 4:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Maleita
Apprentice
Apprentice


Joined: 16 Sep 2004
Posts: 243
Location: Brasil -> São Paulo->Campinas

PostPosted: Fri Jun 30, 2006 2:42 am    Post subject: Reply with quote

http://www.gentoo.org/doc/pt_br/gcc-upgrading.xml
Back to top
View user's profile Send private message
palantir
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Trento, Italia

PostPosted: Fri Jun 30, 2006 7:02 am    Post subject: Reply with quote

And?

I have followed that guide to upgrade, and I don't see the solution to my problem. Unless I have missed something.
Back to top
View user's profile Send private message
Guinpen
Guru
Guru


Joined: 08 Dec 2004
Posts: 393

PostPosted: Fri Jun 30, 2006 11:32 am    Post subject: Reply with quote

I get the same thing, and the upgrade guide doesn't even mention it:
Code:
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgcjawt.la (requires /usr/lib/lib-gnu-java-awt-peer-gtk.la)
  broken /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgij.la (requires /usr/lib/libgcj.la)
  broken /usr/lib/gcc/i686-pc-linux-gnu/4.2.0-alpha20060603/libgij.la (requires /usr/lib/libgcj.la)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -p =sys-devel/gcc-4.1.1 =sys-devel/gcc-4.2.0_alpha20060603


This has been for months using several 4.* versions of gcc. Is disabling the gcj USE flag the only way to fix this?
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Fri Jun 30, 2006 1:39 pm    Post subject: Reply with quote

bug 125728
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
palantir
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2003
Posts: 142
Location: Trento, Italia

PostPosted: Fri Jun 30, 2006 4:55 pm    Post subject: Reply with quote

I see... I always searched the bugzilla using the main page, and it always returns zarro bugs... because it searches in the summary only and not in the comments 8-) Next time I'll check them as well.

Thanks for the reply, marking as solved...
Back to top
View user's profile Send private message
necrose
n00b
n00b


Joined: 02 Nov 2004
Posts: 14

PostPosted: Sat Jul 01, 2006 2:04 am    Post subject: GCC Woes Reply with quote

I'm Trying to get a full gcc Emerge

Use="libffi gcj fortan objc obj-c++ g++ libada ada" unfortunaly Ebuilds are preventing me from setting this

hoping to set .use or something to force any GCC to emerge all commmon relivent libs and languages..

I like windowmaker and Gnustep- (req Objc and libffi) for doing baseline matences over KDE and Gnome
I like KDE gnome etc ; but if Doing Emerge form an Xterm my screen gets an acid trippy look do to Xorg server and Nvida defect in driver
even if you can exit to standard console its: gijangijngjrngprgngojhjrnhgn/#/


I hate having to emerge then re-emerge just to get what I want.

system is a ye-old Althlon for the moment with 1 gig and 3.5 gis swap.

Just Looking to force My gcc ./configure options so all futre Gcc builds and updates use 1 hour compiles and done have to keep burning hours emerging over again.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Sun Feb 18, 2007 10:38 am    Post subject: Reply with quote

This has been discussed in topic: "Persistent revdep-rebuild issues: gcc and libgcj.la".

Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum