Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mdns, login problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
keba
Guru
Guru


Joined: 02 Jun 2006
Posts: 304
Location: Switzerland

PostPosted: Thu Jun 29, 2006 8:01 am    Post subject: mdns, login problem Reply with quote

Hey Guys,

I know this has been asked before but I really don't know what to do. I set up a Gentoo box that work perfectly, then I did a
Code:
emerge --update --deep --newuse world
and I couldn't login afterwards, the PC showing me there was a wron line in /etc/host.conf:
Code:
line 24: wrong line: "mdns off"

So I searched the forum and I read I had to
Code:
etc-update
and choose the "-5" option. That's what I did booting from the liveCD and chrooting, after which I rebooted back to the system on the HD. The "error" line didn't show up again, but I can't log in. When I type ANY username, it takes ages and then shows me the login message again without asking for the password.
What can I do? Please help me... THX
_________________
Prayer can change the world!
Back to top
View user's profile Send private message
phorn
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2006
Posts: 109

PostPosted: Sun Jul 02, 2006 10:29 am    Post subject: Reply with quote

The "mdns" problem happened after a recent upgrade to a package, which occurs when you forget to etc-update, however it won't cause the login problem.

The not logging in sounds like a PAM (pluggable authentication modules) problem.

When you do an etc-update, make sure that *all* the files in /etc/pam.d are up-to-date, as they will allow you to login.

If you cannot login as root, you will need to boot into single user mode. To do this, type "gentoo single" at the boot prompt.

Then you will have to look at making sure you have the right pam.d files.

You should try re-emerging shadow and possibly libpam. Then make sure to do an etc-update.

(I have never used the -5 option -- I go through each file and hit 1 to confirm replace.)
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4726
Location: Angra do Heroísmo (PT)

PostPosted: Fri Aug 11, 2006 3:16 pm    Post subject: Reply with quote

Moved from Networking & Security to Duplicate Threads.

[mod]Moved this thread in favour of this one. Your login problem was likely caused by removing pam-login, but forgetting to re-emerge shadow.[/mod]
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum