Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
In case anyone can't get Lilypond emacs mode working..
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
ShaneK
n00b
n00b


Joined: 05 Mar 2006
Posts: 4
Location: Lancaster, PA

PostPosted: Wed Jun 28, 2006 11:47 pm    Post subject: In case anyone can't get Lilypond emacs mode working.. Reply with quote

Here's what fixed it for me. I first verified that:

lilypond-font-lock.el
lilypond-indent.el
lilypond-init.el
lilypond-mode.el
lilypond-what-beat.el
lilypond-words.el

were in /usr/share/emacs/site-lisp/

then I copied the following from lilypond-init.el into my ~/.emacs file:

(autoload 'LilyPond-mode "lilypond-mode" "LilyPond Editing Mode" t)
(add-to-list 'auto-mode-alist '("\\.ly$" . LilyPond-mode))
(add-to-list 'auto-mode-alist '("\\.ily$" . LilyPond-mode))
(add-hook 'LilyPond-mode-hook (lambda () (turn-on-font-lock)))

now the menu items and syntax highlighting work. Enjoy
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Jun 29, 2006 5:26 am    Post subject: Reply with quote

Moved from Multimedia to Documentation, Tips & Tricks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum