Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia-
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
eleanor
l33t
l33t


Joined: 01 Nov 2004
Posts: 664

PostPosted: Tue Jun 27, 2006 10:39 am    Post subject: x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia- Reply with quote

I have some problems. Look at this:

Quote:
localhost eleanor # emerge -e world -pv

These are the packages that would be merged, in order:

Calculating world dependencies ... done!
[blocks B ] >=x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia-glx-1.0.7167-r3)



Quote:
emerge -s xorg-server
Searching... s
[ Results for search key : xorg-server ]
[ Applications found : 1 ]

* x11-base/xorg-server
Latest version available: 1.1.0-r1
Latest version installed: 1.1.0-r1
Size of files: 9,165 kB
Homepage: http://xorg.freedesktop.org/
Description: X.Org X servers
License: xorg-server MIT



Quote:
media-video/nvidia-glx
Latest version available: 1.0.7167-r3
Latest version installed: [ Not Installed ]
Size of files: 17,711 kB
Homepage: http://www.nvidia.com/
Description: NVIDIA X11 driver and GLX libraries
License: NVIDIA

* media-video/nvidia-kernel
Latest version available: 1.0.7167-r1
Latest version installed: [ Not Installed ]
Size of files: 17,711 kB
Homepage: http://www.nvidia.com/
Description: Linux kernel module for the NVIDIA X11 driver
License: NVIDIA



Quote:
localhost eleanor # cat /etc/portage/package.mask
>=x11-base/xorg-x11-7.1
>=x11-base/xorg-server-1.0.99
>=x11-base/xorg-server-1.1.0-r1
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-drivers/xf86-input-mouse-1.1.0
>=x11-drivers/xf86-input-joystick-1.1.0
>=x11-drivers/xf86-input-spaceorb-1.1.0
>=x11-drivers/xf86-input-summa-1.1.0
>=x11-drivers/xf86-input-elo2300-1.1.0
>=x11-drivers/xf86-input-elographics-1.1.0
>=x11-drivers/xf86-input-jamstudio-1.1.0
>=x11-drivers/xf86-input-palmax-1.1.0
>=x11-drivers/xf86-input-dynapro-1.1.0
>=x11-drivers/xf86-input-ur98-1.1.0
>=x11-drivers/xf86-input-evdev-1.1.2-r1
>=x11-drivers/xf86-input-citron-2.2.0
>=x11-drivers/xf86-input-hyperpen-1.1.0
>=x11-drivers/xf86-input-aiptek-1.0.1
>=x11-drivers/xf86-input-calcomp-1.1.0
>=x11-drivers/xf86-input-void-1.1.0
>=x11-drivers/xf86-input-digitaledge-1.1.0
>=x11-drivers/xf86-input-microtouch-1.1.0
>=x11-drivers/xf86-input-dmc-1.1.0
>=x11-drivers/xf86-input-fpit-1.1.0
>=x11-drivers/xf86-input-penmount-1.2.0
>=x11-drivers/xf86-input-penmount-1.1.0
>=x11-drivers/xf86-input-mutouch-1.1.0
>=x11-drivers/xf86-input-tek4957-1.1.0
>=x11-drivers/xf86-input-acecad-1.1.0
>=x11-drivers/xf86-input-magellan-1.1.0
>=media-video/nvidia-glx-1.0.7174-r5
>=media-video/nvidia-kernel-1.0.7174-r2
>=media-video/nvidia-settings-1.0.7167
>=x11-base/xorg-x11-7.1
>=x11-base/xorg-server-1.0.99
>=x11-drivers/xf86-input-keyboard-1.1.0
>=x11-drivers/xf86-input-mouse-1.1.0
>=x11-drivers/xf86-input-joystick-1.1.0



Can somebody help me?
Back to top
View user's profile Send private message
gami
Apprentice
Apprentice


Joined: 02 Jun 2006
Posts: 297

PostPosted: Tue Jun 27, 2006 1:17 pm    Post subject: Reply with quote

This is a common problem. Look at this topic for more information.
Back to top
View user's profile Send private message
eleanor
l33t
l33t


Joined: 01 Nov 2004
Posts: 664

PostPosted: Thu Jun 29, 2006 9:48 am    Post subject: Reply with quote

I don't even have xorg-server-1.0.99 installed:

Quote:
* x11-base/xorg-server
Latest version available: 1.1.0-r1
Latest version installed: 1.1.0-r1
Size of files: 9,165 kB
Homepage: http://xorg.freedesktop.org/
Description: X.Org X servers
License: xorg-server MIT
Back to top
View user's profile Send private message
gami
Apprentice
Apprentice


Joined: 02 Jun 2006
Posts: 297

PostPosted: Thu Jun 29, 2006 10:11 am    Post subject: Reply with quote

Look again at the original error message you got.
Quote:
localhost eleanor # emerge -e world -pv

These are the packages that would be merged, in order:

Calculating world dependencies ... done!
[blocks B ] >=x11-base/xorg-server-1.0.99 (is blocking media-video/nvidia-glx-1.0.7167-r3)


">=x11-base/xorg-server-1.0.99". You have xorg-server-1.1.0-r1 installed, which by Gentoo standards has a greater version number than xorg-server-1.0.99. Basically xorg-7.1 (and all packages it pulls in) is not compatible with nvidia drivers at the moment.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Jun 29, 2006 1:39 pm    Post subject: Reply with quote

Please follow up to the topic gami linked to.

Moved from Other Things Gentoo to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum