Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IBM T41 fails first boot's net connect: eth0 does not exist
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
pvgentoo
n00b
n00b


Joined: 09 Jul 2004
Posts: 42

PostPosted: Tue Jun 27, 2006 1:51 am    Post subject: IBM T41 fails first boot's net connect: eth0 does not exist Reply with quote

Hi,

I've got a fresh install of 2006.0 going. During initial installation, I successfully modprobe'd e1000 and got on the lan where the router assigned me a dhcp address, etc. and I finished the install. Since e1000 seemed to be the deal, I build the kernel with it included (*). Upon reboot, all seems well until the network tries to come up. I'll freehand copy what it says.

Quote:
Starting etho0
Bringing up eth0
dhcp
eth0 does not exist [!!]
ERROR: Problem starting needed services.
"netmount" was not started.
ERROR: Problem starting needed services.
"sshd" was not started.


Obviously this is problematic. If I check my kernel config, I see:

Code:
CONFIG_E1000=y
# CONFIG_E1000_NAPI is not set
# CONFIG_E1000_DISABLE_PACKET_SPLIT is not set


My /etc/conf.d/net effectively just says:
Code:
config_eth0=( "dhcp" )


dhcpcd is available.

Any ideas?

Phil
Back to top
View user's profile Send private message
tane_stelzer
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 263
Location: Edinburgh, Scotland and Kempen, Germany

PostPosted: Tue Jun 27, 2006 2:01 am    Post subject: Reply with quote

looks like you haven't enabled your ethernet card in your kernel, OR you have compiled it as module
if that is the case just
Code:
modprobe "module name"
nano /etc/modules.autoload.d/kernel-2.6
and add your ethernet card to that file. and reboot
Hope that helps
Tane
_________________
Quick Quide to Linux Commands!
MINI HOWTO Get Planeshift working
Back to top
View user's profile Send private message
pvgentoo
n00b
n00b


Joined: 09 Jul 2004
Posts: 42

PostPosted: Tue Jun 27, 2006 2:16 am    Post subject: Reply with quote

tane_stelzer wrote:
looks like you haven't enabled your ethernet card in your kernel, OR you have compiled it as module
if that is the case just
Code:
modprobe "module name"
nano /etc/modules.autoload.d/kernel-2.6
and add your ethernet card to that file. and reboot
Hope that helps
Tane


As I said, it was built into the kernel. However, it's apparent that something's amiss, and I've got time to kill, so I rebuilt the kernel with E1000 as a module and included it in said faile. It failed to load and, subsequently, the same error occurs.

So, I tried the autoload with 'e1000' instead. Let's see.....

ok - it loaded and came up ok this time. Yee haw!

ping yahoo. All is go!

I still don't see why it didn't work as a built-in. Go figure. Now to figure-out wireless.

Cheers and thanks!
Phil
Back to top
View user's profile Send private message
tane_stelzer
Apprentice
Apprentice


Joined: 30 Dec 2005
Posts: 263
Location: Edinburgh, Scotland and Kempen, Germany

PostPosted: Tue Jun 27, 2006 8:51 am    Post subject: Reply with quote

Well personally i like to have all my hardware to be compiled as modules. Maybe just me being stupid :lol:
But glad it helped. Maybe its just a bug in the current kernel, you might wanna think of submiting it.
Tane
_________________
Quick Quide to Linux Commands!
MINI HOWTO Get Planeshift working
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum